aboutsummaryrefslogtreecommitdiff
path: root/multimedia/pwcbsd/Makefile
diff options
context:
space:
mode:
authorSergey Matveychuk <sem@FreeBSD.org>2006-04-29 13:47:23 +0000
committerSergey Matveychuk <sem@FreeBSD.org>2006-04-29 13:47:23 +0000
commitbe0b65d43e41e2f783fa63a4c8c23012d0dab3ca (patch)
tree366196898a698341960ae80c0e3e6d7a1281ede9 /multimedia/pwcbsd/Makefile
parentc7179e5ec519e492a0de9e204eae8b68445611fa (diff)
downloadports-be0b65d43e41e2f783fa63a4c8c23012d0dab3ca.tar.gz
ports-be0b65d43e41e2f783fa63a4c8c23012d0dab3ca.zip
This port provides a FreeBSD kernel module that
video4linux enabled and raw yuv420p applications can use to access several USB based webcams. WWW: http://www.saillard.org/linux/pwc/ PR: ports/93464 Submitted by: Raaf <raaf@luna.afraid.org>
Notes
Notes: svn path=/head/; revision=160766
Diffstat (limited to 'multimedia/pwcbsd/Makefile')
-rw-r--r--multimedia/pwcbsd/Makefile65
1 files changed, 65 insertions, 0 deletions
diff --git a/multimedia/pwcbsd/Makefile b/multimedia/pwcbsd/Makefile
new file mode 100644
index 000000000000..0e2a71d78051
--- /dev/null
+++ b/multimedia/pwcbsd/Makefile
@@ -0,0 +1,65 @@
+# New ports collection makefile for: pwcbsd
+# Date created: 17 Feb 2006
+# Whom: Raaf <freebsd@luna.afraid.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= pwcbsd
+PORTVERSION= 1.0
+CATEGORIES= multimedia sysutils
+MASTER_SITES= http://raaf.atspace.org/
+
+MAINTAINER= freebsd@luna.afraid.org
+COMMENT= The Linux pwc webcam driver ported to FreeBSD
+
+MAN4= pwc.4
+
+WRKSRC= ${WRKDIR}/${PORTNAME}
+NO_PACKAGE= should be recompiled for a particular FreeBSD kernel
+
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} < 504000
+IGNORE= requires FreeBSD 5.4 or superior
+.endif
+
+.if !exists(/usr/src/sys/Makefile)
+IGNORE= requires kernel source files
+.endif
+
+.if !defined(WITHOUT_PROGRAMS)
+ALL_TARGET= all pwcview
+PROGRAMS= pwcview
+MAN1= pwcview.1
+USE_SDL= sdl
+PLIST_SUB+= PROGRAMS=""
+.else
+PLIST_SUB+= PROGRAMS="@comment "
+.endif
+
+pre-everything::
+.if !defined(WITHOUT_PROGRAMS)
+ @${ECHO_MSG} "=================================================="
+ @${ECHO_MSG} "You may specify the following on the command line:"
+ @${ECHO_MSG} ""
+ @${ECHO_MSG} "WITHOUT_PROGRAMS=yes to only build the driver "
+ @${ECHO_MSG} "=================================================="
+.endif
+
+post-patch:
+.if !defined(WITHOUT_PROGRAMS)
+ @${REINPLACE_CMD} -e 's|sdl11-config|${SDL_CONFIG}|g' ${WRKSRC}/Makefile
+.endif
+
+post-install:
+ ${MKDIR} ${PREFIX}/include/linux
+ ${INSTALL_DATA} ${WRKSRC}/videodev.h ${PREFIX}/include/linux
+ ${INSTALL_MAN} ${MAN4:S|^|${WRKSRC}/|} ${PREFIX}/man/man4
+.if !defined(WITHOUT_PROGRAMS)
+ ${INSTALL_PROGRAM} ${PROGRAMS:S|^|${WRKSRC}/|} ${PREFIX}/bin
+ ${INSTALL_MAN} ${MAN1:S|^|${WRKSRC}/|} ${PREFIX}/man/man1
+.endif
+ @${CAT} ${PKGMESSAGE}
+
+.include <bsd.port.post.mk>