aboutsummaryrefslogtreecommitdiff
path: root/multimedia/qdvdauthor
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2005-02-25 23:52:10 +0000
committerPav Lucistnik <pav@FreeBSD.org>2005-02-25 23:52:10 +0000
commitd13ca8fee420c45ad7d9aa448bc99392f3528771 (patch)
treea02e3a2d64c955faf26550072961baf22f22edf1 /multimedia/qdvdauthor
parentf2e1fac7689773db8168074e6666c1af7b7ff624 (diff)
downloadports-d13ca8fee420c45ad7d9aa448bc99392f3528771.tar.gz
ports-d13ca8fee420c45ad7d9aa448bc99392f3528771.zip
- Update to 0.0.9
PR: ports/78002 Submitted by: Phil Oleson <oz@nixil.net> (maintainer)
Notes
Notes: svn path=/head/; revision=129811
Diffstat (limited to 'multimedia/qdvdauthor')
-rw-r--r--multimedia/qdvdauthor/Makefile81
-rw-r--r--multimedia/qdvdauthor/distinfo4
-rw-r--r--multimedia/qdvdauthor/files/patch-configure36
-rw-r--r--multimedia/qdvdauthor/files/patch-qdvdauthor-qdvdauthor.pro22
-rw-r--r--multimedia/qdvdauthor/files/patch-qdvdauthor-qplayer-engines-qxinewidget.h10
-rw-r--r--multimedia/qdvdauthor/files/patch-qdvdauthor-qplayer-mediacreator.cpp20
-rw-r--r--multimedia/qdvdauthor/files/patch-qdvdauthor-qplayer-qplayer.pro19
-rw-r--r--multimedia/qdvdauthor/files/patch-qdvdauthor-qplayer-qxinewidget.h10
8 files changed, 185 insertions, 17 deletions
diff --git a/multimedia/qdvdauthor/Makefile b/multimedia/qdvdauthor/Makefile
index 982757bbe7c6..782250a71cdc 100644
--- a/multimedia/qdvdauthor/Makefile
+++ b/multimedia/qdvdauthor/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= qdvdauthor
-PORTVERSION= 0.0.8
-PORTREVISION= 1
+PORTVERSION= 0.0.9
CATEGORIES= multimedia
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE_EXTENDED}
MASTER_SITE_SUBDIR= ${PORTNAME}
@@ -18,7 +17,6 @@ COMMENT= QT graphical frontend for dvdauthor
BUILD_DEPENDS= dvdauthor:${PORTSDIR}/multimedia/dvdauthor \
mpeg2enc:${PORTSDIR}/multimedia/mjpegtools \
qmake:${PORTSDIR}/devel/qmake
-LIB_DEPENDS= xine.12:${PORTSDIR}/multimedia/libxine
RUN_DEPENDS= dvdauthor:${PORTSDIR}/multimedia/dvdauthor \
mpeg2enc:${PORTSDIR}/multimedia/mjpegtools
@@ -31,13 +29,86 @@ USE_X_PREFIX= yes
USE_QT_VER= 3
QT_NONSTANDARD= yes
CONFIGURE_ENV= QMAKESPEC=${LOCALBASE}/share/qt/mkspecs/freebsd-g++
-CONFIGURE_ARGS= --qt-dir=${X11BASE} --with-xine-lib \
+CONFIGURE_ARGS= --prefix=${PREFIX} --qt-dir=${X11BASE} --with-qt-lib=qt-mt \
--build-qslideshow --build-qplayer
NO_BUILD= yes
+OPTIONS= NETPBM "Create mpeg2 streams for movie menus" on \
+ MJPEGTOOLS "Convert background images into mpeg2 movie" on \
+ CDRTOOLS "Create iso images of DVD on the Hard Drive" on \
+ TRANSCODE "Support for movie format conversion" on \
+ DVDSLIDE "Creates slideshow-style dvd with menus" on \
+ DVDRWTOOLS "Optional DVD recording/burning prog" off \
+ MPLAYER "Optional support for mplayer playback" off \
+ TOOLAME "Optional support for audio conversion" off \
+ MCTOOLAME "Optional support for audio conversion" off
+
+.include <bsd.port.pre.mk>
+
+.if exists(${LOCALBASE}/bin/pngtopnm)
+WITH_NETPBM=yes
+.endif
+.if exists(${LOCALBASE}/bin/mpeg2enc)
+WITH_MJPEGTOOLS=yes
+.endif
+.if exists(${LOCALBASE}/bin/mkisofs)
+WITH_CDRTOOLS=yes
+.endif
+.if exists(${LOCALBASE}/bin/dvd-slideshow)
+WITH_DVDSLIDE=yes
+.endif
+.if exists(${LOCALBASE}/bin/growisofs)
+WITH_DVDRWTOOLS=yes
+.endif
+.if exists(${LOCALBASE}/bin/mplayer)
+WITH_MPLAYER=yes
+.endif
+.if exists(${LOCALBASE}/bin/transcode)
+WITH_TRANSCODE=yes
+.endif
+.if exists(${LOCALBASE}/bin/toolame)
+WITH_TOOLAME=yes
+.endif
+.if exists(${LOCALBASE}/bin/mctoolame)
+WITH_MCTOOLAME=yes
+.endif
+
+.if !defined(WITHOUT_NETPBM)
+RUN_DEPENDS+= pngtopnm:${PORTSDIR}/graphics/netpbm
+.endif
+.if !defined(WITHOUT_MJPEGTOOLS)
+RUN_DEPENDS+= mpeg2enc:${PORTSDIR}/multimedia/mjpegtools
+.endif
+.if !defined(WITHOUT_CDRTOOLS)
+RUN_DEPENDS+= mkisofs:${PORTSDIR}/sysutils/cdrtools
+.endif
+.if !defined(WITHOUT_DVDSLIDE)
+RUN_DEPENDS+= dvd-slideshow:${PORTSDIR}/multimedia/dvd-slideshow
+.endif
+.if defined(WITH_DVDRWTOOLS)
+RUN_DEPENDS+= growisofs:${PORTSDIR}/sysutils/dvd+rw-tools
+.endif
+.if !defined(WITHOUT_LIBXINE)
+LIB_DEPENDS+= xine.12:${PORTSDIR}/multimedia/libxine
+CONFIGURE_ARGS+=--with-xine-support
+.endif
+.if defined(WITH_MPLAYER)
+RUN_DEPENDS+= mplayer:${PORTSDIR}/multimedia/mplayer
+CONFIGURE_ARGS+=--with-mplayer-support
+.endif
+.if !defined(WITHOUT_TRANSCODE)
+RUN_DEPENDS+= transcode:${PORTSDIR}/multimedia/transcode
+.endif
+.if defined(WITH_TOOLAME)
+RUN_DEPENDS+= toolame:${PORTSDIR}/audio/toolame
+.endif
+.if defined(WITH_MCTOOLAME)
+RUN_DEPENDS+= mctoolame:${PORTSDIR}/audio/mctoolame-encoder
+.endif
+
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/bin/qdvdauthor ${PREFIX}/bin/qdvdauthor
${INSTALL_PROGRAM} ${WRKSRC}/bin/qslideshow ${PREFIX}/bin/qslideshow
${INSTALL_PROGRAM} ${WRKSRC}/bin/qplayer ${PREFIX}/bin/qplayer
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/multimedia/qdvdauthor/distinfo b/multimedia/qdvdauthor/distinfo
index dfd6960bef12..8dc61c4f9188 100644
--- a/multimedia/qdvdauthor/distinfo
+++ b/multimedia/qdvdauthor/distinfo
@@ -1,2 +1,2 @@
-MD5 (qdvdauthor-0.0.8.tar.gz) = 40044fd97d7c42d09dbdeb4727b9534a
-SIZE (qdvdauthor-0.0.8.tar.gz) = 678802
+MD5 (qdvdauthor-0.0.9.tar.gz) = 465d888ef6f29162fe9b36ff8c49791c
+SIZE (qdvdauthor-0.0.9.tar.gz) = 913252
diff --git a/multimedia/qdvdauthor/files/patch-configure b/multimedia/qdvdauthor/files/patch-configure
index e69de29bb2d1..86326f89ed3a 100644
--- a/multimedia/qdvdauthor/files/patch-configure
+++ b/multimedia/qdvdauthor/files/patch-configure
@@ -0,0 +1,36 @@
+--- configure.orig Sat Feb 12 22:46:49 2005
++++ configure Mon Feb 14 20:39:36 2005
+@@ -295,20 +295,20 @@
+ esac;
+ done;
+ # Sanity check to make sure we have at least one media library ...
+- if [ $WITH_MPLAYER_SUPPORT$WITH_VLC_SUPPORT$WITH_XINE_SUPPORT == "000" ];
++ if [ $WITH_MPLAYER_SUPPORT$WITH_VLC_SUPPORT$WITH_XINE_SUPPORT -eq "000" ];
+ then
+ export WITH_XINE_SUPPORT=1
+ fi;
+ # Here we check for xine, or mplayer
+- if [ $WITH_XINE_SUPPORT == 1 ];
++ if [ $WITH_XINE_SUPPORT -eq 1 ];
+ then
+ check_xinelibs;
+ fi;
+- if [ $WITH_VLC_SUPPORT == 1 ];
++ if [ $WITH_VLC_SUPPORT -eq 1 ];
+ then
+ check_vlclibs;
+ fi;
+- if [ $WITH_MPLAYER_SUPPORT == 1 ];
++ if [ $WITH_MPLAYER_SUPPORT -eq 1 ];
+ then
+ check_mplayerlibs;
+ fi;
+@@ -316,7 +316,7 @@
+ # Next we write CONFIG.h
+ echo "#ifndef CONFIG_H" > qdvdauthor/CONFIG.h
+ echo "#define CONFIG_H" >> qdvdauthor/CONFIG.h
+- echo "#define PREFIX_DIRECTORY $PREFIX" >> qdvdauthor/CONFIG.h
++ echo "#define PREFIX_DIRECTORY \"$PREFIX\"" >> qdvdauthor/CONFIG.h
+ echo "#endif // CONFIG_H" >> qdvdauthor/CONFIG.h
+
+
diff --git a/multimedia/qdvdauthor/files/patch-qdvdauthor-qdvdauthor.pro b/multimedia/qdvdauthor/files/patch-qdvdauthor-qdvdauthor.pro
new file mode 100644
index 000000000000..a5b42e6655a3
--- /dev/null
+++ b/multimedia/qdvdauthor/files/patch-qdvdauthor-qdvdauthor.pro
@@ -0,0 +1,22 @@
+--- qdvdauthor/qdvdauthor.pro.orig Mon Feb 14 20:40:21 2005
++++ qdvdauthor/qdvdauthor.pro Mon Feb 14 20:40:39 2005
+@@ -29,19 +29,6 @@
+ isEmpty(WHICH_PREFIX) {
+ WHICH_PREFIX = /usr
+ }
+-# Here we create CONFIG.h according to the set-up ...
+-system (echo -e '\x23ifndef CONFIG_H' > CONFIG.h )
+-system (echo -e '\x23define CONFIG_H' >> CONFIG.h )
+-system (echo -e '\x23define PREFIX_DIRECTORY "$$WHICH_PREFIX"' >> CONFIG.h )
+-system (echo -e '\x23endif // CONFIG_H' >> CONFIG.h )
+-
+-# Next we create the MEDIA_CONFIG.h - file
+-system (echo -e '\x23ifndef MEDIA_CONFIG_H' > qplayer/MEDIA_CONFIG.h )
+-system (echo -e '\x23define MEDIA_CONFIG_H' >> qplayer/MEDIA_CONFIG.h )
+-contains ( HAS_MPLAYER_SUPPORT, 1 ) { system (echo -e '\x23define MPLAYER_SUPPORT $$(WITH_MPLAYER_SUPPORT)' >> qplayer/MEDIA_CONFIG.h ) }
+-contains ( HAS_XINE_SUPPORT, 1 ) { system (echo -e '\x23define XINE_SUPPORT $$(WITH_XINE_SUPPORT)' >> qplayer/MEDIA_CONFIG.h ) }
+-contains ( HAS_VLC_SUPPORT, 1 ) { system (echo -e '\x23define VLC_SUPPORT $$(WITH_VLC_SUPPORT)' >> qplayer/MEDIA_CONFIG.h ) }
+-system (echo -e '\x23endif // MEDIA_CONFIG_H' >> qplayer/MEDIA_CONFIG.h )
+
+ SOURCES += main.cpp\
+ utils.cpp \
diff --git a/multimedia/qdvdauthor/files/patch-qdvdauthor-qplayer-engines-qxinewidget.h b/multimedia/qdvdauthor/files/patch-qdvdauthor-qplayer-engines-qxinewidget.h
new file mode 100644
index 000000000000..a8565a552847
--- /dev/null
+++ b/multimedia/qdvdauthor/files/patch-qdvdauthor-qplayer-engines-qxinewidget.h
@@ -0,0 +1,10 @@
+--- qdvdauthor/qplayer/engines/qxinewidget.h.orig Wed Feb 16 02:14:23 2005
++++ qdvdauthor/qplayer/engines/qxinewidget.h Wed Feb 16 02:15:10 2005
+@@ -31,6 +31,7 @@
+ #include <qtimer.h>
+ #include <qevent.h>
+ #include <qthread.h>
++#include <pthread.h>
+
+ #include <xine.h>
+
diff --git a/multimedia/qdvdauthor/files/patch-qdvdauthor-qplayer-mediacreator.cpp b/multimedia/qdvdauthor/files/patch-qdvdauthor-qplayer-mediacreator.cpp
new file mode 100644
index 000000000000..5b93a8aecdd2
--- /dev/null
+++ b/multimedia/qdvdauthor/files/patch-qdvdauthor-qplayer-mediacreator.cpp
@@ -0,0 +1,20 @@
+--- qdvdauthor/qplayer/mediacreator.cpp.orig Mon Feb 14 20:53:57 2005
++++ qdvdauthor/qplayer/mediacreator.cpp Mon Feb 14 20:53:59 2005
+@@ -189,7 +189,7 @@
+ pParent = pParent;
+ pName = pName;
+ pExistingEngine = pExistingEngine;
+-#ifdef VLC_SUPPORT
++#if (VLC_SUPPORT == 1)
+ pMediaInterface = (MediaInterface *) new VLCWidget (pParent, "VLCPart", pExistingEngine);
+ #endif
+ return pMediaInterface;
+@@ -206,7 +206,7 @@
+ if (m_qsPreferredEngine == "QMPlayerWidget")
+ pInfo = (MediaInfo *) new MPlayerInfo (pVoid);
+ #endif
+-#ifdef VLC_SUPPORT
++#if (VLC_SUPPORT == 1)
+ if (m_qsPreferredEngine == "VLCWidget")
+ pInfo = (MediaInfo *) new VLCInfo (pVoid);
+ #endif
diff --git a/multimedia/qdvdauthor/files/patch-qdvdauthor-qplayer-qplayer.pro b/multimedia/qdvdauthor/files/patch-qdvdauthor-qplayer-qplayer.pro
new file mode 100644
index 000000000000..3b1324174552
--- /dev/null
+++ b/multimedia/qdvdauthor/files/patch-qdvdauthor-qplayer-qplayer.pro
@@ -0,0 +1,19 @@
+--- qdvdauthor/qplayer/qplayer.pro.orig Mon Feb 14 20:41:59 2005
++++ qdvdauthor/qplayer/qplayer.pro Mon Feb 14 20:42:05 2005
+@@ -25,16 +25,6 @@
+ CREATE_MEDIA_CONFIG = 1
+ }
+
+-# So the question is if we should create the MEDIA_CONFIG.h - file ?
+-contains (CREATE_MEDIA_CONFIG, 1) {
+-system (echo -e '\x23ifndef MEDIA_CONFIG_H' > MEDIA_CONFIG.h )
+-system (echo -e '\x23define MEDIA_CONFIG_H' >> MEDIA_CONFIG.h )
+-contains ( HAS_MPLAYER_SUPPORT, 1 ) { system (echo -e '\x23define MPLAYER_SUPPORT $$(WITH_MPLAYER_SUPPORT)' >> MEDIA_CONFIG.h ) }
+-contains ( HAS_XINE_SUPPORT, 1 ) { system (echo -e '\x23define XINE_SUPPORT $$(WITH_XINE_SUPPORT)' >> MEDIA_CONFIG.h ) }
+-contains ( HAS_VLC_SUPPORT, 1 ) { system (echo -e '\x23define VLC_SUPPORT $$(WITH_VLC_SUPPORT)' >> MEDIA_CONFIG.h ) }
+-system (echo -e '\x23endif // MEDIA_CONFIG_H' >> MEDIA_CONFIG.h )
+-}
+-
+ DISTFILES = README
+
+ SOURCES += qplayer.cpp \
diff --git a/multimedia/qdvdauthor/files/patch-qdvdauthor-qplayer-qxinewidget.h b/multimedia/qdvdauthor/files/patch-qdvdauthor-qplayer-qxinewidget.h
deleted file mode 100644
index 77c3b694728e..000000000000
--- a/multimedia/qdvdauthor/files/patch-qdvdauthor-qplayer-qxinewidget.h
+++ /dev/null
@@ -1,10 +0,0 @@
---- qdvdauthor/qplayer/qxinewidget.h.orig Fri Nov 5 14:56:16 2004
-+++ qdvdauthor/qplayer/qxinewidget.h Fri Nov 5 14:56:28 2004
-@@ -31,6 +31,7 @@
- #include <qtimer.h>
- #include <qevent.h>
- #include <qthread.h>
-+#include <pthread.h>
-
- #include <xine.h>
-