aboutsummaryrefslogtreecommitdiff
path: root/multimedia/sabbu
diff options
context:
space:
mode:
authorDirk Meyer <dinoex@FreeBSD.org>2008-05-04 09:46:09 +0000
committerDirk Meyer <dinoex@FreeBSD.org>2008-05-04 09:46:09 +0000
commit031ae7df5b35e2a6c70a335a86086ad340b6d106 (patch)
tree4532bbe862db28f392944b7052ad941f780db898 /multimedia/sabbu
parent64b7c92706a9603ce9932e59f0a8773d4f7687c5 (diff)
downloadports-031ae7df5b35e2a6c70a335a86086ad340b6d106.tar.gz
ports-031ae7df5b35e2a6c70a335a86086ad340b6d106.zip
- fix configure
Notes
Notes: svn path=/head/; revision=212586
Diffstat (limited to 'multimedia/sabbu')
-rw-r--r--multimedia/sabbu/Makefile2
-rw-r--r--multimedia/sabbu/files/patch-configure55
2 files changed, 53 insertions, 4 deletions
diff --git a/multimedia/sabbu/Makefile b/multimedia/sabbu/Makefile
index ff03f43c9a3d..9c8f73dcd138 100644
--- a/multimedia/sabbu/Makefile
+++ b/multimedia/sabbu/Makefile
@@ -7,7 +7,7 @@
PORTNAME= sabbu
PORTVERSION= 0.3.0
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= multimedia
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME}
diff --git a/multimedia/sabbu/files/patch-configure b/multimedia/sabbu/files/patch-configure
index 5aec633f3556..c69aa667cc5d 100644
--- a/multimedia/sabbu/files/patch-configure
+++ b/multimedia/sabbu/files/patch-configure
@@ -1,11 +1,60 @@
---- configure.orig Sun Nov 27 01:30:25 2005
-+++ configure Sun May 27 09:45:46 2007
-@@ -6320,6 +6320,8 @@
+--- configure.orig 2005-11-27 01:30:25.000000000 +0100
++++ configure 2008-05-04 10:42:17.000000000 +0200
+@@ -3222,6 +3222,7 @@
+ cat >>conftest.$ac_ext <<_ACEOF
+ /* end confdefs.h. */
+ $ac_declaration
++#include <stdlib.h>
+ int
+ main ()
+ {
+@@ -6277,6 +6278,7 @@
+ cat confdefs.h >>conftest.$ac_ext
+ cat >>conftest.$ac_ext <<_ACEOF
+ /* end confdefs.h. */
++#include <stdlib.h>
+ #include <ffmpeg/avformat.h>
+ int
+ main ()
+@@ -6320,6 +6322,9 @@
cat confdefs.h >>conftest.$ac_ext
cat >>conftest.$ac_ext <<_ACEOF
/* end confdefs.h. */
+
+#define __STDC_CONSTANT_MACROS
++#include <stdlib.h>
#include <ffmpeg/avformat.h>
int
main ()
+@@ -6385,6 +6390,7 @@
+ cat confdefs.h >>conftest.$ac_ext
+ cat >>conftest.$ac_ext <<_ACEOF
+ /* end confdefs.h. */
++#include <stdlib.h>
+ #include <iconv.h>
+ int
+ main ()
+@@ -6428,6 +6434,7 @@
+ cat confdefs.h >>conftest.$ac_ext
+ cat >>conftest.$ac_ext <<_ACEOF
+ /* end confdefs.h. */
++#include <stdlib.h>
+ #include <iconv.h>
+ int
+ main ()
+@@ -6912,6 +6919,7 @@
+ cat confdefs.h >>conftest.$ac_ext
+ cat >>conftest.$ac_ext <<_ACEOF
+ /* end confdefs.h. */
++#include <stdlib.h>
+ #include <ctype.h>
+ #if ((' ' & 0x0FF) == 0x020)
+ # define ISLOWER(c) ('a' <= (c) && (c) <= 'z')
+@@ -7550,6 +7558,7 @@
+ cat confdefs.h >>conftest.$ac_ext
+ cat >>conftest.$ac_ext <<_ACEOF
+ /* end confdefs.h. */
++#include <stdlib.h>
+ #include <ctype.h>
+ #if ((' ' & 0x0FF) == 0x020)
+ # define ISLOWER(c) ('a' <= (c) && (c) <= 'z')