aboutsummaryrefslogtreecommitdiff
path: root/multimedia/sabbu
diff options
context:
space:
mode:
authorDirk Meyer <dinoex@FreeBSD.org>2013-12-04 05:53:40 +0000
committerDirk Meyer <dinoex@FreeBSD.org>2013-12-04 05:53:40 +0000
commit7f137051020ef934494a5c2fc95b8b0de6887a3a (patch)
tree1f885c41d35cb1eb58a5594d69b899eb157a890e /multimedia/sabbu
parente04e2dcf3bce181f77a1dc3e9cdc427c965b1d91 (diff)
downloadports-7f137051020ef934494a5c2fc95b8b0de6887a3a.tar.gz
ports-7f137051020ef934494a5c2fc95b8b0de6887a3a.zip
- use STAGEDIR
- USES=gmake
Notes
Notes: svn path=/head/; revision=335604
Diffstat (limited to 'multimedia/sabbu')
-rw-r--r--multimedia/sabbu/Makefile18
1 files changed, 5 insertions, 13 deletions
diff --git a/multimedia/sabbu/Makefile b/multimedia/sabbu/Makefile
index 3ecfc7fe1e5e..f7c0da93ca44 100644
--- a/multimedia/sabbu/Makefile
+++ b/multimedia/sabbu/Makefile
@@ -10,13 +10,10 @@ MAINTAINER= dinoex@FreeBSD.org
COMMENT= Program used to time subtitles
LIB_DEPENDS= libavcodec0.so:${PORTSDIR}/multimedia/ffmpeg0 \
- sndfile:${PORTSDIR}/audio/libsndfile
+ libsndfile.so:${PORTSDIR}/audio/libsndfile
-NO_STAGE= yes
-
-USES= pkgconfig iconv
+USES= pkgconfig iconv gmake
USE_BZIP2= yes
-USE_GMAKE= yes
GNU_CONFIGURE= yes
USE_GNOME= gtk20
@@ -26,6 +23,8 @@ LDFLAGS+= -L${LOCALBASE}/lib/ffmpeg0 -L${LOCALBASE}/lib ${PTHREAD_LIBS} -lswscal
OPTIONS_DEFINE= GTKSPELL
OPTIONS_DEFAULT=GTKSPELL
+GTKSPELL_LIB_DEPENDS= libgtkspell.so:${PORTSDIR}/textproc/gtkspell
+
.include <bsd.port.options.mk>
.if ${PORT_OPTIONS:MNLS}
@@ -36,13 +35,6 @@ CONFIGURE_ARGS+= --disable-nls
PLIST_SUB+= WITH_NLS="@comment "
.endif
-.if ${PORT_OPTIONS:MGTKSPELL}
-LIB_DEPENDS+= gtkspell:${PORTSDIR}/textproc/gtkspell
-.else
-.endif
-
-.include <bsd.port.pre.mk>
-
.if ${ARCH} == "powerpc"
BROKEN= Does not configure on powerpc
.endif
@@ -55,4 +47,4 @@ post-patch:
-e 's,lavswscale,lavswscale0,g' \
${WRKSRC}/configure
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>