aboutsummaryrefslogtreecommitdiff
path: root/multimedia/smpeg
diff options
context:
space:
mode:
authorChris Piazza <cpiazza@FreeBSD.org>2000-02-03 04:57:35 +0000
committerChris Piazza <cpiazza@FreeBSD.org>2000-02-03 04:57:35 +0000
commit7719b4dc719ba120f0843b1f5ee413d70dd71343 (patch)
tree6384d3ef6a8ed6fde27dbc9db9be968ad2345edb /multimedia/smpeg
parentf12328cf33ae1b8ab90181185b9335f4e1ee2043 (diff)
downloadports-7719b4dc719ba120f0843b1f5ee413d70dd71343.tar.gz
ports-7719b4dc719ba120f0843b1f5ee413d70dd71343.zip
add smpeg.
SMPEG is a free, general purpose mpeg player that uses the SDL library. Combines the functionality of mpeg_play and splay. SMPEG is made by Loki Entertainment
Notes
Notes: svn path=/head/; revision=25443
Diffstat (limited to 'multimedia/smpeg')
-rw-r--r--multimedia/smpeg/Makefile24
-rw-r--r--multimedia/smpeg/distinfo1
-rw-r--r--multimedia/smpeg/pkg-comment1
-rw-r--r--multimedia/smpeg/pkg-descr4
-rw-r--r--multimedia/smpeg/pkg-plist16
5 files changed, 46 insertions, 0 deletions
diff --git a/multimedia/smpeg/Makefile b/multimedia/smpeg/Makefile
new file mode 100644
index 000000000000..c4e87749ac46
--- /dev/null
+++ b/multimedia/smpeg/Makefile
@@ -0,0 +1,24 @@
+# New ports collection makefile for: smpeg
+# Version required: 0.3.3
+# Date created: 2 Feb 2000
+# Whom: Chris Piazza <cpiazza@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+DISTNAME= smpeg-0.3.3
+CATEGORIES= graphics
+MASTER_SITES= http://www.lokigames.com/development/download/smpeg/
+
+MAINTAINER= cpiazza@FreeBSD.org
+
+LIB_DEPENDS= SDL-1.0.2:${PORTSDIR}/devel/sdl
+
+GTK_CONFIG= ${X11BASE}/bin/gtk12-config
+GNU_CONFIGURE= yes
+USE_GMAKE= yes
+CONFIGURE_ENV= GTK_CONFIG="${GTK_CONFIG}"
+
+MAN1= gtv.1 plaympeg.1
+
+.include <bsd.port.mk>
diff --git a/multimedia/smpeg/distinfo b/multimedia/smpeg/distinfo
new file mode 100644
index 000000000000..2211a2ea618d
--- /dev/null
+++ b/multimedia/smpeg/distinfo
@@ -0,0 +1 @@
+MD5 (smpeg-0.3.3.tar.gz) = fdd7e801890a491e6b26eaea8f4c1b1a
diff --git a/multimedia/smpeg/pkg-comment b/multimedia/smpeg/pkg-comment
new file mode 100644
index 000000000000..2c26ffa252d1
--- /dev/null
+++ b/multimedia/smpeg/pkg-comment
@@ -0,0 +1 @@
+A free MPEG player that supports video and audio.
diff --git a/multimedia/smpeg/pkg-descr b/multimedia/smpeg/pkg-descr
new file mode 100644
index 000000000000..34e560a04396
--- /dev/null
+++ b/multimedia/smpeg/pkg-descr
@@ -0,0 +1,4 @@
+SMPEG is a free, general purpose mpeg player that uses the
+SDL library. Combines the functionality of mpeg_play and splay.
+
+WWW: http://www.lokigames.com/development/smpeg.php3
diff --git a/multimedia/smpeg/pkg-plist b/multimedia/smpeg/pkg-plist
new file mode 100644
index 000000000000..b28aad8970e9
--- /dev/null
+++ b/multimedia/smpeg/pkg-plist
@@ -0,0 +1,16 @@
+bin/gtv
+bin/plaympeg
+include/smpeg/MPEG.h
+include/smpeg/MPEGaction.h
+include/smpeg/MPEGaudio.h
+include/smpeg/MPEGerror.h
+include/smpeg/MPEGring.h
+include/smpeg/MPEGstream.h
+include/smpeg/MPEGvideo.h
+include/smpeg/smpeg.h
+lib/libsmpeg-0.3.so
+lib/libsmpeg-0.3.so.0
+lib/libsmpeg.a
+lib/libsmpeg.la
+lib/libsmpeg.so
+@dirrm include/smpeg