aboutsummaryrefslogtreecommitdiff
path: root/multimedia/subtitleeditor
diff options
context:
space:
mode:
authorAndrew Pantyukhin <sat@FreeBSD.org>2007-01-08 03:49:07 +0000
committerAndrew Pantyukhin <sat@FreeBSD.org>2007-01-08 03:49:07 +0000
commite3dd1f9e6ca4cb60e906cc1303477757cd18fb21 (patch)
tree382b5c8f86582dcde44c3e205bedf98a5b1c39e1 /multimedia/subtitleeditor
parent46bd50407d900505c0151ad816f5c5f78b8ff18e (diff)
downloadports-e3dd1f9e6ca4cb60e906cc1303477757cd18fb21.tar.gz
ports-e3dd1f9e6ca4cb60e906cc1303477757cd18fb21.zip
Add port multimedia/subtitleeditor:
Subtitle Editor is a GTK+2 tool to edit subtitles. It can be used for new subtitles or as a tool to transform, edit, correct and refine existing subtitle. This program also shows sound waves, which makes it easier to synchronise subtitles to voices. WWW: http://kitone.free.fr/subtitleeditor/ Author: IDJAAD djamel <kitone_at_free_dot_fr>
Notes
Notes: svn path=/head/; revision=181745
Diffstat (limited to 'multimedia/subtitleeditor')
-rw-r--r--multimedia/subtitleeditor/Makefile47
-rw-r--r--multimedia/subtitleeditor/distinfo3
-rw-r--r--multimedia/subtitleeditor/pkg-descr7
-rw-r--r--multimedia/subtitleeditor/pkg-plist32
4 files changed, 89 insertions, 0 deletions
diff --git a/multimedia/subtitleeditor/Makefile b/multimedia/subtitleeditor/Makefile
new file mode 100644
index 000000000000..c49ac246a36e
--- /dev/null
+++ b/multimedia/subtitleeditor/Makefile
@@ -0,0 +1,47 @@
+# New ports collection makefile for: subtitleeditor
+# Date created: 08 January 2007
+# Whom: Andrew Pantyukhin <infofarmer@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= subtitleeditor
+PORTVERSION= 0.12.4
+CATEGORIES= multimedia
+MASTER_SITES= http://kitone.free.fr/subtitleeditor/files/ CSME
+
+MAINTAINER= infofarmer@FreeBSD.org
+COMMENT= Subtitle editor
+
+BUILD_DEPENDS= ${LOCALBASE}/libdata/pkgconfig/iso-codes.pc:${PORTSDIR}/misc/iso-codes
+RUN_DEPENDS:= ${BUILD_DEPENDS}
+LIB_DEPENDS= gtkmm-2.4.1:${PORTSDIR}/x11-toolkits/gtkmm24 \
+ glademm-2.4.1:${PORTSDIR}/devel/libglademm24 \
+ enchant.1:${PORTSDIR}/textproc/enchant \
+ pcre.0:${PORTSDIR}/devel/pcre-utf8
+
+USE_GNOME= gtk20
+USE_GSTREAMER= good
+USE_GETTEXT= yes
+GNU_CONFIGURE= yes
+CONFIGURE_ARGS= --mandir=${MANPREFIX}/man
+CONFIGURE_ENV= CPPFLAGS="${CPPFLAGS}" LDFLAGS="${LDFLAGS}"
+CPPFLAGS= -I${LOCALBASE}/include
+LDFLAGS= -L${LOCALBASE}/lib
+PLIST_SUB= DESKTOPDIR="${DESKTOPDIR:S,^${PREFIX}/,,}"
+MAN1= ${PORTNAME}.1
+
+post-patch:
+ @${REINPLACE_CMD} -e '/test/s|==|=|g' ${WRKSRC}/configure
+ @${REINPLACE_CMD} -e 's|strtoll|std::strtoll|g' ${WRKSRC}/src/SubtitleASS.cc
+
+pre-configure::
+ @${ECHO_MSG} ""
+ @${ECHO_MSG} "This ports need pcre with utf-8 support. If you already"
+ @${ECHO_MSG} "have pcre installed, you may need to run"
+ @${ECHO_MSG} "# portupgrade -fo devel/pcre-utf8 pcre"
+ @${ECHO_MSG} "for this port to build"
+ @${ECHO_MSG} ""
+ @sleep 2
+
+.include <bsd.port.mk>
diff --git a/multimedia/subtitleeditor/distinfo b/multimedia/subtitleeditor/distinfo
new file mode 100644
index 000000000000..af2cacde85ad
--- /dev/null
+++ b/multimedia/subtitleeditor/distinfo
@@ -0,0 +1,3 @@
+MD5 (subtitleeditor-0.12.4.tar.gz) = ab663dac360704e66f0f2b0213e82148
+SHA256 (subtitleeditor-0.12.4.tar.gz) = 3bbe12a0dc0b7eddd4b59dc495056c17893a8f3a6e1b5fc5072e07da1e19d300
+SIZE (subtitleeditor-0.12.4.tar.gz) = 565286
diff --git a/multimedia/subtitleeditor/pkg-descr b/multimedia/subtitleeditor/pkg-descr
new file mode 100644
index 000000000000..30603714a91a
--- /dev/null
+++ b/multimedia/subtitleeditor/pkg-descr
@@ -0,0 +1,7 @@
+Subtitle Editor is a GTK+2 tool to edit subtitles. It can be used for
+new subtitles or as a tool to transform, edit, correct and refine
+existing subtitle. This program also shows sound waves, which makes it
+easier to synchronise subtitles to voices.
+
+WWW: http://kitone.free.fr/subtitleeditor/
+Author: IDJAAD djamel <kitone_at_free_dot_fr>
diff --git a/multimedia/subtitleeditor/pkg-plist b/multimedia/subtitleeditor/pkg-plist
new file mode 100644
index 000000000000..11957b5010bb
--- /dev/null
+++ b/multimedia/subtitleeditor/pkg-plist
@@ -0,0 +1,32 @@
+bin/subtitleeditor
+%%DESKTOPDIR%%/subtitleeditor.desktop
+%%DATADIR%%/dialog-change-fps.glade
+%%DATADIR%%/dialog-encodings-chooser.glade
+%%DATADIR%%/dialog-find-and-replace.glade
+%%DATADIR%%/dialog-move-subtitles.glade
+%%DATADIR%%/dialog-preferences.glade
+%%DATADIR%%/dialog-scale.glade
+%%DATADIR%%/dialog-script-properties.glade
+%%DATADIR%%/dialog-spell-checking.glade
+%%DATADIR%%/dialog-split.glade
+%%DATADIR%%/dialog-style-editor.glade
+%%DATADIR%%/menubar.xml
+%%DATADIR%%/subtitleeditor-icon.png
+%%DATADIR%%/subtitleeditor.glade
+%%DATADIR%%/subtitleeditor.png
+share/locale/ca/LC_MESSAGES/subtitleeditor.mo
+share/locale/cs/LC_MESSAGES/subtitleeditor.mo
+share/locale/es/LC_MESSAGES/subtitleeditor.mo
+share/locale/fr/LC_MESSAGES/subtitleeditor.mo
+share/locale/hu/LC_MESSAGES/subtitleeditor.mo
+share/locale/pl/LC_MESSAGES/subtitleeditor.mo
+share/locale/pt_BR/LC_MESSAGES/subtitleeditor.mo
+share/locale/pt_PT/LC_MESSAGES/subtitleeditor.mo
+@dirrmtry %%DESKTOPDIR%%
+@dirrmtry share/locale/ca/LC_MESSAGES
+@dirrmtry share/locale/ca
+@dirrmtry share/locale/cs/LC_MESSAGES
+@dirrmtry share/locale/cs
+@dirrmtry share/locale/pl/LC_MESSAGES
+@dirrmtry share/locale/pl
+@dirrm %%DATADIR%%