aboutsummaryrefslogtreecommitdiff
path: root/multimedia/totem
diff options
context:
space:
mode:
authorJoe Marcus Clarke <marcus@FreeBSD.org>2009-01-10 05:22:13 +0000
committerJoe Marcus Clarke <marcus@FreeBSD.org>2009-01-10 05:22:13 +0000
commit610ae5681637c1051a0c17b54e29d97f53da2f3a (patch)
treec231a1eb74b07e444fa7363012cb84bf23d83ce0 /multimedia/totem
parent15b6544926b07a98710eeb765baf03e3fc9a195c (diff)
downloadports-610ae5681637c1051a0c17b54e29d97f53da2f3a.tar.gz
ports-610ae5681637c1051a0c17b54e29d97f53da2f3a.zip
Presenting GNOME 2.24 for FreeBSD.
See http://library.gnome.org/misc/release-notes/2.24/ for the general release notes. On the FreeBSD front, this release introduces Fuse support in HAL, adds multi-CPU support to libgtop, WebKit updates, and fixes some long-standing seahorse and gnome-keyring bugs. The documentation updates to the website are forthcoming. This release features commits by adamw, ahze, kwm, mezz, and myself. It would not have been possible without are contributors and testers: Alexander Loginov Craig Butler [1] Dmitry Marakasov [6] Eric L. Chen Joseph S. Atkinson Kris Moore Lapo Luchini [7] Nikos Ntarmos Pawel Worach Romain Tartiere TAOKA Fumiyoshi [3] Yasuda Keisuke Zyl aZ [4] bf [2] [5] Florent Thoumie Peter Wemm pluknet PR: 125857 [1] 126993 [2] 130031 [3] 127399 [4] 127661 [5] 124302 [6] 129570 [7] 129936 123790
Notes
Notes: svn path=/head/; revision=225629
Diffstat (limited to 'multimedia/totem')
-rw-r--r--multimedia/totem/Makefile53
-rw-r--r--multimedia/totem/distinfo6
-rw-r--r--multimedia/totem/files/patch-browser-plugin_idl_Makefile.in11
-rw-r--r--multimedia/totem/files/patch-browser-plugin_totemClassInfo.h45
-rw-r--r--multimedia/totem/files/patch-configure22
-rw-r--r--multimedia/totem/files/pkg-message.in10
-rw-r--r--multimedia/totem/pkg-plist68
7 files changed, 83 insertions, 132 deletions
diff --git a/multimedia/totem/Makefile b/multimedia/totem/Makefile
index 81836a23f05d..d04788bf07b3 100644
--- a/multimedia/totem/Makefile
+++ b/multimedia/totem/Makefile
@@ -3,12 +3,12 @@
# Whom: Hendrik Scholz <hendrik@scholz.net>
#
# $FreeBSD$
-# $MCom: ports-stable/multimedia/totem/Makefile,v 1.9 2008/08/02 21:17:25 mezz Exp $
+# $MCom: ports/multimedia/totem/Makefile,v 1.118 2008/11/09 11:58:37 kwm Exp $
#
PORTNAME= totem
-PORTVERSION= 2.22.2
-PORTREVISION?= 4
+PORTVERSION= 2.24.3
+PORTREVISION?= 0
CATEGORIES= multimedia gnome
MASTER_SITES= GNOME
DIST_SUBDIR= gnome2
@@ -18,7 +18,7 @@ COMMENT?= A gstreamer-based video player for the GNOME 2 Desktop
BUILD_DEPENDS= ${LOCALBASE}/libdata/pkgconfig/iso-codes.pc:${PORTSDIR}/misc/iso-codes
LIB_DEPENDS= musicbrainz:${PORTSDIR}/audio/libmusicbrainz \
- totem-plparser.10:${PORTSDIR}/multimedia/totem-pl-parser
+ totem-plparser.12:${PORTSDIR}/multimedia/totem-pl-parser
RUN_DEPENDS= ${LOCALBASE}/libdata/pkgconfig/iso-codes.pc:${PORTSDIR}/misc/iso-codes \
${LOCALBASE}/libexec/gnome-settings-daemon:${PORTSDIR}/sysutils/gnome-settings-daemon \
${PYTHON_SITELIBDIR}/atom/__init__.py:${PORTSDIR}/devel/py-gdata
@@ -26,7 +26,7 @@ RUN_DEPENDS= ${LOCALBASE}/libdata/pkgconfig/iso-codes.pc:${PORTSDIR}/misc/iso-co
USE_PYTHON= yes
USE_BZIP2= yes
USE_GETTEXT= yes
-USE_GNOME= gnomeprefix intlhack gnomehack libgnomeui desktopfileutils \
+USE_GNOME= gnomeprefix intlhack gnomehack desktopfileutils \
nautiluscdburner ltverhack pygtk2
GNOME_DESKTOP_VERSION=2
WANT_GSTREAMER= yes
@@ -37,17 +37,18 @@ USE_LDCONFIG= yes
INSTALLS_OMF= yes
PKGMESSAGE= ${WRKDIR}/pkg-message
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
- LIBS="-L${LOCALBASE}/lib -lXrandr"
+ LIBS="-L${LOCALBASE}/lib -lXrandr" \
+ BROWSER_PLUGIN_DIR="${WEBPLUGINS_DIR}"
CONFIGURE_ARGS= --with-plugins="${TOTEM_PLUGINS}"
MAN1= totem.1 totem-video-thumbnailer.1
GCONF_SCHEMAS= totem-handlers.schemas totem-video-thumbnail.schemas \
totem.schemas
-CONFLICTS?= totem-gstreamer-[0-9]* totem-xine-[0-9]*
+CONFLICTS?= totem-xine-[0-9]*
OPTIONS= LIRC "Enable lirc support" off \
GALAGO "Enable Galago support" off \
- GECKO_PLUGINS "Enable install plugins for gecko browser" on \
+ BROWSER_PLUGINS "Enable install plugins for gecko browser" on \
PUBLISH "Enable Publish (network playlist) plugin" off \
TRACKER "Enable tracker local search plugin" off
@@ -91,34 +92,26 @@ TOTEM_PLUGINS:= ${TOTEM_PLUGINS} galago
PLIST_SUB+= GALAGO="@comment "
.endif
-.if !defined(WITHOUT_GECKO_PLUGINS)
-USE_GECKO= firefox mozilla seamonkey xulrunner<->firefox firefox-devel<->firefox
-.include "${PORTSDIR}/www/mozilla/bsd.gecko.mk"
-CONFIGURE_ARGS+=--with-mozilla=${GECKO} \
- --enable-browser-plugins \
+.if !defined(WITHOUT_BROWSER_PLUGINS)
+CONFIGURE_ARGS+=--enable-browser-plugins \
--enable-gmp-plugin \
--enable-complex-plugin \
--enable-narrowspace-plugin
-PLIST_SUB+= GECKO_PLUGINS=""
-
-USE_WEBPLUGINS= gecko*
-WEBPLUGINS_FILES= libtotem-basic-plugin.so libtotem-basic-plugin.xpt \
- libtotem-complex-plugin.so libtotem-complex-plugin.xpt \
- libtotem-cone-plugin.so libtotem-cone-plugin.xpt \
- libtotem-gmp-plugin.so libtotem-gmp-plugin.xpt \
- libtotem-mully-plugin.so libtotem-mully-plugin.xpt \
- libtotem-narrowspace-plugin.so \
- libtotem-narrowspace-plugin.xpt
+PLIST_SUB+= BROWSER_PLUGINS=""
+
+USE_WEBPLUGINS= gecko19 webkit-gtk2
+WEBPLUGINS_FILES= libtotem-basic-plugin.so libtotem-complex-plugin.so \
+ libtotem-cone-plugin.so libtotem-gmp-plugin.so \
+ libtotem-mully-plugin.so \
+ libtotem-narrowspace-plugin.so
.include "${PORTSDIR}/www/firefox/Makefile.webplugins"
.else
-CONFIGURE_ARGS+=--without-mozilla \
- --disable-browser-plugins \
- --disable-mozilla \
+CONFIGURE_ARGS+=--disable-browser-plugins \
--disable-basic-plugin \
--disable-gmp-plugin \
--disable-complex-plugin \
--disable-narrowspace-plugin
-PLIST_SUB+= GECKO_PLUGINS="@comment "
+PLIST_SUB+= BROWSER_PLUGINS="@comment "
.endif
.if !defined(WITH_TOTEM_XINE) || ${SLAVE_PORT}=="no"
@@ -149,9 +142,8 @@ pre-everything::
post-patch:
@${CP} -f ${FILESDIR}/pkg-message.in ${PKGMESSAGE}
- @${REINPLACE_CMD} -e 's|dbus >= 0.61|dbus-1 >= 0.61|g ; \
- s|_PLUGINDIR=".*"|_PLUGINDIR="${WEBPLUGINS_DIR}"|g' \
- ${WRKSRC}/configure
+ @${REINPLACE_CMD} -e 's|dbus >= 0.61|dbus-1 >= 0.61|g' \
+ ${WRKSRC}/configure
@${REINPLACE_CMD} -e 's|/dev/dvd|${DEFAULT_DVD_DEVICE}|' \
${WRKSRC}/src/backend/bacon-video-widget-gst-0.10.c
@@ -160,5 +152,6 @@ post-install:
${MKDIR} ${PREFIX}/share/vala/vapi
${INSTALL_DATA} ${WRKSRC}/bindings/vala/totem.vapi ${PREFIX}/share/vala/vapi
${INSTALL_DATA} ${WRKSRC}/bindings/vala/totem.deps ${PREFIX}/share/vala/vapi
+ @${CAT} ${PKGMESSAGE}
.include <bsd.port.post.mk>
diff --git a/multimedia/totem/distinfo b/multimedia/totem/distinfo
index 22866f91f455..a19d2bab72a2 100644
--- a/multimedia/totem/distinfo
+++ b/multimedia/totem/distinfo
@@ -1,3 +1,3 @@
-MD5 (gnome2/totem-2.22.2.tar.bz2) = 6062080e81b4859f87fee8a592b92489
-SHA256 (gnome2/totem-2.22.2.tar.bz2) = 7dd755e3b9a9610989661bfe7e09388e67ba6aca960c33e65e6a39682c00ffd4
-SIZE (gnome2/totem-2.22.2.tar.bz2) = 2403730
+MD5 (gnome2/totem-2.24.3.tar.bz2) = 261bae2586c3bb6a55bfa2704d7e3b14
+SHA256 (gnome2/totem-2.24.3.tar.bz2) = 235a2e39959e7da3dc49f5d1d9c7259a74047d32a52b0eefeec5265174769836
+SIZE (gnome2/totem-2.24.3.tar.bz2) = 2545808
diff --git a/multimedia/totem/files/patch-browser-plugin_idl_Makefile.in b/multimedia/totem/files/patch-browser-plugin_idl_Makefile.in
deleted file mode 100644
index 238b32c3263a..000000000000
--- a/multimedia/totem/files/patch-browser-plugin_idl_Makefile.in
+++ /dev/null
@@ -1,11 +0,0 @@
---- browser-plugin/idl/Makefile.in.orig 2008-03-15 20:31:26.000000000 -0500
-+++ browser-plugin/idl/Makefile.in 2008-03-15 20:31:34.000000000 -0500
-@@ -532,7 +532,7 @@
-
- info-am:
-
--install-data-am: install-docDATA install-xptDATA
-+install-data-am: install-xptDATA
-
- install-dvi: install-dvi-am
-
diff --git a/multimedia/totem/files/patch-browser-plugin_totemClassInfo.h b/multimedia/totem/files/patch-browser-plugin_totemClassInfo.h
deleted file mode 100644
index e4f8e650ed7b..000000000000
--- a/multimedia/totem/files/patch-browser-plugin_totemClassInfo.h
+++ /dev/null
@@ -1,45 +0,0 @@
---- browser-plugin/totemClassInfo.h.orig 2007-08-09 17:32:58.000000000 +0000
-+++ browser-plugin/totemClassInfo.h 2007-08-09 17:55:50.000000000 +0000
-@@ -47,10 +47,10 @@
- NS_IMETHODIMP _class::GetClassDescription(char * *aClassDescription)\
- {\
- *aClassDescription = static_cast<char*>(\
-- nsMemory::Clone (_description,\
-- sizeof (_description)));\
-+ nsMemory::Alloc (sizeof (_description) + 1));\
- if (!*aClassDescription)\
- return NS_ERROR_OUT_OF_MEMORY;\
-+ strcpy(*aClassDescription, _description);\
- \
- return NS_OK;\
- }\
-@@ -59,10 +59,10 @@
- NS_IMETHODIMP _class::GetClassID(nsCID * *aClassID)\
- {\
- *aClassID = static_cast<nsCID*>(\
-- nsMemory::Clone (&_cid,\
-- sizeof (nsCID*)));\
-+ nsMemory::Alloc (sizeof (nsCID*) + 1));\
- if (!*aClassID)\
- return NS_ERROR_OUT_OF_MEMORY;\
-+ memcpy(*aClassID, &_cid, sizeof (nsCID*));\
- \
- return NS_OK;\
- }\
-@@ -99,13 +99,12 @@
-
- #define TOTEM_CLASSINFO_ENTRY(_i, _interface)\
- (*array)[_i] = static_cast<nsIID*>(\
-- nsMemory::Clone(&NS_GET_IID(_interface),\
-- sizeof(nsIID)));\
-+ nsMemory::Alloc(sizeof(nsIID) + 1));\
- if (!(*array)[_i]) {\
- NS_FREE_XPCOM_ALLOCATED_POINTER_ARRAY (_i, *array);\
- return NS_ERROR_OUT_OF_MEMORY;\
-- }
--
-+ }\
-+ memcpy((*array)[_i], &NS_GET_IID(_interface), sizeof(nsIID));
-
- #define TOTEM_CLASSINFO_END \
- return NS_OK;\
diff --git a/multimedia/totem/files/patch-configure b/multimedia/totem/files/patch-configure
index 67b99d2287b5..4c6c7b340f9d 100644
--- a/multimedia/totem/files/patch-configure
+++ b/multimedia/totem/files/patch-configure
@@ -1,12 +1,12 @@
---- configure.orig 2008-08-02 00:06:51.000000000 -0500
-+++ configure 2008-08-02 00:09:01.000000000 -0500
-@@ -25298,8 +25298,7 @@
- if test "$have_libxpcomglue_s" = "yes"; then
- LIBXPCOMGLUE_S="-L$MOZILLA_LIBDIR -lxpcomglue_s"
- else
-- { echo "$as_me:$LINENO: WARNING: libxpcomglue_s not available; plugins may not be portable" >&5
--echo "$as_me: WARNING: libxpcomglue_s not available; plugins may not be portable" >&2;}
-+ LIBXPCOMGLUE_S=`$PKG_CONFIG --libs $MOZILLA-xpcom`
- fi
- fi
+--- configure.orig 2008-08-30 08:23:22.000000000 +0200
++++ configure 2008-08-30 08:24:20.000000000 +0200
+@@ -25171,7 +25171,9 @@
+ _ACEOF
+
+
++if [ -z "${BROWSER_PLUGIN_DIR}" ]; then
+ BROWSER_PLUGIN_DIR="${BROWSER_PLUGIN_DIR:-"\${libdir}/mozilla/plugins"}"
++fi
+
+
diff --git a/multimedia/totem/files/pkg-message.in b/multimedia/totem/files/pkg-message.in
index 05d7f5b20978..5c4332981d9d 100644
--- a/multimedia/totem/files/pkg-message.in
+++ b/multimedia/totem/files/pkg-message.in
@@ -1,4 +1,6 @@
-Make sure you've enough shared memory, the xine FAQ
-advises to have the following sysctl settings:
-kern.ipc.shmmax=67108864
-kern.ipc.shmall=32768
+********************************************************
+* Make sure you've enough shared memory, the xine FAQ *
+* advises to have the following sysctl settings: *
+* kern.ipc.shmmax=67108864 *
+* kern.ipc.shmall=32768 *
+********************************************************
diff --git a/multimedia/totem/pkg-plist b/multimedia/totem/pkg-plist
index ef4479b60a0a..67ffdd5a10da 100644
--- a/multimedia/totem/pkg-plist
+++ b/multimedia/totem/pkg-plist
@@ -2,30 +2,28 @@ bin/totem
bin/totem-audio-preview
bin/totem-video-indexer
bin/totem-video-thumbnailer
-%%GECKO_PLUGINS%%%%WEBPLUGINS_DIR%%/libtotem-basic-plugin.a
-%%GECKO_PLUGINS%%%%WEBPLUGINS_DIR%%/libtotem-basic-plugin.la
-%%GECKO_PLUGINS%%%%WEBPLUGINS_DIR%%/libtotem-basic-plugin.so
-%%GECKO_PLUGINS%%%%WEBPLUGINS_DIR%%/libtotem-basic-plugin.xpt
-%%GECKO_PLUGINS%%%%WEBPLUGINS_DIR%%/libtotem-complex-plugin.a
-%%GECKO_PLUGINS%%%%WEBPLUGINS_DIR%%/libtotem-complex-plugin.la
-%%GECKO_PLUGINS%%%%WEBPLUGINS_DIR%%/libtotem-complex-plugin.so
-%%GECKO_PLUGINS%%%%WEBPLUGINS_DIR%%/libtotem-complex-plugin.xpt
-%%GECKO_PLUGINS%%%%WEBPLUGINS_DIR%%/libtotem-cone-plugin.a
-%%GECKO_PLUGINS%%%%WEBPLUGINS_DIR%%/libtotem-cone-plugin.la
-%%GECKO_PLUGINS%%%%WEBPLUGINS_DIR%%/libtotem-cone-plugin.so
-%%GECKO_PLUGINS%%%%WEBPLUGINS_DIR%%/libtotem-cone-plugin.xpt
-%%GECKO_PLUGINS%%%%WEBPLUGINS_DIR%%/libtotem-gmp-plugin.a
-%%GECKO_PLUGINS%%%%WEBPLUGINS_DIR%%/libtotem-gmp-plugin.la
-%%GECKO_PLUGINS%%%%WEBPLUGINS_DIR%%/libtotem-gmp-plugin.so
-%%GECKO_PLUGINS%%%%WEBPLUGINS_DIR%%/libtotem-gmp-plugin.xpt
-%%GECKO_PLUGINS%%%%WEBPLUGINS_DIR%%/libtotem-mully-plugin.a
-%%GECKO_PLUGINS%%%%WEBPLUGINS_DIR%%/libtotem-mully-plugin.la
-%%GECKO_PLUGINS%%%%WEBPLUGINS_DIR%%/libtotem-mully-plugin.so
-%%GECKO_PLUGINS%%%%WEBPLUGINS_DIR%%/libtotem-mully-plugin.xpt
-%%GECKO_PLUGINS%%%%WEBPLUGINS_DIR%%/libtotem-narrowspace-plugin.a
-%%GECKO_PLUGINS%%%%WEBPLUGINS_DIR%%/libtotem-narrowspace-plugin.la
-%%GECKO_PLUGINS%%%%WEBPLUGINS_DIR%%/libtotem-narrowspace-plugin.so
-%%GECKO_PLUGINS%%%%WEBPLUGINS_DIR%%/libtotem-narrowspace-plugin.xpt
+%%BROWSER_PLUGINS%%%%WEBPLUGINS_DIR%%/libtotem-basic-plugin.a
+%%BROWSER_PLUGINS%%%%WEBPLUGINS_DIR%%/libtotem-basic-plugin.la
+%%BROWSER_PLUGINS%%%%WEBPLUGINS_DIR%%/libtotem-basic-plugin.so
+%%BROWSER_PLUGINS%%%%WEBPLUGINS_DIR%%/libtotem-complex-plugin.a
+%%BROWSER_PLUGINS%%%%WEBPLUGINS_DIR%%/libtotem-complex-plugin.la
+%%BROWSER_PLUGINS%%%%WEBPLUGINS_DIR%%/libtotem-complex-plugin.so
+%%BROWSER_PLUGINS%%%%WEBPLUGINS_DIR%%/libtotem-cone-plugin.a
+%%BROWSER_PLUGINS%%%%WEBPLUGINS_DIR%%/libtotem-cone-plugin.la
+%%BROWSER_PLUGINS%%%%WEBPLUGINS_DIR%%/libtotem-cone-plugin.so
+%%BROWSER_PLUGINS%%%%WEBPLUGINS_DIR%%/libtotem-gmp-plugin.a
+%%BROWSER_PLUGINS%%%%WEBPLUGINS_DIR%%/libtotem-gmp-plugin.la
+%%BROWSER_PLUGINS%%%%WEBPLUGINS_DIR%%/libtotem-gmp-plugin.so
+%%BROWSER_PLUGINS%%%%WEBPLUGINS_DIR%%/libtotem-mully-plugin.a
+%%BROWSER_PLUGINS%%%%WEBPLUGINS_DIR%%/libtotem-mully-plugin.la
+%%BROWSER_PLUGINS%%%%WEBPLUGINS_DIR%%/libtotem-mully-plugin.so
+%%BROWSER_PLUGINS%%%%WEBPLUGINS_DIR%%/libtotem-narrowspace-plugin.a
+%%BROWSER_PLUGINS%%%%WEBPLUGINS_DIR%%/libtotem-narrowspace-plugin.la
+%%BROWSER_PLUGINS%%%%WEBPLUGINS_DIR%%/libtotem-narrowspace-plugin.so
+lib/libbaconvideowidget.a
+lib/libbaconvideowidget.la
+lib/libbaconvideowidget.so
+lib/libbaconvideowidget.so.0
lib/nautilus/extensions-2.0/libtotem-properties-page.a
lib/nautilus/extensions-2.0/libtotem-properties-page.la
lib/nautilus/extensions-2.0/libtotem-properties-page.so
@@ -83,7 +81,7 @@ lib/totem/plugins/youtube/youtube.pyc
lib/totem/plugins/youtube/youtube.pyo
lib/totem/plugins/youtube/youtube.totem-plugin
lib/totem/plugins/youtube/youtube.ui
-%%GECKO_PLUGINS%%libexec/totem-plugin-viewer
+%%BROWSER_PLUGINS%%libexec/totem-plugin-viewer
libexec/totem/totem-bugreport.py
share/applications/totem.desktop
share/gnome/help/totem/C/figures/totem_next_button.png
@@ -180,6 +178,15 @@ share/gnome/help/totem/pa/figures/totem_start_window.png
share/gnome/help/totem/pa/figures/totem_volume_maximum_button.png
share/gnome/help/totem/pa/figures/totem_volume_mute_button.png
share/gnome/help/totem/pa/totem.xml
+share/gnome/help/totem/pl/figures/totem_next_button.png
+share/gnome/help/totem/pl/figures/totem_pause_button.png
+share/gnome/help/totem/pl/figures/totem_play_button.png
+share/gnome/help/totem/pl/figures/totem_previous_button.png
+share/gnome/help/totem/pl/figures/totem_show_playlist_button.png
+share/gnome/help/totem/pl/figures/totem_start_window.png
+share/gnome/help/totem/pl/figures/totem_volume_maximum_button.png
+share/gnome/help/totem/pl/figures/totem_volume_mute_button.png
+share/gnome/help/totem/pl/totem.xml
share/gnome/help/totem/pt_BR/figures/totem_next_button.png
share/gnome/help/totem/pt_BR/figures/totem_pause_button.png
share/gnome/help/totem/pt_BR/figures/totem_play_button.png
@@ -305,7 +312,7 @@ share/locale/sk/LC_MESSAGES/totem.mo
share/locale/sl/LC_MESSAGES/totem.mo
share/locale/sq/LC_MESSAGES/totem.mo
share/locale/sr/LC_MESSAGES/totem.mo
-share/locale/sr@Latn/LC_MESSAGES/totem.mo
+share/locale/sr@latin/LC_MESSAGES/totem.mo
share/locale/sv/LC_MESSAGES/totem.mo
share/locale/ta/LC_MESSAGES/totem.mo
share/locale/te/LC_MESSAGES/totem.mo
@@ -330,6 +337,7 @@ share/omf/totem/totem-fr.omf
share/omf/totem/totem-it.omf
share/omf/totem/totem-oc.omf
share/omf/totem/totem-pa.omf
+share/omf/totem/totem-pl.omf
share/omf/totem/totem-pt_BR.omf
share/omf/totem/totem-ru.omf
share/omf/totem/totem-sv.omf
@@ -364,6 +372,8 @@ share/vala/vapi/totem.vapi
@dirrm share/gnome/help/totem/ru
@dirrm share/gnome/help/totem/pt_BR/figures
@dirrm share/gnome/help/totem/pt_BR
+@dirrm share/gnome/help/totem/pl/figures
+@dirrm share/gnome/help/totem/pl
@dirrm share/gnome/help/totem/pa/figures
@dirrm share/gnome/help/totem/pa
@dirrm share/gnome/help/totem/oc/figures
@@ -387,6 +397,7 @@ share/vala/vapi/totem.vapi
@dirrm share/gnome/help/totem/C/figures
@dirrm share/gnome/help/totem/C
@dirrm share/gnome/help/totem
+@dirrmtry share/applications
@dirrm libexec/totem
@dirrm lib/totem/plugins/youtube
@dirrm lib/totem/plugins/totem
@@ -403,10 +414,9 @@ share/vala/vapi/totem.vapi
%%GALAGO%%@dirrm lib/totem/plugins/galago
@dirrm lib/totem/plugins
@dirrm lib/totem
-%%GECKO_PLUGINS%%@dirrmtry %%WEBPLUGINS_DIR%%
+%%BROWSER_PLUGINS%%@dirrmtry %%WEBPLUGINS_DIR%%
@exec %%LOCALBASE%%/bin/update-desktop-database > /dev/null || /usr/bin/true
@unexec %%LOCALBASE%%/bin/update-desktop-database > /dev/null || /usr/bin/true
-@dirrmtry share/applications
@dirrmtry share/locale/zh_HK/LC_MESSAGES
@dirrmtry share/locale/zh_HK
@dirrmtry share/locale/xh/LC_MESSAGES
@@ -415,6 +425,8 @@ share/vala/vapi/totem.vapi
@dirrmtry share/locale/ug
@dirrmtry share/locale/te/LC_MESSAGES
@dirrmtry share/locale/te
+@dirrmtry share/locale/sr@latin/LC_MESSAGES
+@dirrmtry share/locale/sr@latin
@dirrmtry share/locale/si/LC_MESSAGES
@dirrmtry share/locale/si
@dirrmtry share/locale/rw/LC_MESSAGES