aboutsummaryrefslogtreecommitdiff
path: root/multimedia/totem
diff options
context:
space:
mode:
authorJoe Marcus Clarke <marcus@FreeBSD.org>2009-11-28 20:06:37 +0000
committerJoe Marcus Clarke <marcus@FreeBSD.org>2009-11-28 20:06:37 +0000
commitf76d32b8e89fed7c0e459c1a7fe7a4b57661b01c (patch)
treead29e6808ff698f84e08dab8e047f0ae72838df9 /multimedia/totem
parent873cae3ab41a109b6f9cf9f4149f101d6d996235 (diff)
downloadports-f76d32b8e89fed7c0e459c1a7fe7a4b57661b01c.tar.gz
ports-f76d32b8e89fed7c0e459c1a7fe7a4b57661b01c.zip
Presenting GNOME 2.28.1 for FreeBSD. The official release notes for this
release can be found at http://library.gnome.org/misc/release-notes/2.28/ . Officially, this is mostly a polishing release in preparation for GNOME 3.0 due in about a year. On the FreeBSD front, though, a lot went into this release. Major thanks goes to kwm and avl who did a lot of the porting work for this release. In particular, kwm brought in Evolution MAPI support for better Microsoft Exchange integration. Avl made sure that the new gobject introspection repository ports were nicely compartmentalized so that large dependencies aren't brought in wholesale. But, every GNOME team member (ahze, avl, bland, kwm, mezz, and myself) contributed to this release. Other major improvements include an updated HAL with better volume probing code, ufsid integration, and support for volume names containing spaces (big thanks to J.R. Oldroyd); a new WebKit; updated AbiWord; an updated Gimp; and a preview of the new GNOME Shell project (thanks to Pawel Worach). The FreeBSD GNOME Team would like to that the following additional contributors to this release whose patches and testing really helped make it a success: Andrius Morkunas Dominique Goncalves Eric L. Chen J.R. Oldroyd Joseph S. Atkinson Li Pawel Worach Romain Tartière Thomas Vogt Yasuda Keisuke Rui Paulo Martin Wilke (and an extra shout out to miwi and pav for pointyhat runs) We would like to send this release out to Alexander Loginov (avl) in hopes that he feels better soon. PR: 136676 136967 138872 (obsolete with new epiphany-webkit) 139160 134737 139941 140097 140838 140929
Notes
Notes: svn path=/head/; revision=244923
Diffstat (limited to 'multimedia/totem')
-rw-r--r--multimedia/totem/Makefile27
-rw-r--r--multimedia/totem/distinfo6
-rw-r--r--multimedia/totem/files/patch-help_Makefile.in11
-rw-r--r--multimedia/totem/pkg-plist31
4 files changed, 42 insertions, 33 deletions
diff --git a/multimedia/totem/Makefile b/multimedia/totem/Makefile
index c1b985261cf8..9cb5bfba73ca 100644
--- a/multimedia/totem/Makefile
+++ b/multimedia/totem/Makefile
@@ -3,12 +3,12 @@
# Whom: Hendrik Scholz <hendrik@scholz.net>
#
# $FreeBSD$
-# $MCom: ports/multimedia/totem/Makefile,v 1.126 2009/04/03 10:17:44 kwm Exp $
+# $MCom: ports/multimedia/totem/Makefile,v 1.138 2009/11/19 15:28:58 kwm Exp $
#
PORTNAME= totem
-PORTVERSION= 2.26.3
-PORTREVISION?= 1
+PORTVERSION= 2.28.4
+PORTREVISION?= 0
CATEGORIES= multimedia gnome
MASTER_SITES= GNOME
DIST_SUBDIR= gnome2
@@ -18,6 +18,7 @@ COMMENT?= A gstreamer-based video player for the GNOME 2 Desktop
BUILD_DEPENDS= ${LOCALBASE}/libdata/pkgconfig/iso-codes.pc:${PORTSDIR}/misc/iso-codes
LIB_DEPENDS= musicbrainz:${PORTSDIR}/audio/libmusicbrainz \
+ gdata.6:${PORTSDIR}/devel/libgdata \
totem-plparser.12:${PORTSDIR}/multimedia/totem-pl-parser
RUN_DEPENDS= ${LOCALBASE}/libdata/pkgconfig/iso-codes.pc:${PORTSDIR}/misc/iso-codes \
${LOCALBASE}/libexec/gnome-settings-daemon:${PORTSDIR}/sysutils/gnome-settings-daemon \
@@ -29,7 +30,7 @@ USE_GETTEXT= yes
USE_GNOME= gnomeprefix intlhack gnomehack desktopfileutils \
nautilus2 ltverhack pygtk2
GNOME_DESKTOP_VERSION=2
-WANT_GSTREAMER= yes
+USE_GSTREAMER= core gconf hal good mpeg2dec soup ugly python gio
INSTALLS_ICONS= yes
USE_GMAKE= yes
USE_AUTOTOOLS= libtool:22
@@ -44,7 +45,8 @@ CONFIGURE_ARGS= --with-plugins="${TOTEM_PLUGINS}"
MAN1= totem.1 totem-video-thumbnailer.1
GCONF_SCHEMAS= totem-handlers.schemas totem-video-thumbnail.schemas \
totem.schemas
-CONFLICTS?= totem-xine-[0-9]*
+
+WITHOUT_DVDNAV= yes
OPTIONS= LIRC "Enable lirc support" off \
GALAGO "Enable Galago support" off \
@@ -100,7 +102,7 @@ CONFIGURE_ARGS+=--enable-browser-plugins \
PLIST_SUB+= BROWSER_PLUGINS=""
USE_WEBPLUGINS= gecko19 webkit-gtk2
-WEBPLUGINS_FILES= libtotem-basic-plugin.so libtotem-complex-plugin.so \
+WEBPLUGINS_FILES= libtotem-complex-plugin.so \
libtotem-cone-plugin.so libtotem-gmp-plugin.so \
libtotem-mully-plugin.so \
libtotem-narrowspace-plugin.so
@@ -114,17 +116,6 @@ CONFIGURE_ARGS+=--disable-browser-plugins \
PLIST_SUB+= BROWSER_PLUGINS="@comment "
.endif
-.if !defined(WITH_TOTEM_XINE) || ${SLAVE_PORT}=="no"
-CONFIGURE_ARGS+=--enable-gstreamer=yes
-USE_GSTREAMER+= core gconf hal good mpeg2dec soup ugly python gio
-WITHOUT_DVDNAV= yes
-PLIST_SUB+= GSTREAMER=""
-.else
-CONFIGURE_ARGS+=--enable-xine=yes
-LIB_DEPENDS+= xine.1:${PORTSDIR}/multimedia/libxine
-PLIST_SUB+= GSTREAMER="@comment "
-.endif
-
.if defined(WITH_DVDNAV) && !defined(WITHOUT_DVDNAV)
LIB_DEPENDS+= dvdnav.4:${PORTSDIR}/multimedia/libdvdnav
.endif
@@ -142,8 +133,6 @@ pre-everything::
post-patch:
@${CP} -f ${FILESDIR}/pkg-message.in ${PKGMESSAGE}
- @${REINPLACE_CMD} -e 's|dbus >= 0.61|dbus-1 >= 0.61|g' \
- ${WRKSRC}/configure
@${REINPLACE_CMD} -e 's|/dev/dvd|${DEFAULT_DVD_DEVICE}|' \
${WRKSRC}/src/backend/bacon-video-widget-gst-0.10.c
diff --git a/multimedia/totem/distinfo b/multimedia/totem/distinfo
index 3b60109a80f7..343a163cc425 100644
--- a/multimedia/totem/distinfo
+++ b/multimedia/totem/distinfo
@@ -1,3 +1,3 @@
-MD5 (gnome2/totem-2.26.3.tar.bz2) = f8f7390f5d93268cd200086a1b4f765a
-SHA256 (gnome2/totem-2.26.3.tar.bz2) = ae1bd6682385ad401effda4a856f4ba8150b5ef4eab113a288b29e9335170d70
-SIZE (gnome2/totem-2.26.3.tar.bz2) = 3193956
+MD5 (gnome2/totem-2.28.4.tar.bz2) = a08fca39db3c3e7885c584e0fd533f5a
+SHA256 (gnome2/totem-2.28.4.tar.bz2) = ac1f9091450e2dde2887dd7176183341fcea5adc4b6cee6887342837f2a6e17e
+SIZE (gnome2/totem-2.28.4.tar.bz2) = 3081676
diff --git a/multimedia/totem/files/patch-help_Makefile.in b/multimedia/totem/files/patch-help_Makefile.in
new file mode 100644
index 000000000000..0695029ac2b6
--- /dev/null
+++ b/multimedia/totem/files/patch-help_Makefile.in
@@ -0,0 +1,11 @@
+--- help/Makefile.in.orig 2009-05-10 03:06:15.000000000 -0400
++++ help/Makefile.in 2009-05-10 03:06:29.000000000 -0400
+@@ -783,7 +783,7 @@ $(DOC_H_FILE): $(DOC_H_DOCS);
+ xsltproc --path "$$xmlpath" $(_credits) $$doc; \
+ done | sort | uniq \
+ | awk 'BEGIN{s=""}{n=split($$0,w,"<");if(s!=""&&s!=substr(w[1],1,length(w[1])-1)){print s};if(n>1){print $$0;s=""}else{s=$$0}};END{if(s!=""){print s}}' \
+- | sed -e 's/\\/\\\\/' -e 's/"/\\"/' -e 's/\(.*\)/\t"\1",/' >> $@.tmp
++ | sed -e 's/\\/\\\\/' -e 's/"/\\"/' -e 's/\(.*\)/ "\1",/' >> $@.tmp
+ echo ' NULL' >> $@.tmp
+ echo '};' >> $@.tmp
+ echo >> $@.tmp
diff --git a/multimedia/totem/pkg-plist b/multimedia/totem/pkg-plist
index 7edd484c982a..971411f013dc 100644
--- a/multimedia/totem/pkg-plist
+++ b/multimedia/totem/pkg-plist
@@ -17,10 +17,6 @@ bin/totem-video-thumbnailer
%%BROWSER_PLUGINS%%%%WEBPLUGINS_DIR%%/libtotem-narrowspace-plugin.a
%%BROWSER_PLUGINS%%%%WEBPLUGINS_DIR%%/libtotem-narrowspace-plugin.la
%%BROWSER_PLUGINS%%%%WEBPLUGINS_DIR%%/libtotem-narrowspace-plugin.so
-lib/libbaconvideowidget.a
-lib/libbaconvideowidget.la
-lib/libbaconvideowidget.so
-lib/libbaconvideowidget.so.0
lib/nautilus/extensions-2.0/libtotem-properties-page.a
lib/nautilus/extensions-2.0/libtotem-properties-page.la
lib/nautilus/extensions-2.0/libtotem-properties-page.so
@@ -73,9 +69,9 @@ lib/totem/plugins/thumbnail/thumbnail.totem-plugin
lib/totem/plugins/totem/__init__.py
lib/totem/plugins/totem/__init__.pyc
lib/totem/plugins/totem/__init__.pyo
-lib/totem/plugins/youtube/youtube.py
-lib/totem/plugins/youtube/youtube.pyc
-lib/totem/plugins/youtube/youtube.pyo
+lib/totem/plugins/youtube/libyoutube.a
+lib/totem/plugins/youtube/libyoutube.la
+lib/totem/plugins/youtube/libyoutube.so
lib/totem/plugins/youtube/youtube.totem-plugin
lib/totem/plugins/youtube/youtube.ui
%%BROWSER_PLUGINS%%libexec/totem-plugin-viewer
@@ -98,6 +94,8 @@ share/applications/totem.desktop
%%DOCSDIR%%/totem-Interface.html
%%DOCSDIR%%/totem.devhelp
%%DOCSDIR%%/totem.devhelp2
+%%DOCSDIR%%/totem-plugins.html
+%%DOCSDIR%%/tutorials.html
%%DOCSDIR%%/up.png
%%DOCSDIR%%/widget-api.html
share/gnome/help/totem/C/figures/totem_next_button.png
@@ -275,6 +273,15 @@ share/gnome/help/totem/uk/figures/totem_start_window.png
share/gnome/help/totem/uk/figures/totem_volume_maximum_button.png
share/gnome/help/totem/uk/figures/totem_volume_mute_button.png
share/gnome/help/totem/uk/totem.xml
+share/gnome/help/totem/zh_CN/figures/totem_next_button.png
+share/gnome/help/totem/zh_CN/figures/totem_pause_button.png
+share/gnome/help/totem/zh_CN/figures/totem_play_button.png
+share/gnome/help/totem/zh_CN/figures/totem_previous_button.png
+share/gnome/help/totem/zh_CN/figures/totem_show_playlist_button.png
+share/gnome/help/totem/zh_CN/figures/totem_start_window.png
+share/gnome/help/totem/zh_CN/figures/totem_volume_maximum_button.png
+share/gnome/help/totem/zh_CN/figures/totem_volume_mute_button.png
+share/gnome/help/totem/zh_CN/totem.xml
share/gnome/help/totem/zh_HK/figures/totem_next_button.png
share/gnome/help/totem/zh_HK/figures/totem_pause_button.png
share/gnome/help/totem/zh_HK/figures/totem_play_button.png
@@ -317,6 +324,7 @@ share/locale/bn/LC_MESSAGES/totem.mo
share/locale/bn_IN/LC_MESSAGES/totem.mo
share/locale/br/LC_MESSAGES/totem.mo
share/locale/ca/LC_MESSAGES/totem.mo
+share/locale/ca@valencia/LC_MESSAGES/totem.mo
share/locale/crh/LC_MESSAGES/totem.mo
share/locale/cs/LC_MESSAGES/totem.mo
share/locale/cy/LC_MESSAGES/totem.mo
@@ -363,7 +371,6 @@ share/locale/oc/LC_MESSAGES/totem.mo
share/locale/or/LC_MESSAGES/totem.mo
share/locale/pa/LC_MESSAGES/totem.mo
share/locale/pl/LC_MESSAGES/totem.mo
-share/locale/ps/LC_MESSAGES/totem.mo
share/locale/pt/LC_MESSAGES/totem.mo
share/locale/pt_BR/LC_MESSAGES/totem.mo
share/locale/ro/LC_MESSAGES/totem.mo
@@ -408,6 +415,7 @@ share/omf/totem/totem-pt_BR.omf
share/omf/totem/totem-ru.omf
share/omf/totem/totem-sv.omf
share/omf/totem/totem-uk.omf
+share/omf/totem/totem-zh_CN.omf
share/omf/totem/totem-zh_HK.omf
share/omf/totem/totem-zh_TW.omf
%%DATADIR%%/filmholes-big-left.png
@@ -419,7 +427,6 @@ share/omf/totem/totem-zh_TW.omf
%%DATADIR%%/plugins.ui
%%DATADIR%%/properties.ui
%%DATADIR%%/totem.ui
-%%DATADIR%%/totem_logo.png
%%DATADIR%%/uri.ui
%%DATADIR%%/video-list.ui
share/vala/vapi/totem.deps
@@ -430,6 +437,8 @@ share/vala/vapi/totem.vapi
@dirrm share/gnome/help/totem/zh_TW
@dirrm share/gnome/help/totem/zh_HK/figures
@dirrm share/gnome/help/totem/zh_HK
+@dirrm share/gnome/help/totem/zh_CN/figures
+@dirrm share/gnome/help/totem/zh_CN
@dirrm share/gnome/help/totem/uk/figures
@dirrm share/gnome/help/totem/uk
@dirrm share/gnome/help/totem/sv/figures
@@ -506,8 +515,6 @@ share/vala/vapi/totem.vapi
@dirrmtry share/locale/si
@dirrmtry share/locale/rw/LC_MESSAGES
@dirrmtry share/locale/rw
-@dirrmtry share/locale/ps/LC_MESSAGES
-@dirrmtry share/locale/ps
@dirrmtry share/locale/oc/LC_MESSAGES
@dirrmtry share/locale/oc
@dirrmtry share/locale/mr/LC_MESSAGES
@@ -522,6 +529,8 @@ share/vala/vapi/totem.vapi
@dirrmtry share/locale/dz
@dirrmtry share/locale/crh/LC_MESSAGES
@dirrmtry share/locale/crh
+@dirrmtry share/locale/ca@valencia/LC_MESSAGES
+@dirrmtry share/locale/ca@valencia
@dirrmtry share/locale/bn_IN/LC_MESSAGES
@dirrmtry share/locale/bn_IN
@dirrmtry share/locale/be@latin/LC_MESSAGES