aboutsummaryrefslogtreecommitdiff
path: root/multimedia/vdr-plugin-infosatepg
diff options
context:
space:
mode:
authorJuergen Lock <nox@FreeBSD.org>2013-02-16 15:04:16 +0000
committerJuergen Lock <nox@FreeBSD.org>2013-02-16 15:04:16 +0000
commit03eb5721759c4803c7bbcd86e8b2826f44320737 (patch)
tree78bec3552eba89188dfa787634cd83f2c7dcf216 /multimedia/vdr-plugin-infosatepg
parent417a7b673b50ba8d770ab50b2b9396165510555d (diff)
downloadports-03eb5721759c4803c7bbcd86e8b2826f44320737.tar.gz
ports-03eb5721759c4803c7bbcd86e8b2826f44320737.zip
- Add bugfix for infosatepg grabbing a bonded device.
- Convert Makefile header.
Notes
Notes: svn path=/head/; revision=312357
Diffstat (limited to 'multimedia/vdr-plugin-infosatepg')
-rw-r--r--multimedia/vdr-plugin-infosatepg/Makefile8
-rw-r--r--multimedia/vdr-plugin-infosatepg/files/patch-infosatepg.cpp11
2 files changed, 12 insertions, 7 deletions
diff --git a/multimedia/vdr-plugin-infosatepg/Makefile b/multimedia/vdr-plugin-infosatepg/Makefile
index 7e2fc64fdb03..2f4ba3bf7eaf 100644
--- a/multimedia/vdr-plugin-infosatepg/Makefile
+++ b/multimedia/vdr-plugin-infosatepg/Makefile
@@ -1,13 +1,9 @@
-# New ports collection makefile for: vdr-plugin-infosatepg
-# Date created: Wed Apr 14 18:11:42 CEST 2010
-# Whom: Juergen Lock <nox@freebsd.org>
-#
+# Created by: Juergen Lock <nox@freebsd.org>
# $FreeBSD$
-#
PORTNAME= vdr-plugin-infosatepg
PORTVERSION= 0.0.11
-PORTREVISION= 14
+PORTREVISION= 15
CATEGORIES= multimedia
MASTER_SITES= http://projects.vdr-developer.org/attachments/download/342/
DISTNAME= ${PORTNAME:S/-plugin-/-/}-${DISTVERSIONPREFIX}${DISTVERSION}${DISTVERSIONSUFFIX}
diff --git a/multimedia/vdr-plugin-infosatepg/files/patch-infosatepg.cpp b/multimedia/vdr-plugin-infosatepg/files/patch-infosatepg.cpp
index 4e856cf8db01..f4e30a99c38b 100644
--- a/multimedia/vdr-plugin-infosatepg/files/patch-infosatepg.cpp
+++ b/multimedia/vdr-plugin-infosatepg/files/patch-infosatepg.cpp
@@ -16,7 +16,16 @@
if (dev->IsTunedToTransponder(chan))
{
// we already have a device which is tuned (maybe switched manually?)
-@@ -403,7 +407,7 @@ cString cPluginInfosatepg::SVDRPCommand(
+@@ -202,6 +206,8 @@ void cPluginInfosatepg::MainThreadHook(v
+ return;
+ }
+
++ if (!dev->MaySwitchTransponder(chan)) continue; // bonded?
++
+ // ok -> use this device
+ dsyslog("infosatepg: found free device %i",dev->DeviceNumber()+1);
+ dev->SwitchChannel(chan,false);
+@@ -403,7 +409,7 @@ cString cPluginInfosatepg::SVDRPCommand(
cString head2;
head2="\n" \
" | | missed | | | unlocated\n" \