aboutsummaryrefslogtreecommitdiff
path: root/multimedia/vdr-plugin-osdpip
diff options
context:
space:
mode:
authorJuergen Lock <nox@FreeBSD.org>2012-06-03 18:21:42 +0000
committerJuergen Lock <nox@FreeBSD.org>2012-06-03 18:21:42 +0000
commit1636e273185d0f9be1d7e419ba6161290dd7b501 (patch)
treecd4fa165f454933aec7d43bc966de1ea71c72b13 /multimedia/vdr-plugin-osdpip
parent2dc3eeefabcaaddd86d29f2413c1434d2f68c9bc (diff)
downloadports-1636e273185d0f9be1d7e419ba6161290dd7b501.tar.gz
ports-1636e273185d0f9be1d7e419ba6161290dd7b501.zip
- Fix osdteletext plugin calling free() when it should be calling av_free(),
and update to proper vdr 1.7.27 api while I'm here. - Bump PORTREVISION.
Notes
Notes: svn path=/head/; revision=298111
Diffstat (limited to 'multimedia/vdr-plugin-osdpip')
-rw-r--r--multimedia/vdr-plugin-osdpip/Makefile2
-rw-r--r--multimedia/vdr-plugin-osdpip/files/patch-decoder.c20
-rw-r--r--multimedia/vdr-plugin-osdpip/files/patch-receiver.c20
3 files changed, 41 insertions, 1 deletions
diff --git a/multimedia/vdr-plugin-osdpip/Makefile b/multimedia/vdr-plugin-osdpip/Makefile
index b54a1a7f2996..01d393b6f457 100644
--- a/multimedia/vdr-plugin-osdpip/Makefile
+++ b/multimedia/vdr-plugin-osdpip/Makefile
@@ -7,7 +7,7 @@
PORTNAME= vdr-plugin-osdpip
PORTVERSION= 0.1.1
-PORTREVISION= 3
+PORTREVISION= 4
CATEGORIES= multimedia
MASTER_SITES= http://projects.vdr-developer.org/attachments/download/880/
DISTNAME= ${PORTNAME:S/-plugin-/-/}-${DISTVERSIONPREFIX}${DISTVERSION}${DISTVERSIONSUFFIX}
diff --git a/multimedia/vdr-plugin-osdpip/files/patch-decoder.c b/multimedia/vdr-plugin-osdpip/files/patch-decoder.c
new file mode 100644
index 000000000000..0645b3bae435
--- /dev/null
+++ b/multimedia/vdr-plugin-osdpip/files/patch-decoder.c
@@ -0,0 +1,20 @@
+--- decoder.c.orig
++++ decoder.c
+@@ -55,13 +55,13 @@ int cDecoder::Close()
+ {
+ #ifndef USE_SWSCALE
+ delete[] m_BufferConvert;
+- free(m_PicConvert);
++ av_free(m_PicConvert);
+ #endif
+ delete[] m_BufferResample;
+- free(m_PicResample);
++ av_free(m_PicResample);
+ avcodec_close(m_Context);
+- free(m_Context);
+- free(m_PicDecoded);
++ av_free(m_Context);
++ av_free(m_PicDecoded);
+
+ return 0;
+ }
diff --git a/multimedia/vdr-plugin-osdpip/files/patch-receiver.c b/multimedia/vdr-plugin-osdpip/files/patch-receiver.c
new file mode 100644
index 000000000000..c0aabbd06d53
--- /dev/null
+++ b/multimedia/vdr-plugin-osdpip/files/patch-receiver.c
@@ -0,0 +1,20 @@
+--- receiver.c.orig
++++ receiver.c
+@@ -37,11 +37,16 @@ cOsdPipReceiver::cOsdPipReceiver(const c
+ cRingBufferFrame *ESBuffer):
+ #if (APIVERSNUM < 10500)
+ cReceiver(Channel->Ca(), 0, Channel->Vpid()),
+-#else
++#elif (APIVERSNUM < 10725)
+ cReceiver(Channel->GetChannelID(), 0, Channel->Vpid()),
++#else
++ cReceiver(Channel, 0),
+ #endif
+ cThread("osdpip_receiver")
+ {
++#if (APIVERSNUM >= 10725)
++ AddPid(Channel->Vpid());
++#endif
+ m_TSBuffer = new cRingBufferLinear(MEGABYTE(3), TS_SIZE * 2, true);
+ m_TSBuffer->SetTimeouts(0, 100);
+ m_ESBuffer = ESBuffer;