aboutsummaryrefslogtreecommitdiff
path: root/multimedia/vdr-plugin-osdpip
diff options
context:
space:
mode:
authorJuergen Lock <nox@FreeBSD.org>2014-03-01 12:21:13 +0000
committerJuergen Lock <nox@FreeBSD.org>2014-03-01 12:21:13 +0000
commit47452dcb43fe706a104d820e5e33726758a0362a (patch)
tree5b514c92c45cfe80c1cae5cd74f5bbac9f011628 /multimedia/vdr-plugin-osdpip
parent7a2c2ce6e780ec6a01f1de55c980810b9175edce (diff)
downloadports-47452dcb43fe706a104d820e5e33726758a0362a.tar.gz
ports-47452dcb43fe706a104d820e5e33726758a0362a.zip
- Finally stagify the vdr ports. \o/
- Use new LIB_DEPENDS syntax. - Change multimedia/vdr-plugins defaults and bump PORTREVISION for it. (switch from xvdr to vnsiserver and disable plugins depending on ffmpeg0)
Notes
Notes: svn path=/head/; revision=346615
Diffstat (limited to 'multimedia/vdr-plugin-osdpip')
-rw-r--r--multimedia/vdr-plugin-osdpip/Makefile12
-rw-r--r--multimedia/vdr-plugin-osdpip/files/patch-Makefile2
2 files changed, 7 insertions, 7 deletions
diff --git a/multimedia/vdr-plugin-osdpip/Makefile b/multimedia/vdr-plugin-osdpip/Makefile
index 9c9500b828bb..041d872437b8 100644
--- a/multimedia/vdr-plugin-osdpip/Makefile
+++ b/multimedia/vdr-plugin-osdpip/Makefile
@@ -15,7 +15,7 @@ PATCHFILES= osdpip-vdr-1.7.26.diff
MAINTAINER= nox@FreeBSD.org
COMMENT= Video Disk Recorder - picture-in-picture plugin
-LIB_DEPENDS+= avcodec:${PORTSDIR}/multimedia/ffmpeg
+LIB_DEPENDS+= libavcodec.so:${PORTSDIR}/multimedia/ffmpeg
USES= pkgconfig
DIST_SUBDIR= vdr
@@ -25,15 +25,15 @@ HAVE_CONFIGURE= yes
PORTDOCS= COPYING README HISTORY
WRKSRC= ${WRKDIR}/${PLUGIN}-${DISTVERSION}
-NO_STAGE= yes
.include "${.CURDIR}/../vdr/Makefile.plugins"
post-patch: post-patch-plugin
+pre-install:
+ ${MKDIR} ${STAGEDIR}${PREFIX}/lib/vdr
+
post-install: post-install-pluginlocales
-.if !defined(NOPORTDOCS)
- ${MKDIR} ${DOCSDIR}
- (cd ${WRKSRC} && ${INSTALL_DATA} ${PORTDOCS} ${DOCSDIR})
-.endif
+ ${MKDIR} ${STAGEDIR}${DOCSDIR}
+ (cd ${WRKSRC} && ${INSTALL_DATA} ${PORTDOCS} ${STAGEDIR}${DOCSDIR})
.include <bsd.port.mk>
diff --git a/multimedia/vdr-plugin-osdpip/files/patch-Makefile b/multimedia/vdr-plugin-osdpip/files/patch-Makefile
index 70d9b1e7c8ff..69ad8ea22094 100644
--- a/multimedia/vdr-plugin-osdpip/files/patch-Makefile
+++ b/multimedia/vdr-plugin-osdpip/files/patch-Makefile
@@ -15,4 +15,4 @@
@-rm -f $(OBJS) $(DEPFILE) *.so *.tgz core* *~ $(PODIR)/*.mo $(PODIR)/*.pot
+
+install:
-+ ${INSTALL_PROGRAM} $(LIBDIR)/libvdr-$(PLUGIN).so.$(APIVERSION) $(PREFIX)/lib/vdr/libvdr-$(PLUGIN).so.$(APIVERSION)
++ ${INSTALL_PROGRAM} $(LIBDIR)/libvdr-$(PLUGIN).so.$(APIVERSION) ${DESTDIR}$(PREFIX)/lib/vdr/libvdr-$(PLUGIN).so.$(APIVERSION)