aboutsummaryrefslogtreecommitdiff
path: root/multimedia/vlc
diff options
context:
space:
mode:
authorJeremy Messenger <mezz@FreeBSD.org>2009-01-10 02:45:46 +0000
committerJeremy Messenger <mezz@FreeBSD.org>2009-01-10 02:45:46 +0000
commit15b6544926b07a98710eeb765baf03e3fc9a195c (patch)
tree35103cf986d2ed2295c97768e62afcc47dfed877 /multimedia/vlc
parent23fcf54562404bb41380488c8318ac0e3ce15efc (diff)
downloadports-15b6544926b07a98710eeb765baf03e3fc9a195c.tar.gz
ports-15b6544926b07a98710eeb765baf03e3fc9a195c.zip
Add a new framework for browser plugins, USE_WEBPLUGINS. It is for which foo
plugins support one of web browsers and can take care of plist (depend on how you use it) at the same time. I have written a complete document and even show how it works in the www/firefox/Makefile.webplugins so be sure to read in there. If there is anything that isn't clear in the document, please feel free to ask and I will try my best to improvement it. FYI: GNOME 2.24 depends on this, so it's coming. BTW: It's based on www/linux-mplayer-plugin/Makefile.npapi with heavy modified. Approved by: portmgr
Notes
Notes: svn path=/head/; revision=225627
Diffstat (limited to 'multimedia/vlc')
-rw-r--r--multimedia/vlc/Makefile8
-rw-r--r--multimedia/vlc/Makefile.inc9
2 files changed, 11 insertions, 6 deletions
diff --git a/multimedia/vlc/Makefile b/multimedia/vlc/Makefile
index a9a811d8344e..263181c70104 100644
--- a/multimedia/vlc/Makefile
+++ b/multimedia/vlc/Makefile
@@ -3,14 +3,14 @@
# Whom: Brian Somers <brian@FreeBSD.org>
#
# $FreeBSD$
-# $MCom: ports/multimedia/vlc-devel/Makefile,v 1.21 2006/10/01 18:16:43 ahze Exp $
+# $MCom: ports-stable/multimedia/vlc/Makefile,v 1.6 2009/01/09 23:41:21 mezz Exp $
# $Id: Makefile 6 2006-09-27 14:05:34Z buhnux $
# *** PLEASE READ Makefile.inc for more information on knobs ***
#
PORTNAME= vlc
DISTVERSION= 0.8.6i
-PORTREVISION= 2
+PORTREVISION= 3
PORTEPOCH= 2
CATEGORIES= multimedia audio ipv6 net www
MASTER_SITES= http://download.videolan.org/pub/videolan/vlc/${DISTVERSION}/ \
@@ -354,6 +354,10 @@ CONFIGURE_ENV+= MOZILLA_CONFIG="${GECKO_CONFIG}" \
XPIDL="${XPIDL}" \
XPIDL_INCL="${XPIDL_INCL}"
CONFIGURE_ARGS+=--enable-mozilla
+
+USE_WEBPLUGINS= gecko*
+WEBPLUGINS_FILES=libvlcplugin.so
+.include "${PORTSDIR}/www/firefox/Makefile.webplugins"
.endif
.if !defined(WITHOUT_MPEG2)
diff --git a/multimedia/vlc/Makefile.inc b/multimedia/vlc/Makefile.inc
index 6b88cc3bae3a..7b06e305cc87 100644
--- a/multimedia/vlc/Makefile.inc
+++ b/multimedia/vlc/Makefile.inc
@@ -4,7 +4,7 @@
# and will be autodetected to enable
#
# $FreeBSD$
-# $MCom: ports/multimedia/vlc-devel/Makefile.inc,v 1.8 2006/10/01 18:16:43 ahze Exp $
+# $MCom: ports-stable/multimedia/vlc/Makefile.inc,v 1.5 2009/01/09 23:41:21 mezz Exp $
# $Id: Makefile.inc 6 2006-09-27 14:05:34Z buhnux $
# If you define for example WITH_FAAD and WITHOUT_FAAD
# the WITHOUT_ will always over ride the WITH_.
@@ -302,7 +302,8 @@ pre-install: build
.endif
.if defined(WITH_VLC_MOZILLA_PLUGIN) && !defined(WITHOUT_VLC_MOZILLA_PLUGIN)
cd ${FAKEDIR}/mozilla && ${FIND} -s * | \
- ${SED} -e 's|^|lib/browser_plugins/|' >> ${PLIST}
+ ${SED} -e 's|^|%%WEBPLUGINS_DIR%%/|' >> ${PLIST}
+ ${ECHO_CMD} "@dirrmtry %%WEBPLUGINS_DIR%%" >> ${PLIST}
.endif
.for locale in co fur my oc ps tet tl
${ECHO_CMD} "@unexec ${RMDIR} %D/share/locale/${locale}/LC_MESSAGES 2>/dev/null || ${TRUE}" >> ${PLIST}
@@ -322,8 +323,8 @@ do-install:
cd ${FAKEDIR}/share && ${FIND} . | \
${CPIO} -vpdm -L -R ${SHAREOWN} ${PREFIX}/share
.if defined(WITH_VLC_MOZILLA_PLUGIN) && !defined(WITHOUT_VLC_MOZILLA_PLUGIN)
- @${MKDIR} ${PREFIX}/lib/browser_plugins
- ${INSTALL_DATA} ${FAKEDIR}/mozilla/* ${PREFIX}/lib/browser_plugins
+ @${MKDIR} ${WEBPLUGINS_DIR}
+ ${INSTALL_DATA} ${FAKEDIR}/mozilla/* ${WEBPLUGINS_DIR}
.endif
${INSTALL_MAN} ${WRKSRC}/doc/vlc.1 ${MANPREFIX}/man/man1/
${INSTALL_MAN} ${WRKSRC}/doc/vlc-config.1 ${MANPREFIX}/man/man1/