aboutsummaryrefslogtreecommitdiff
path: root/multimedia/x264
diff options
context:
space:
mode:
authorMario Sergio Fujikawa Ferreira <lioux@FreeBSD.org>2009-11-22 20:28:29 +0000
committerMario Sergio Fujikawa Ferreira <lioux@FreeBSD.org>2009-11-22 20:28:29 +0000
commit83960ce6709df2c895364580c33ec73c0c53c24d (patch)
tree6702c6e77bffcf258feb4e905858c3cc1e5aac5b /multimedia/x264
parenteefcf2a610e47dc07ebe93aa56ed8e20370ff2d0 (diff)
downloadports-83960ce6709df2c895364580c33ec73c0c53c24d.tar.gz
ports-83960ce6709df2c895364580c33ec73c0c53c24d.zip
- Fix build on systems where GCC stack protection (aka Propolice)
was enabled for userland on src/share/mk/bsd.sys.mk (SVN rev 180012 on 2008-06-25 21:33:28Z by ru) - For OSVERSION >= 800040, add -fstack-protector to LDFLAGS
Notes
Notes: svn path=/head/; revision=244659
Diffstat (limited to 'multimedia/x264')
-rw-r--r--multimedia/x264/Makefile7
1 files changed, 7 insertions, 0 deletions
diff --git a/multimedia/x264/Makefile b/multimedia/x264/Makefile
index ace2002880f1..b315b2be58bf 100644
--- a/multimedia/x264/Makefile
+++ b/multimedia/x264/Makefile
@@ -40,6 +40,13 @@ CONFIGURE_ARGS+= --extra-cflags="${CPPFLAGS} ${CFLAGS} -fPIC -I${LOCALBASE}/incl
.include <bsd.port.pre.mk>
+# Around the time GCC stack protection (aka Propolice) for userland
+# was enabled on src/share/mk/bsd.sys.mk
+# SVN rev 180012 on 2008-06-25 21:33:28Z by ru
+.if ${OSVERSION} >= 800040
+LDFLAGS+= -fstack-protector
+.endif
+
.if ${ARCH}=="i386"
MAKE_ENV+= ARCH_X86="1"
.endif