aboutsummaryrefslogtreecommitdiff
path: root/multimedia/xanim/Makefile
diff options
context:
space:
mode:
authorAndrew Gallatin <gallatin@FreeBSD.org>2002-06-01 22:03:31 +0000
committerAndrew Gallatin <gallatin@FreeBSD.org>2002-06-01 22:03:31 +0000
commitd7ccf63375cb9961620931e39632202210c407a0 (patch)
tree85e320170709e5b36dd74f3c724544bf88df9c3f /multimedia/xanim/Makefile
parentdb576618d0e28854e9cf02f1d5c6a9d705aca9ba (diff)
downloadports-d7ccf63375cb9961620931e39632202210c407a0.tar.gz
ports-d7ccf63375cb9961620931e39632202210c407a0.zip
Make this build and install cleanly on alpha so as to unblock the kde
build. Approved by: kris
Notes
Notes: svn path=/head/; revision=60442
Diffstat (limited to 'multimedia/xanim/Makefile')
-rw-r--r--multimedia/xanim/Makefile16
1 files changed, 15 insertions, 1 deletions
diff --git a/multimedia/xanim/Makefile b/multimedia/xanim/Makefile
index 29266b79fe43..0b829719d1dd 100644
--- a/multimedia/xanim/Makefile
+++ b/multimedia/xanim/Makefile
@@ -18,6 +18,7 @@ PATCHFILES= xanim-2801-to-2802-patch.gz
MAINTAINER= ports@FreeBSD.org
+.if (${MACHINE_ARCH} == "i386")
EXTRA_FILES= vid_cvid_2.1_freebsdELFx86.tgz \
vid_cyuv_1.0_freebsdELFx86.tgz \
vid_h261_1.0_freebsdELFx86.tgz \
@@ -25,19 +26,32 @@ EXTRA_FILES= vid_cvid_2.1_freebsdELFx86.tgz \
vid_iv32_2.1_freebsdELFx86.tgz \
vid_iv41_1.1_freebsdELFx86.tgz \
vid_iv50_1.0_freebsdELFx86.tgz
+
+DLLDIR= ${PREFIX}/lib/X11/xanim
+
+PLIST_SUB+= CODECS=""
+
+.else
+
+PLIST_SUB+= CODECS="@comment "
+
+.endif
+
USE_IMAKE= yes
MAN1= xanim.1
-DLLDIR= ${PREFIX}/lib/X11/xanim
MAKE_ARGS+= -j 2 # safe and helps even the single-CPU machines
post-extract:
${CP} ${WRKSRC}/docs/xanim.man ${WRKSRC}
+.if (${MACHINE_ARCH} == "i386")
post-install:
@${MKDIR} ${DLLDIR}
${INSTALL_DATA} ${WRKDIR}/*.readme ${DLLDIR}
${INSTALL_DATA} ${WRKDIR}/*.xa ${DLLDIR}
+.endif
+
.include <bsd.port.mk>