aboutsummaryrefslogtreecommitdiff
path: root/multimedia
diff options
context:
space:
mode:
authorBen Woods <woodsb02@FreeBSD.org>2016-06-08 16:17:25 +0000
committerBen Woods <woodsb02@FreeBSD.org>2016-06-08 16:17:25 +0000
commit6b8e13a110adfdda6549f91a3877f0a5652759f6 (patch)
tree5f34320ae57f56c54d8e0ebcbaa57f4b1427f6dc /multimedia
parent5502d7f54eac1aab283a91280056fdfdf33c1e26 (diff)
downloadports-6b8e13a110adfdda6549f91a3877f0a5652759f6.tar.gz
ports-6b8e13a110adfdda6549f91a3877f0a5652759f6.zip
multimedia/mlt:
- Update to 6.2.0 - Mark KDE4 option as implying/requiring QT4 option - Move USE_KDE4=kdelibs to new options helpers - Add USE_GNOME=cairo as notified by new stage-qa error Changes this release: http://mltframework.blogspot.fr/2016/04/version-620-released.html http://mltframework.blogspot.fr/2016/02/version-600-released.html http://mltframework.blogspot.fr/2015/07/version-098-released.html This update also allows multimedia/mlt to build against ffmpeg 3.0.x. The ports tree currently still has multimedia/ffmepg at version 2.8.7, however this update is backwards compatible with ffmpeg 2.8.7. The update of multimedia/ffmpeg to 3.0.x branch is waiting for ports which depend on it to successfully build with the newer version of ffmpeg. PR: 207390 Submitted by: olivierd Approved by: avilla (maintainer timeout), mat (mentor), makc, araujo (with kde hat) Differential Revision: https://reviews.freebsd.org/D6754
Notes
Notes: svn path=/head/; revision=416546
Diffstat (limited to 'multimedia')
-rw-r--r--multimedia/mlt/Makefile12
-rw-r--r--multimedia/mlt/distinfo5
-rw-r--r--multimedia/mlt/pkg-plist12
3 files changed, 20 insertions, 9 deletions
diff --git a/multimedia/mlt/Makefile b/multimedia/mlt/Makefile
index 11ace30a3d30..94f29ae02c6d 100644
--- a/multimedia/mlt/Makefile
+++ b/multimedia/mlt/Makefile
@@ -1,8 +1,8 @@
# $FreeBSD$
PORTNAME= mlt
-PORTVERSION= 0.9.6
-PORTREVISION?= 1
+PORTVERSION= 6.2.0
+PORTREVISION?= 0
CATEGORIES?= multimedia
MASTER_SITES= SF/${PORTNAME}/${PORTNAME}
@@ -19,7 +19,7 @@ SLAVE_PORT?= no
# They both install bin/melt.
CONFLICTS_INSTALL= freeze-[0-9]*
-USE_GNOME= libxml2
+USE_GNOME= cairo libxml2
USE_SDL= image
USES= alias gmake iconv pathfix pkgconfig
GNU_CONFIGURE= yes
@@ -66,6 +66,8 @@ JACK_CONFIGURE_ENABLE= jackrack
KDE4_CONFIGURE_ENV= PATH="${KDE4_PREFIX}/bin:$$PATH"
KDE4_CONFIGURE_WITH= kde
+KDE4_USE= kde4=kdelibs
+KDE4_IMPLIES= QT4
QT4_LIB_DEPENDS= libexif.so:graphics/libexif
QT4_USE= QT4=corelib,gui,opengl,svg,xml
@@ -94,10 +96,6 @@ VIDSTAB_CONFIGURE_ENABLE=vid.stab
BROKEN= does not compile on sparc64 (invokes i386 asm)
.endif
-.if ${PORT_OPTIONS:MKDE4} && ${PORT_OPTIONS:MQT4}
-USE_KDE4+= kdelibs
-.endif
-
.if ${PORT_OPTIONS:MVDPAU} && ${PORT_OPTIONS:MFFMPEG}
USE_XORG+= x11
.endif
diff --git a/multimedia/mlt/distinfo b/multimedia/mlt/distinfo
index 9f00fbe5564f..41f8ac571137 100644
--- a/multimedia/mlt/distinfo
+++ b/multimedia/mlt/distinfo
@@ -1,2 +1,3 @@
-SHA256 (mlt-0.9.6.tar.gz) = ab999992828a03dadbf62f6a131aada776cfd7afe63a94d994877fdba31a3000
-SIZE (mlt-0.9.6.tar.gz) = 1242448
+TIMESTAMP = 1465366021
+SHA256 (mlt-6.2.0.tar.gz) = 5acdc8760cc28b19e9dc291f66cbe3faa2bc5e8d53e2de3ef543eb5be0feb9f4
+SIZE (mlt-6.2.0.tar.gz) = 1314506
diff --git a/multimedia/mlt/pkg-plist b/multimedia/mlt/pkg-plist
index c563bc44447f..90e7a86b38d3 100644
--- a/multimedia/mlt/pkg-plist
+++ b/multimedia/mlt/pkg-plist
@@ -1,5 +1,6 @@
bin/melt
include/mlt++/Mlt.h
+include/mlt++/MltAnimation.h
include/mlt++/MltConsumer.h
include/mlt++/MltDeque.h
include/mlt++/MltEvent.h
@@ -82,10 +83,12 @@ lib/mlt/libmltxml.so
libdata/pkgconfig/mlt++.pc
libdata/pkgconfig/mlt-framework.pc
man/man1/melt.1.gz
+%%FFMPEG%%%%DATADIR%%/avformat/blacklist.txt
%%FFMPEG%%%%DATADIR%%/avformat/consumer_avformat.yml
%%FFMPEG%%%%DATADIR%%/avformat/producer_avformat.yml
%%DATADIR%%/core/consumer_multi.yml
%%DATADIR%%/core/data_fx.properties
+%%DATADIR%%/core/filter_audiomap.yml
%%DATADIR%%/core/filter_audiowave.yml
%%DATADIR%%/core/filter_brightness.yml
%%DATADIR%%/core/filter_channelcopy.yml
@@ -113,6 +116,7 @@ man/man1/melt.1.gz
%%DATADIR%%/core/producer_melt.yml
%%DATADIR%%/core/producer_melt_file.yml
%%DATADIR%%/core/producer_noise.yml
+%%DATADIR%%/core/producer_timewarp.yml
%%DATADIR%%/core/producer_tone.yml
%%DATADIR%%/core/transition_composite.yml
%%DATADIR%%/core/transition_luma.yml
@@ -217,10 +221,14 @@ man/man1/melt.1.gz
%%DATADIR%%/plus/consumer_blipflash.yml
%%DATADIR%%/plus/filter_affine.yml
%%DATADIR%%/plus/filter_charcoal.yml
+%%DATADIR%%/plus/filter_dance.yml
%%DATADIR%%/plus/filter_dynamictext.yml
+%%DATADIR%%/plus/filter_dynamic_loudness.yml
+%%DATADIR%%/plus/filter_fft.yml
%%DATADIR%%/plus/filter_invert.yml
%%DATADIR%%/plus/filter_lift_gamma_gain.yml
%%DATADIR%%/plus/filter_loudness.yml
+%%DATADIR%%/plus/filter_loudness_meter.yml
%%DATADIR%%/plus/filter_lumakey.yml
%%DATADIR%%/plus/filter_rgblut.yml
%%DATADIR%%/plus/filter_sepia.yml
@@ -233,6 +241,7 @@ man/man1/melt.1.gz
%%DATADIR%%/plusgpl/filter_rotoscoping.yml
%%DATADIR%%/presets/consumer/avformat/AAC
%%DATADIR%%/presets/consumer/avformat/Flash
+%%DATADIR%%/presets/consumer/avformat/GIF
%%DATADIR%%/presets/consumer/avformat/MJPEG
%%DATADIR%%/presets/consumer/avformat/MP3
%%DATADIR%%/presets/consumer/avformat/MPEG-2
@@ -388,6 +397,9 @@ man/man1/melt.1.gz
%%DATADIR%%/profiles/uhd_2160p_60
%%DATADIR%%/profiles/vcd_ntsc
%%DATADIR%%/profiles/vcd_pal
+%%DATADIR%%/qt/filter_audiospectrum.yml
+%%QT4%%%%DATADIR%%/qt/filter_audiowaveform.yml
+%%QT4%%%%DATADIR%%/qt/filter_lightshow.yml
%%QT4%%%%DATADIR%%/qt/producer_kdenlivetitle.yml
%%QT4%%%%DATADIR%%/qt/producer_qimage.yml
%%QT4%%%%DATADIR%%/qt/producer_qtext.yml