aboutsummaryrefslogtreecommitdiff
path: root/multimedia
diff options
context:
space:
mode:
authorTilman Keskinoz <arved@FreeBSD.org>2016-05-04 09:23:19 +0000
committerTilman Keskinoz <arved@FreeBSD.org>2016-05-04 09:23:19 +0000
commitee0a22e6df83c47996f211cb1aab82af28d55dbb (patch)
tree1c8df8169241290d387a35b83f90d9822c4be497 /multimedia
parent592a867c640302c40e1e6224e5847d0bd3025ffc (diff)
downloadports-ee0a22e6df83c47996f211cb1aab82af28d55dbb.tar.gz
ports-ee0a22e6df83c47996f211cb1aab82af28d55dbb.zip
Fix DVB support
PR: 208097 Reported by: Stefan Rumetshofer Grab back maintainership
Notes
Notes: svn path=/head/; revision=414596
Diffstat (limited to 'multimedia')
-rw-r--r--multimedia/kaffeine/Makefile4
-rw-r--r--multimedia/kaffeine/files/patch-dmx.h3
-rw-r--r--multimedia/kaffeine/files/patch-dvbdevice_linux.cpp23
-rw-r--r--multimedia/kaffeine/files/patch-frontend.h3
4 files changed, 29 insertions, 4 deletions
diff --git a/multimedia/kaffeine/Makefile b/multimedia/kaffeine/Makefile
index ca3697b32f09..e91a193c746a 100644
--- a/multimedia/kaffeine/Makefile
+++ b/multimedia/kaffeine/Makefile
@@ -3,11 +3,11 @@
PORTNAME= kaffeine
PORTVERSION= 1.3.1
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= multimedia kde
MASTER_SITES= SF/kaffeine/current
-MAINTAINER= ports@FreeBSD.org
+MAINTAINER= arved@FreeBSD.org
COMMENT= Multimedia player based on KDE and VLC
LICENSE= GPLv2+
diff --git a/multimedia/kaffeine/files/patch-dmx.h b/multimedia/kaffeine/files/patch-dmx.h
index 6d974ccef4b0..cead472ab7a8 100644
--- a/multimedia/kaffeine/files/patch-dmx.h
+++ b/multimedia/kaffeine/files/patch-dmx.h
@@ -1,6 +1,6 @@
--- include/dmx.h.orig 2015-08-07 15:43:59 UTC
+++ include/dmx.h
-@@ -24,7 +24,15 @@
+@@ -24,7 +24,16 @@
#ifndef _DVBDMX_H_
#define _DVBDMX_H_
@@ -12,6 +12,7 @@
+typedef uint32_t __u32;
+typedef uint16_t __u16;
+typedef uint8_t __u8;
++typedef int64_t __s64;
+#endif
+
#include <time.h>
diff --git a/multimedia/kaffeine/files/patch-dvbdevice_linux.cpp b/multimedia/kaffeine/files/patch-dvbdevice_linux.cpp
new file mode 100644
index 000000000000..e391c16e5a4d
--- /dev/null
+++ b/multimedia/kaffeine/files/patch-dvbdevice_linux.cpp
@@ -0,0 +1,23 @@
+--- src/dvb/dvbdevice_linux.cpp.orig 2016-05-03 12:36:58.011789000 +0200
++++ src/dvb/dvbdevice_linux.cpp 2016-05-03 12:41:02.658341000 +0200
+@@ -35,7 +35,9 @@
+ #include <sys/ioctl.h>
+ #include <sys/stat.h>
+ #include <dirent.h>
++#ifndef __FreeBSD__
+ #include <sys/inotify.h>
++#endif
+ #include <vector>
+ #include <stdlib.h>
+ #include <unistd.h>
+@@ -854,8 +856,10 @@
+
+ runstate = 1;
+
++#ifndef __FreeBSD__
+ ifd = inotify_init();
+ inotify_add_watch(ifd, "/dev/dvb", IN_CREATE|IN_DELETE);
++#endif
+ fcntl(ifd, F_SETFL, O_NONBLOCK);
+ pfd.fd = ifd;
+ pfd.events = POLLIN;
diff --git a/multimedia/kaffeine/files/patch-frontend.h b/multimedia/kaffeine/files/patch-frontend.h
index b0fec379bfed..bd28fc97ec07 100644
--- a/multimedia/kaffeine/files/patch-frontend.h
+++ b/multimedia/kaffeine/files/patch-frontend.h
@@ -1,6 +1,6 @@
--- include/frontend.h.orig 2015-08-07 15:43:59 UTC
+++ include/frontend.h
-@@ -26,7 +26,14 @@
+@@ -26,7 +26,15 @@
#ifndef _DVBFRONTEND_H_
#define _DVBFRONTEND_H_
@@ -12,6 +12,7 @@
+typedef uint32_t __u32;
+typedef uint16_t __u16;
+typedef uint8_t __u8;
++typedef int64_t __s64;
+#endif
typedef enum fe_type {