aboutsummaryrefslogtreecommitdiff
path: root/multimedia
diff options
context:
space:
mode:
authorMax Khon <fjoe@FreeBSD.org>2003-10-28 03:31:05 +0000
committerMax Khon <fjoe@FreeBSD.org>2003-10-28 03:31:05 +0000
commite8365b58f87fd38a4d2be7760377f1178ba38fec (patch)
treee5925949ba7ea4a63254fd55a4de0e4116766abb /multimedia
parentf9aee6c916deda3bb52cb3149c6d152ef60caffc (diff)
downloadports-e8365b58f87fd38a4d2be7760377f1178ba38fec.tar.gz
ports-e8365b58f87fd38a4d2be7760377f1178ba38fec.zip
Fix build with gcc 3.3.1.
Bump PORTREVISION.
Notes
Notes: svn path=/head/; revision=92386
Diffstat (limited to 'multimedia')
-rw-r--r--multimedia/xmps/Makefile9
-rw-r--r--multimedia/xmps/files/patch-codecs-video-mpeg3-motion_comp.c20
2 files changed, 22 insertions, 7 deletions
diff --git a/multimedia/xmps/Makefile b/multimedia/xmps/Makefile
index 8ce580091849..cd38292001d7 100644
--- a/multimedia/xmps/Makefile
+++ b/multimedia/xmps/Makefile
@@ -7,6 +7,7 @@
PORTNAME= xmps
PORTVERSION= 0.2.0
+PORTREVISION= 1
CATEGORIES= multimedia gnome
MASTER_SITES= http://xmps.sourceforge.net/sources/
@@ -26,12 +27,6 @@ CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
SDL_CONFIG="${SDL_CONFIG}" \
LDFLAGS="-L${LOCALBASE}/lib"
-.include <bsd.port.pre.mk>
-
-.if ${OSVERSION} >= 500113
-BROKEN= "Does not compile"
-.endif
-
post-patch:
@${REINPLACE_CMD} -e "s|-lpthread|${PTHREAD_LIBS}|g" ${WRKSRC}/configure
@${FIND} ${WRKSRC} -name "Makefile.in" | xargs ${REINPLACE_CMD} -e \
@@ -41,4 +36,4 @@ post-configure:
@${REINPLACE_CMD} -e 's|^deplibs_check_method=.*|deplibs_check_method=pass_all|' \
${WRKSRC}/libtool
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/multimedia/xmps/files/patch-codecs-video-mpeg3-motion_comp.c b/multimedia/xmps/files/patch-codecs-video-mpeg3-motion_comp.c
new file mode 100644
index 000000000000..07e2c5ae73e4
--- /dev/null
+++ b/multimedia/xmps/files/patch-codecs-video-mpeg3-motion_comp.c
@@ -0,0 +1,20 @@
+--- codecs/video/mpeg3/motion_comp.c.orig Tue Oct 28 08:53:27 2003
++++ codecs/video/mpeg3/motion_comp.c Tue Oct 28 08:55:16 2003
+@@ -66,7 +66,7 @@
+ // mc function template
+
+ #define MC_FUNC(op,xy) \
+-static void motion_comp_##op####xy##_16x16_c (uint8_t * dest, \
++static void motion_comp_##op##xy##_16x16_c (uint8_t * dest, \
+ uint8_t * ref, \
+ int stride, \
+ int height) \
+@@ -92,7 +92,7 @@
+ dest += stride; \
+ } while (--height); \
+ } \
+-static void motion_comp_##op####xy##_8x8_c (uint8_t * dest, \
++static void motion_comp_##op##xy##_8x8_c (uint8_t * dest, \
+ uint8_t * ref, \
+ int stride, \
+ int height) \