aboutsummaryrefslogtreecommitdiff
path: root/multimedia
diff options
context:
space:
mode:
authorGanael LAPLANCHE <martymac@FreeBSD.org>2016-06-15 20:41:42 +0000
committerGanael LAPLANCHE <martymac@FreeBSD.org>2016-06-15 20:41:42 +0000
commitf1ba253ca3c1dbcaf67623efe7bb57d50928c632 (patch)
tree50f51b5cd4ec0540cd2d97fee19b6f1b0cd1ecd7 /multimedia
parent123ac8a702cee50ec8bf979e80a1156492e25aa1 (diff)
downloadports-f1ba253ca3c1dbcaf67623efe7bb57d50928c632.tar.gz
ports-f1ba253ca3c1dbcaf67623efe7bb57d50928c632.zip
Fix build [1] and remove obsolete distfiles instructions
Reported by: Daniel Farfán Muñoz <daniel@farfan.cl> [1]
Notes
Notes: svn path=/head/; revision=416936
Diffstat (limited to 'multimedia')
-rw-r--r--multimedia/sms1xxx-kmod/Makefile16
-rw-r--r--multimedia/sms1xxx-kmod/files/patch-8cf5b27631
2 files changed, 34 insertions, 13 deletions
diff --git a/multimedia/sms1xxx-kmod/Makefile b/multimedia/sms1xxx-kmod/Makefile
index 5e9279ed62f2..18072efceaaa 100644
--- a/multimedia/sms1xxx-kmod/Makefile
+++ b/multimedia/sms1xxx-kmod/Makefile
@@ -3,7 +3,7 @@
PORTNAME= sms1xxx
PORTVERSION= 20120113
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= multimedia
MASTER_SITES= http://contribs.martymac.org/FreeBSD-siano/
PKGNAMESUFFIX= -kmod
@@ -54,12 +54,7 @@ DISTFILE_INSTRUCTIONS=\n\
.endif
DISTFILE_INSTRUCTIONS+= \
\n- Please, get the appropriate firmware for your Stellar device\n\
- and copy the file to '${DISTDIR}/${DIST_SUBDIR}/${STELLAR_FW}.fw'\n\
- e.g. :\n\
- wget 'ftp://ftp.terratec.net/Receiver/Cinergy_Piranha/Update/Cinergy_Piranha_Drv_Vista_XP_3.09.02.00.exe'\n\
- unzip -j 'Cinergy_Piranha_Drv_Vista_XP_3.09.02.00.exe' \\\\\n\
- \t'Cinergy Piranha/BDA Driver 3.09.02.00/Windos XP (32Bit)/SMS100x_Dvbt.inp'\n\
- mv 'SMS100x_Dvbt.inp' '${DISTDIR}/${DIST_SUBDIR}/${STELLAR_FW}.fw'\n
+ and copy the file to '${DISTDIR}/${DIST_SUBDIR}/${STELLAR_FW}.fw'\n
.endif
.endif
@@ -72,12 +67,7 @@ DISTFILE_INSTRUCTIONS=\n\
.endif
DISTFILE_INSTRUCTIONS+= \
\n- Please, get the appropriate firmware for your Nova device\n\
- and copy the file to '${DISTDIR}/${DIST_SUBDIR}/${NOVA_FW}.fw'\n\
- e.g. :\n\
- wget 'http://www.wintvcd.co.uk/drivers/WinTV-MiniStick_4_2_26_28027_WHQL.zip'\n\
- unzip -j 'WinTV-MiniStick_4_2_26_28027_WHQL.zip' \\\\\n\
- \t'driver17/hcw17dvb.1b0'\n\
- mv 'hcw17dvb.1b0' '${DISTDIR}/${DIST_SUBDIR}/${NOVA_FW}.fw'\n
+ and copy the file to '${DISTDIR}/${DIST_SUBDIR}/${NOVA_FW}.fw'\n
.endif
.endif
diff --git a/multimedia/sms1xxx-kmod/files/patch-8cf5b276 b/multimedia/sms1xxx-kmod/files/patch-8cf5b276
new file mode 100644
index 000000000000..2ef03b9c531d
--- /dev/null
+++ b/multimedia/sms1xxx-kmod/files/patch-8cf5b276
@@ -0,0 +1,31 @@
+commit 8cf5b276a25047ed9cef710f73c59e0f63d7f337
+Author: Ganael Laplanche <ganael.laplanche@martymac.org>
+Date: Wed Feb 11 09:04:46 2015 +0100
+
+ Use int instead of u8 for variables handled through SYSCTL_ADD_INT
+
+--- sms1xxx-gpio.h.orig
++++ sms1xxx-gpio.h
+@@ -88,7 +88,7 @@ struct sms1xxx_gpio {
+ /* Other */
+ u32 get_res; /* last GET result */
+ int status_led_state; /* current status led state */
+- u8 use_lna; /* sysctl, use LNA when tuning ? */
++ int use_lna; /* sysctl, use LNA when tuning ? */
+ };
+
+ int sms1xxx_gpio_get_pin_params(u32, u32 *, u32 *, u32 *);
+--- sms1xxx-ir.h.orig
++++ sms1xxx-ir.h
+@@ -37,9 +37,9 @@
+ /* Board IR configuration */
+ struct sms1xxx_ir {
+ /* IR module state */
+- u8 module_avail; /* Has board an IR module ?
++ int module_avail; /* Has board an IR module ?
+ XXX Should be based on GPIO cfg ? */
+- u8 module_started; /* Is IR module started ? */
++ int module_started; /* Is IR module started ? */
+ struct cdev *dev; /* ir0 device */
+
+ /* MSG_SMS_START_IR_REQ Msg parameters */