aboutsummaryrefslogtreecommitdiff
path: root/multimedia
diff options
context:
space:
mode:
authorOliver Braun <obraun@FreeBSD.org>2003-02-12 07:17:35 +0000
committerOliver Braun <obraun@FreeBSD.org>2003-02-12 07:17:35 +0000
commite6647e93a223a0bd4ae66d0cfde68122c7b25465 (patch)
treefc933fba54d4d5cf4dae87e342392c5e06797da1 /multimedia
parentbcb633199aed03d0371079b6ad34ea8549036f73 (diff)
downloadports-e6647e93a223a0bd4ae66d0cfde68122c7b25465.tar.gz
ports-e6647e93a223a0bd4ae66d0cfde68122c7b25465.zip
* Add patch forgotten to "cvs add" in last commit.
* Bump PORTREVISION. Noticed by: lioux
Notes
Notes: svn path=/head/; revision=75348
Diffstat (limited to 'multimedia')
-rw-r--r--multimedia/mplayer/Makefile1
-rw-r--r--multimedia/mplayer/files/patch-libmpdemux::demux_mov23
2 files changed, 24 insertions, 0 deletions
diff --git a/multimedia/mplayer/Makefile b/multimedia/mplayer/Makefile
index 958db2055e7f..7988f110fd23 100644
--- a/multimedia/mplayer/Makefile
+++ b/multimedia/mplayer/Makefile
@@ -146,6 +146,7 @@
PORTNAME= mplayer
PORTVERSION= 0.90.0.104
+PORTREVISION= 1
CATEGORIES= multimedia audio
MASTER_SITES= http://www1.mplayerhq.hu/MPlayer/releases/ \
http://www2.mplayerhq.hu/MPlayer/releases/ \
diff --git a/multimedia/mplayer/files/patch-libmpdemux::demux_mov b/multimedia/mplayer/files/patch-libmpdemux::demux_mov
new file mode 100644
index 000000000000..5e866b571544
--- /dev/null
+++ b/multimedia/mplayer/files/patch-libmpdemux::demux_mov
@@ -0,0 +1,23 @@
+--- libmpdemux/demux_mov.c.orig Sat Feb 8 11:31:57 2003
++++ libmpdemux/demux_mov.c Sat Feb 8 11:32:29 2003
+@@ -597,7 +597,10 @@
+ unsigned int fourcc=stream_read_dword_le(demuxer->stream);
+ if(len<8) break; // error
+ mp_msg(MSGT_DEMUX,MSGL_V,"MOV: %*s desc #%d: %.4s (%d bytes)\n",level,"",i,&fourcc,len-16);
+- if(!i){
++ if(fourcc!=trak->fourcc && i)
++ mp_msg(MSGT_DEMUX,MSGL_WARN,MSGTR_MOVvariableFourCC);
++ //if(!i)
++ {
+ trak->fourcc=fourcc;
+ // read type specific (audio/video/time/text etc) header
+ // NOTE: trak type is not yet known at this point :(((
+@@ -605,8 +608,6 @@
+ trak->stdata=malloc(trak->stdata_len);
+ stream_read(demuxer->stream,trak->stdata,trak->stdata_len);
+ }
+- if(fourcc!=trak->fourcc && i)
+- mp_msg(MSGT_DEMUX,MSGL_WARN,MSGTR_MOVvariableFourCC);
+ if(!stream_seek(demuxer->stream,pos+len)) break;
+ }
+ break;