aboutsummaryrefslogtreecommitdiff
path: root/multimedia
diff options
context:
space:
mode:
authorTilman Keskinoz <arved@FreeBSD.org>2003-01-08 20:32:37 +0000
committerTilman Keskinoz <arved@FreeBSD.org>2003-01-08 20:32:37 +0000
commitf7fdddf901ea563ce5b0578bfd007282889a7244 (patch)
tree39bae59dee781583ebcb777605ba49193326b278 /multimedia
parentc3bfb150a988262ad076e37f4fd18b659d4ac623 (diff)
downloadports-f7fdddf901ea563ce5b0578bfd007282889a7244.tar.gz
ports-f7fdddf901ea563ce5b0578bfd007282889a7244.zip
Add slideshow, a tool to write slides in python or XML
PR: 45832 Submitted by: Stefan Farfeleder <e0026813@stud3.tuwien.ac.at>
Notes
Notes: svn path=/head/; revision=72759
Diffstat (limited to 'multimedia')
-rw-r--r--multimedia/Makefile1
-rw-r--r--multimedia/slideshow/Makefile66
-rw-r--r--multimedia/slideshow/distinfo1
-rw-r--r--multimedia/slideshow/files/patch-src::EffectDarkness.cpp13
-rw-r--r--multimedia/slideshow/files/patch-src::FontVault.h11
-rw-r--r--multimedia/slideshow/files/patch-src::Makefile.in11
-rw-r--r--multimedia/slideshow/pkg-comment1
-rw-r--r--multimedia/slideshow/pkg-descr19
-rw-r--r--multimedia/slideshow/pkg-message2
-rw-r--r--multimedia/slideshow/pkg-plist24
10 files changed, 149 insertions, 0 deletions
diff --git a/multimedia/Makefile b/multimedia/Makefile
index 13036c49a28f..fccda3d3dfdf 100644
--- a/multimedia/Makefile
+++ b/multimedia/Makefile
@@ -34,6 +34,7 @@
SUBDIR += openquicktime
SUBDIR += oqtencoder
SUBDIR += oqtplayer
+ SUBDIR += slideshow
SUBDIR += tosvcd
SUBDIR += vcdgear
SUBDIR += vcdimager
diff --git a/multimedia/slideshow/Makefile b/multimedia/slideshow/Makefile
new file mode 100644
index 000000000000..719c7eb602fc
--- /dev/null
+++ b/multimedia/slideshow/Makefile
@@ -0,0 +1,66 @@
+# New ports collection makefile for: slideshow
+# Date created: 26 November 2002
+# Whom: Stefan Farfeleder <e0026813@stud3.tuwien.ac.at>
+#
+# $FreeBSD$
+#
+
+PORTNAME= slideshow
+PORTVERSION= 0.8.0.p4
+CATEGORIES= multimedia
+MASTER_SITES= http://savannah.nongnu.org/download/${PORTNAME}/${PORTNAME}.pkg/${PORTVERSION:S/.p/-pre/}/
+DISTNAME= ${PORTNAME}-${PORTVERSION:S/.p/-pre/}
+
+MAINTAINER= e0026813@stud3.tuwien.ac.at
+
+LIB_DEPENDS= SDL_ttf.3:${PORTSDIR}/graphics/sdl_ttf \
+ SDL_image.10:${PORTSDIR}/graphics/sdl_image \
+ xml2.5:${PORTSDIR}/textproc/libxml2 \
+ smpeg.1:${PORTSDIR}/graphics/smpeg
+
+SDL_CONFIG?= ${LOCALBASE}/bin/sdl11-config
+INSTALLS_SHLIB= yes
+USE_LIBTOOL= yes
+USE_PYTHON= yes
+USE_REINPLACE= yes
+CONFIGURE_ARGS+= --disable-gtk-gui
+CONFIGURE_ENV+= SDL_CONFIG="${SDL_CONFIG}" LDFLAGS="-lstdc++"
+
+.include <bsd.port.pre.mk>
+
+# The default resolution is 640x480
+.if defined(WITH_RES_1024)
+CONFIGURE_ARGS+= --with-res=1024
+.elif defined(WITH_RES_800)
+CONFIGURE_ARGS+= --with-res=800
+.endif
+
+pre-patch:
+ @${REINPLACE_CMD} -e '/SUBDIRS =/s/doc//' ${WRKSRC}/Makefile.in
+.if defined(NOPORTDOCS)
+ @${REINPLACE_CMD} -e '/SUBDIRS =/s/examples//' ${WRKSRC}/Makefile.in
+.endif
+
+post-configure:
+ @${REINPLACE_CMD} -e "/^pythondir/s|= .*|= ${PYTHONPREFIX_SITELIBDIR}|"\
+ ${WRKSRC}/src/Makefile
+
+do-install:
+ @(cd ${WRKSRC}/src; ${MAKE} install)
+.if !defined(NOPORTDOCS)
+ @${MKDIR} ${DOCSDIR}
+ @${MKDIR} ${EXAMPLESDIR}
+ ${INSTALL_MAN} ${WRKSRC}/README ${DOCSDIR}
+# Don't install Simple.py, it is broken
+.for file in AutoSlide.py Backgrounds.py Simple.xml Stages.py Text.py Video.py \
+ Xml.py slideshow.dtd speedfull.jpg standard.ttf
+ ${INSTALL_MAN} ${WRKSRC}/examples/${file} ${EXAMPLESDIR}
+.endfor
+.endif
+
+post-install:
+ @${STRIP_CMD} ${PREFIX}/lib/libslideshow.so.0
+# @${STRIP_CMD} ${PYTHONPREFIX_SITELIBDIR}/_slideshow.so
+ @${CAT} ${PKGMESSAGE}
+
+.include <bsd.port.post.mk>
diff --git a/multimedia/slideshow/distinfo b/multimedia/slideshow/distinfo
new file mode 100644
index 000000000000..ddf26e0a5a6e
--- /dev/null
+++ b/multimedia/slideshow/distinfo
@@ -0,0 +1 @@
+MD5 (slideshow-0.8.0-pre4.tar.gz) = b17746903b43c62ae7f667de774c5a97
diff --git a/multimedia/slideshow/files/patch-src::EffectDarkness.cpp b/multimedia/slideshow/files/patch-src::EffectDarkness.cpp
new file mode 100644
index 000000000000..1516ff993e60
--- /dev/null
+++ b/multimedia/slideshow/files/patch-src::EffectDarkness.cpp
@@ -0,0 +1,13 @@
+--- src/EffectDarkness.cpp.orig Fri Nov 29 01:06:50 2002
++++ src/EffectDarkness.cpp Fri Nov 29 01:07:20 2002
+@@ -52,8 +52,8 @@
+ int dt = screen->format->BytesPerPixel;
+
+ // Sorry, work to do
+- assert (ds == 4 || ds == 3);
+- assert (dt == 4 || ds == 3);
++ if (ds != 4 && ds != 3) return;
++ if (dt != 4 && ds != 3) return;
+
+
+ for (int i=0; i< parent_surface->w * parent_surface->h; i++) {
diff --git a/multimedia/slideshow/files/patch-src::FontVault.h b/multimedia/slideshow/files/patch-src::FontVault.h
new file mode 100644
index 000000000000..a3bc7e73769d
--- /dev/null
+++ b/multimedia/slideshow/files/patch-src::FontVault.h
@@ -0,0 +1,11 @@
+--- src/FontVault.h.orig Fri Nov 22 00:07:06 2002
++++ src/FontVault.h Thu Nov 28 23:41:37 2002
+@@ -34,7 +34,7 @@
+ }
+ };
+
+-#if (HASHMAP_NAMESPACE == __gnu_cxx)
++#if defined(HAVE_GNU_CXX_HASHMAP)
+ typedef __gnu_cxx::hash_map<std::string, TTF_Font*, ures_hasher, ures_eqstr> Fonts_HashMap;
+ #else
+ typedef std::hash_map<std::string, TTF_Font*, ures_hasher, ures_eqstr> Fonts_HashMap;
diff --git a/multimedia/slideshow/files/patch-src::Makefile.in b/multimedia/slideshow/files/patch-src::Makefile.in
new file mode 100644
index 000000000000..e22622e96bee
--- /dev/null
+++ b/multimedia/slideshow/files/patch-src::Makefile.in
@@ -0,0 +1,11 @@
+--- src/Makefile.in.orig Wed Nov 27 01:32:38 2002
++++ src/Makefile.in Wed Nov 27 01:32:48 2002
+@@ -790,8 +790,6 @@
+ uninstall-recursive
+
+
+-MgpLoaderLex.cpp: MgpLoader.ll
+- flex++ -i -oMgpLoaderLex.cpp MgpLoader.ll
+
+ #
+ # Python wrapper
diff --git a/multimedia/slideshow/pkg-comment b/multimedia/slideshow/pkg-comment
new file mode 100644
index 000000000000..c340a8e4d4e9
--- /dev/null
+++ b/multimedia/slideshow/pkg-comment
@@ -0,0 +1 @@
+A slideshow presentation tool to write slides in Python or XML
diff --git a/multimedia/slideshow/pkg-descr b/multimedia/slideshow/pkg-descr
new file mode 100644
index 000000000000..fe1e060728cb
--- /dev/null
+++ b/multimedia/slideshow/pkg-descr
@@ -0,0 +1,19 @@
+Slideshow allows you to write slides in Python or XML. Some features it has to
+offer:
+
+- Use of TrueType fonts
+- Showing stages in a slide
+- Progressive show of text and images
+- Scrolling of text and images
+- Special effects:
+ * Spinner
+ * Fires
+ * Stars
+ * Plasma
+ * Darkness
+- MPEG videos support
+
+WWW: http://www.alobbs.com/slideshow
+
+-- Stefan Farfeleder
+e0026813@stud3.tuwien.ac.at
diff --git a/multimedia/slideshow/pkg-message b/multimedia/slideshow/pkg-message
new file mode 100644
index 000000000000..3ecc67ad1aaa
--- /dev/null
+++ b/multimedia/slideshow/pkg-message
@@ -0,0 +1,2 @@
+This port still has some bugs when used with a colour depth less than 24 bits.
+For now, your have to use this depth for full functionality.
diff --git a/multimedia/slideshow/pkg-plist b/multimedia/slideshow/pkg-plist
new file mode 100644
index 000000000000..74b580838fca
--- /dev/null
+++ b/multimedia/slideshow/pkg-plist
@@ -0,0 +1,24 @@
+%%PORTDOCS%%%%DOCSDIR%%/README
+%%PORTDOCS%%%%EXAMPLESDIR%%/AutoSlide.py
+%%PORTDOCS%%%%EXAMPLESDIR%%/Backgrounds.py
+%%PORTDOCS%%%%EXAMPLESDIR%%/Simple.xml
+%%PORTDOCS%%%%EXAMPLESDIR%%/Stages.py
+%%PORTDOCS%%%%EXAMPLESDIR%%/Text.py
+%%PORTDOCS%%%%EXAMPLESDIR%%/Video.py
+%%PORTDOCS%%%%EXAMPLESDIR%%/Xml.py
+%%PORTDOCS%%%%EXAMPLESDIR%%/slideshow.dtd
+%%PORTDOCS%%%%EXAMPLESDIR%%/speedfull.jpg
+%%PORTDOCS%%%%EXAMPLESDIR%%/standard.ttf
+%%PORTDOCS%%@dirrm %%DOCSDIR%%
+%%PORTDOCS%%@dirrm %%EXAMPLESDIR%%
+%%PYTHON_SITELIBDIR%%/_slideshow.a
+%%PYTHON_SITELIBDIR%%/_slideshow.la
+%%PYTHON_SITELIBDIR%%/_slideshow.so
+%%PYTHON_SITELIBDIR%%/slideshow.py
+%%PYTHON_SITELIBDIR%%/slideshow.pyc
+%%PYTHON_SITELIBDIR%%/slideshow.pyo
+bin/slideshow
+lib/libslideshow.a
+lib/libslideshow.la
+lib/libslideshow.so
+lib/libslideshow.so.0