aboutsummaryrefslogtreecommitdiff
path: root/multimedia
diff options
context:
space:
mode:
authorDmitry Marakasov <amdmi3@FreeBSD.org>2008-08-21 19:25:33 +0000
committerDmitry Marakasov <amdmi3@FreeBSD.org>2008-08-21 19:25:33 +0000
commit3273e46b7c6a3d3cd9aee5ff2087dfb2859deabb (patch)
treec850cf58a5b938d76e88662986d796cdf02cca50 /multimedia
parent96454e54504fbeb94970aa27f9b85dd2ebeca224 (diff)
downloadports-3273e46b7c6a3d3cd9aee5ff2087dfb2859deabb.tar.gz
ports-3273e46b7c6a3d3cd9aee5ff2087dfb2859deabb.zip
flvtool++ is a tool for hinting and manipulating the metadata of FLV
files. It was originally created for Facebook's Video project (http://facebook.com/video/) for fast video hinting. It is loosely based on the Ruby FLVTool2, but is written in C++ for performance reasons. WWW: http://mirror.facebook.com/facebook/flvtool++/ PR: ports/126336 Submitted by: Gea-Suan Lin <gslin at gslin dot org>
Notes
Notes: svn path=/head/; revision=218966
Diffstat (limited to 'multimedia')
-rw-r--r--multimedia/Makefile1
-rw-r--r--multimedia/flvtool++/Makefile31
-rw-r--r--multimedia/flvtool++/distinfo3
-rw-r--r--multimedia/flvtool++/files/patch-AMFData.h10
-rw-r--r--multimedia/flvtool++/files/patch-SConstruct11
-rw-r--r--multimedia/flvtool++/files/patch-common.h13
-rw-r--r--multimedia/flvtool++/pkg-descr7
7 files changed, 76 insertions, 0 deletions
diff --git a/multimedia/Makefile b/multimedia/Makefile
index e37dbcfe1701..c2abad587f3c 100644
--- a/multimedia/Makefile
+++ b/multimedia/Makefile
@@ -41,6 +41,7 @@
SUBDIR += ffmpeg
SUBDIR += ffmpegthumbnailer
SUBDIR += flv2mpeg4
+ SUBDIR += flvtool++
SUBDIR += freevo
SUBDIR += fxtv
SUBDIR += gaupol
diff --git a/multimedia/flvtool++/Makefile b/multimedia/flvtool++/Makefile
new file mode 100644
index 000000000000..6f19caea74de
--- /dev/null
+++ b/multimedia/flvtool++/Makefile
@@ -0,0 +1,31 @@
+# New ports collection makefile for: flvtool++
+# Date created: 2008-08-07
+# Whom: Gea-Suan Lin <gslin@gslin.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= flvtool++
+PORTVERSION= 1.1
+CATEGORIES= multimedia
+MASTER_SITES= http://mirror.facebook.com/facebook/flvtool++/
+
+MAINTAINER= gslin@gslin.org
+COMMENT= Tool for hinting and manipulating the metadata of FLV files
+
+LIB_DEPENDS= boost_iostreams:${PORTSDIR}/devel/boost
+
+CFLAGS+= -I${LOCALBASE}/include/boost
+NO_WRKSUBDIR= yes
+PLIST_FILES= bin/flvtool++
+USE_SCONS= yes
+SCONS_BUILDENV= ${SCONS_ENV}
+
+post-patch:
+ ${REINPLACE_CMD} -e 's|/usr/local/include/boost-1_33_1|${LOCALBASE}/include|' \
+ ${WRKSRC}/SConscript
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/flvtool++ ${PREFIX}/bin
+
+.include <bsd.port.mk>
diff --git a/multimedia/flvtool++/distinfo b/multimedia/flvtool++/distinfo
new file mode 100644
index 000000000000..17740b27cc05
--- /dev/null
+++ b/multimedia/flvtool++/distinfo
@@ -0,0 +1,3 @@
+MD5 (flvtool++-1.1.tar.gz) = 817e94b46270dd09ae1e88289c38fb7d
+SHA256 (flvtool++-1.1.tar.gz) = 12729726d870edc3c2130837a12a51249f928a6c2bbf11c8d8d5bc7a003d0f90
+SIZE (flvtool++-1.1.tar.gz) = 11071
diff --git a/multimedia/flvtool++/files/patch-AMFData.h b/multimedia/flvtool++/files/patch-AMFData.h
new file mode 100644
index 000000000000..615b9ddf5f3d
--- /dev/null
+++ b/multimedia/flvtool++/files/patch-AMFData.h
@@ -0,0 +1,10 @@
+--- AMFData.h.orig 2008-08-07 21:59:28.000000000 +0800
++++ AMFData.h 2008-08-07 21:59:34.000000000 +0800
+@@ -8,7 +8,6 @@
+ #pragma once
+
+ #include "common.h"
+-#include <byteswap.h>
+ #include <float.h>
+ #include <math.h>
+ #include <netinet/in.h>
diff --git a/multimedia/flvtool++/files/patch-SConstruct b/multimedia/flvtool++/files/patch-SConstruct
new file mode 100644
index 000000000000..114560c0d4e8
--- /dev/null
+++ b/multimedia/flvtool++/files/patch-SConstruct
@@ -0,0 +1,11 @@
+--- SConstruct.orig 2007-09-08 03:24:22.000000000 +0400
++++ SConstruct 2008-08-21 20:38:10.000000000 +0400
+@@ -1,5 +1,7 @@
++import os
++
+ libd = '#lib/'
+-env = Environment(CPPFLAGS='-ggdb -O3 -Wall', LINKFLAGS='-ggdb')
++env = Environment(CXX=os.environ['CXX'], CXXFLAGS=os.environ['CXXFLAGS'], ENV=os.environ)
+ env.TargetSignatures('content')
+
+ Export('env libd')
diff --git a/multimedia/flvtool++/files/patch-common.h b/multimedia/flvtool++/files/patch-common.h
new file mode 100644
index 000000000000..5dce479ea6c0
--- /dev/null
+++ b/multimedia/flvtool++/files/patch-common.h
@@ -0,0 +1,13 @@
+--- common.h.orig 2008-08-07 21:56:41.000000000 +0800
++++ common.h 2008-08-07 21:58:29.000000000 +0800
+@@ -19,6 +19,10 @@
+ #include <boost/shared_ptr.hpp>
+ #include <stdexcept>
+
++#include <sys/endian.h>
++
++#define bswap_64 bswap64
++
+ using std::map;
+ using std::vector;
+ using std::string;
diff --git a/multimedia/flvtool++/pkg-descr b/multimedia/flvtool++/pkg-descr
new file mode 100644
index 000000000000..4abeed0615f6
--- /dev/null
+++ b/multimedia/flvtool++/pkg-descr
@@ -0,0 +1,7 @@
+flvtool++ is a tool for hinting and manipulating the metadata of FLV
+files. It was originally created for Facebook's Video project
+(http://facebook.com/video/) for fast video hinting. It is loosely
+based on the Ruby FLVTool2, but is written in C++ for performance
+reasons.
+
+WWW: http://mirror.facebook.com/facebook/flvtool++/