aboutsummaryrefslogtreecommitdiff
path: root/multimedia
diff options
context:
space:
mode:
authorFlorent Thoumie <flz@FreeBSD.org>2008-08-28 11:32:47 +0000
committerFlorent Thoumie <flz@FreeBSD.org>2008-08-28 11:32:47 +0000
commite65a34d9ca72e4cf4f35ab059ce792747a59233d (patch)
treec8fa5d481d63f93ba1a99afc948f20fff6e4014b /multimedia
parent272b2e639a4779656c69283870b3edfca6e2961c (diff)
downloadports-e65a34d9ca72e4cf4f35ab059ce792747a59233d.tar.gz
ports-e65a34d9ca72e4cf4f35ab059ce792747a59233d.zip
Add multimedia/banshee, a multimedia player for the Gnome desktop.
Notes
Notes: svn path=/head/; revision=219371
Diffstat (limited to 'multimedia')
-rw-r--r--multimedia/Makefile1
-rw-r--r--multimedia/banshee/Makefile80
-rw-r--r--multimedia/banshee/distinfo3
-rw-r--r--multimedia/banshee/files/patch-svn-432134
-rw-r--r--multimedia/banshee/pkg-descr11
-rw-r--r--multimedia/banshee/pkg-plist181
6 files changed, 310 insertions, 0 deletions
diff --git a/multimedia/Makefile b/multimedia/Makefile
index c2abad587f3c..5686146714c8 100644
--- a/multimedia/Makefile
+++ b/multimedia/Makefile
@@ -10,6 +10,7 @@
SUBDIR += avidemux2
SUBDIR += avifile
SUBDIR += avinfo
+ SUBDIR += banshee
SUBDIR += beep-media-player
SUBDIR += bmp-extra-plugins
SUBDIR += bmpx
diff --git a/multimedia/banshee/Makefile b/multimedia/banshee/Makefile
new file mode 100644
index 000000000000..476222939f26
--- /dev/null
+++ b/multimedia/banshee/Makefile
@@ -0,0 +1,80 @@
+# New ports collection makefile for: banshee
+# Date created: Jul 10 2006
+# Whom: Florent Thoumie <flz@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= banshee
+PORTVERSION= 1.2.1
+CATEGORIES= multimedia audio
+MASTER_SITES= http://download.banshee-project.org/banshee/
+DISTNAME= ${PORTNAME}-1-${PORTVERSION}
+
+MAINTAINER= flz@FreeBSD.org
+COMMENT= Music management and playback for gnome
+
+BUILD_DEPENDS= ${SITE_PERL}/${PERL_ARCH}/XML/Parser.pm:${PORTSDIR}/textproc/p5-XML-Parser
+
+LIB_PC_DEPENDS= ${LOCALBASE}/libdata/pkgconfig/mono.pc:${PORTSDIR}/lang/mono \
+ ${LOCALBASE}/libdata/pkgconfig/ndesk-dbus-1.0.pc:${PORTSDIR}/devel/ndesk-dbus \
+ ${LOCALBASE}/libdata/pkgconfig/ndesk-dbus-glib-1.0.pc:${PORTSDIR}/devel/ndesk-dbus-glib \
+ ${LOCALBASE}/libdata/pkgconfig/taglib-sharp.pc:${PORTSDIR}/audio/taglib-sharp \
+ ${LOCALBASE}/libdata/pkgconfig/mono-zeroconf.pc:${PORTSDIR}/net/mono-zeroconf \
+ ${LOCALBASE}/libdata/pkgconfig/mono-addins.pc:${PORTSDIR}/devel/mono-addins \
+ ${LOCALBASE}/libdata/pkgconfig/sqlite3.pc:${PORTSDIR}/databases/sqlite3
+
+OPTIONS= DOCS "Install documentation" on
+
+USE_BZIP2= yes
+USE_GMAKE= yes
+USE_PERL5_BUILD=yes
+GNU_CONFIGURE= yes
+USE_GNOME= gnomehack gtksharp20 gnomesharp20
+USE_GSTREAMER= yes
+USE_GETTEXT= yes
+USE_LDCONFIG= ${PREFIX}/lib/${PORTNAME}-1
+USE_XORG= xrandr xxf86vm
+INSTALLS_ICONS= yes
+CONFIGURE_TARGET= --build=${ARCH}-portbld-freebsd${OSREL}
+CONFIGURE_ARGS+= --disable-boo --disable-ipod --disable-mtp
+
+.include <bsd.port.pre.mk>
+.include "${.CURDIR}/../../lang/mono/bsd.mono.mk"
+
+.if !defined(WITHOUT_DOCS) && !defined(NOPORTDOCS)
+BUILD_DEPENDS+= ${LOCALBASE}/bin/monodocer:${PORTSDIR}/devel/monodoc
+.else
+CONFIGURE_ARGS+= --disable-docs
+.endif
+
+post-patch:
+ @${REINPLACE_CMD} 's|#!/bin/bash|#!/bin/sh|' \
+ ${WRKSRC}/src/Clients/banshee-1.in \
+ ${WRKSRC}/build/icon-theme-installer \
+ ${WRKSRC}/build/private-icon-theme-installer
+ @${REINPLACE_CMD} 's|\[\[|\[|g;s|\]\]|\]|g;s|==|=|g;s/||/-o/g' \
+ ${WRKSRC}/build/private-icon-theme-installer
+ @${REINPLACE_CMD} 's|-a banshee-1||' \
+ ${WRKSRC}/src/Clients/banshee-1.in
+# @${REINPLACE_CMD} 's|sed -r|sed|' \
+# ${WRKSRC}/configure \
+# ${WRKSRC}/data/icon-theme-hicolor/Makefile.in
+
+# XXX - This is gross.
+post-configure:
+ @${REINPLACE_CMD} -e 's|^\(MSGFMT =\)|\1 ${LOCALBASE}/bin/msgfmt|' \
+ -e 's|^\(GMSGFMT =\)|\1 ${LOCALBASE}/bin/msgfmt|' \
+ ${WRKSRC}/po/Makefile
+
+pre-build:
+.for i in 16x16 22x22 48x48 scalable
+ ${MKDIR} ${WRKSRC}/bin/share/banshee-1/icons/hicolor/$i/categories
+.endfor
+
+pre-install:
+.for i in 16x16 22x22 48x48 scalable
+ ${MKDIR} ${PREFIX}/share/banshee-1/icons/hicolor/$i/categories
+.endfor
+
+.include <bsd.port.post.mk>
diff --git a/multimedia/banshee/distinfo b/multimedia/banshee/distinfo
new file mode 100644
index 000000000000..e6a3fa93e92b
--- /dev/null
+++ b/multimedia/banshee/distinfo
@@ -0,0 +1,3 @@
+MD5 (banshee-1-1.2.1.tar.bz2) = 4537d105352b465049953f72da34d3d8
+SHA256 (banshee-1-1.2.1.tar.bz2) = b8380b52a8660b499605fbdee86d00e309a88c3bc822ba30b5b7521e16bec9c0
+SIZE (banshee-1-1.2.1.tar.bz2) = 2115306
diff --git a/multimedia/banshee/files/patch-svn-4321 b/multimedia/banshee/files/patch-svn-4321
new file mode 100644
index 000000000000..4f449e5bdee6
--- /dev/null
+++ b/multimedia/banshee/files/patch-svn-4321
@@ -0,0 +1,34 @@
+Index: src/Extensions/Banshee.Lastfm/Banshee.Lastfm.Recommendations/RecommendationService.cs
+===================================================================
+--- src/Extensions/Banshee.Lastfm/Banshee.Lastfm.Recommendations/RecommendationService.cs (revision 4321)
++++ src/Extensions/Banshee.Lastfm/Banshee.Lastfm.Recommendations/RecommendationService.cs (working copy)
+@@ -110,7 +110,7 @@
+
+ private void UpdateVisibility ()
+ {
+- bool source_is_playback_source = (ServiceManager.SourceManager.ActiveSource == ServiceManager.PlaybackController.Source);
++ bool source_is_playback_source = (ServiceManager.SourceManager.ActiveSource as Banshee.Sources.ITrackModelSource) == ServiceManager.PlaybackController.Source;
+ pane.ShowWhenReady = ShowSchema.Get () && source_is_playback_source;
+ if (!source_is_playback_source) {
+ pane.HideWithTimeout ();
+Index: src/Libraries/Hyena/Hyena.Collections/QueuePipelineElement.cs
+===================================================================
+--- src/Libraries/Hyena/Hyena.Collections/QueuePipelineElement.cs (revision 4321)
++++ src/Libraries/Hyena/Hyena.Collections/QueuePipelineElement.cs (working copy)
+@@ -32,12 +32,12 @@
+
+ namespace Hyena.Collections
+ {
++ internal class ElementProcessCanceledException : ApplicationException
++ {
++ }
++
+ public abstract class QueuePipelineElement<T> where T : class
+ {
+- private class ElementProcessCanceledException : ApplicationException
+- {
+- }
+-
+ private Queue<T> queue = new Queue<T> ();
+ private object monitor = new object ();
+ private AutoResetEvent thread_wait;
diff --git a/multimedia/banshee/pkg-descr b/multimedia/banshee/pkg-descr
new file mode 100644
index 000000000000..6481156bf6da
--- /dev/null
+++ b/multimedia/banshee/pkg-descr
@@ -0,0 +1,11 @@
+Import, organize, play, and share your music using Banshee's simple,
+powerful interface. Rip CDs, play and sync your iPod, create playlists,
+and burn audio and MP3 CDs. Most portable music devices are supported.
+
+Banshee also has support for podcasting, smart playlists, music
+recommendations, and much more.
+
+WWW: http://banshee-project.org/
+
+- Florent Thoumie
+flz@FreeBSD.org
diff --git a/multimedia/banshee/pkg-plist b/multimedia/banshee/pkg-plist
new file mode 100644
index 000000000000..29c8b938f4ed
--- /dev/null
+++ b/multimedia/banshee/pkg-plist
@@ -0,0 +1,181 @@
+bin/banshee-1
+lib/banshee-1/Backends/Banshee.GStreamer.dll
+lib/banshee-1/Backends/Banshee.GStreamer.dll.mdb
+lib/banshee-1/Backends/Banshee.Gnome.dll
+lib/banshee-1/Backends/Banshee.Gnome.dll.mdb
+lib/banshee-1/Backends/Banshee.Hal.dll
+lib/banshee-1/Backends/Banshee.Hal.dll.mdb
+lib/banshee-1/Backends/Banshee.NowPlaying.X11.dll
+lib/banshee-1/Backends/Banshee.NowPlaying.X11.dll.mdb
+lib/banshee-1/Backends/Banshee.Unix.dll
+lib/banshee-1/Backends/Banshee.Unix.dll.mdb
+lib/banshee-1/Backends/libbnpx11.a
+lib/banshee-1/Backends/libbnpx11.la
+lib/banshee-1/Backends/libbnpx11.so
+lib/banshee-1/Banshee.Core.dll
+lib/banshee-1/Banshee.Core.dll.mdb
+lib/banshee-1/Banshee.Services.addins
+lib/banshee-1/Banshee.Services.dll
+lib/banshee-1/Banshee.Services.dll.mdb
+lib/banshee-1/Banshee.ThickClient.dll
+lib/banshee-1/Banshee.ThickClient.dll.mdb
+lib/banshee-1/Banshee.Widgets.dll
+lib/banshee-1/Banshee.Widgets.dll.config
+lib/banshee-1/Banshee.Widgets.dll.mdb
+lib/banshee-1/Extensions/Banshee.AudioCd.dll
+lib/banshee-1/Extensions/Banshee.AudioCd.dll.mdb
+lib/banshee-1/Extensions/Banshee.Bookmarks.dll
+lib/banshee-1/Extensions/Banshee.Bookmarks.dll.mdb
+lib/banshee-1/Extensions/Banshee.CoverArt.dll
+lib/banshee-1/Extensions/Banshee.CoverArt.dll.mdb
+lib/banshee-1/Extensions/Banshee.Daap.dll
+lib/banshee-1/Extensions/Banshee.Daap.dll.mdb
+lib/banshee-1/Extensions/Banshee.Dap.MassStorage.dll
+lib/banshee-1/Extensions/Banshee.Dap.MassStorage.dll.mdb
+lib/banshee-1/Extensions/Banshee.Dap.dll
+lib/banshee-1/Extensions/Banshee.Dap.dll.mdb
+lib/banshee-1/Extensions/Banshee.FileSystemQueue.dll
+lib/banshee-1/Extensions/Banshee.FileSystemQueue.dll.mdb
+lib/banshee-1/Extensions/Banshee.InternetRadio.dll
+lib/banshee-1/Extensions/Banshee.InternetRadio.dll.mdb
+lib/banshee-1/Extensions/Banshee.Lastfm.dll
+lib/banshee-1/Extensions/Banshee.Lastfm.dll.mdb
+lib/banshee-1/Extensions/Banshee.MiniMode.dll
+lib/banshee-1/Extensions/Banshee.MiniMode.dll.mdb
+lib/banshee-1/Extensions/Banshee.MultimediaKeys.dll
+lib/banshee-1/Extensions/Banshee.MultimediaKeys.dll.mdb
+lib/banshee-1/Extensions/Banshee.NotificationArea.dll
+lib/banshee-1/Extensions/Banshee.NotificationArea.dll.config
+lib/banshee-1/Extensions/Banshee.NotificationArea.dll.mdb
+lib/banshee-1/Extensions/Banshee.NowPlaying.dll
+lib/banshee-1/Extensions/Banshee.NowPlaying.dll.mdb
+lib/banshee-1/Extensions/Banshee.PlayQueue.dll
+lib/banshee-1/Extensions/Banshee.PlayQueue.dll.mdb
+lib/banshee-1/Extensions/Banshee.Podcasting.dll
+lib/banshee-1/Extensions/Banshee.Podcasting.dll.mdb
+lib/banshee-1/Halie.exe
+lib/banshee-1/Halie.exe.mdb
+lib/banshee-1/Hyena.Gui.dll
+lib/banshee-1/Hyena.Gui.dll.config
+lib/banshee-1/Hyena.Gui.dll.mdb
+lib/banshee-1/Hyena.dll
+lib/banshee-1/Hyena.dll.mdb
+lib/banshee-1/Lastfm.Gui.dll
+lib/banshee-1/Lastfm.Gui.dll.mdb
+lib/banshee-1/Lastfm.dll
+lib/banshee-1/Lastfm.dll.mdb
+lib/banshee-1/Migo.dll
+lib/banshee-1/Migo.dll.mdb
+lib/banshee-1/Mono.Media.dll
+lib/banshee-1/Mono.Media.dll.mdb
+lib/banshee-1/MusicBrainz.dll
+lib/banshee-1/MusicBrainz.dll.mdb
+lib/banshee-1/Nereid.exe
+lib/banshee-1/Nereid.exe.mdb
+lib/banshee-1/gconf-schema-extractor.exe
+lib/banshee-1/gstreamer-0.10/libgstequalizer.a
+lib/banshee-1/gstreamer-0.10/libgstequalizer.la
+lib/banshee-1/gstreamer-0.10/libgstequalizer.so
+lib/banshee-1/libbanshee.a
+lib/banshee-1/libbanshee.la
+lib/banshee-1/libbanshee.so
+%%PORTDOCS%%lib/monodoc/sources/banshee-docs.source
+%%PORTDOCS%%lib/monodoc/sources/banshee-docs.tree
+%%PORTDOCS%%lib/monodoc/sources/banshee-docs.zip
+%%PORTDOCS%%lib/monodoc/sources/hyena-docs.source
+%%PORTDOCS%%lib/monodoc/sources/hyena-docs.tree
+%%PORTDOCS%%lib/monodoc/sources/hyena-docs.zip
+libdata/pkgconfig/banshee-1-core.pc
+libdata/pkgconfig/banshee-1-hyena-gui.pc
+libdata/pkgconfig/banshee-1-hyena.pc
+libdata/pkgconfig/banshee-1-lastfm-gui.pc
+libdata/pkgconfig/banshee-1-lastfm.pc
+libdata/pkgconfig/banshee-1-mono-media.pc
+libdata/pkgconfig/banshee-1-musicbrainz.pc
+libdata/pkgconfig/banshee-1-services.pc
+libdata/pkgconfig/banshee-1-thickclient.pc
+share/applications/banshee-1.desktop
+share/banshee-1/audio-profiles/base.xml
+share/banshee-1/audio-profiles/flac.xml
+share/banshee-1/audio-profiles/mp3-lame.xml
+share/banshee-1/audio-profiles/mp3-xing.xml
+share/banshee-1/audio-profiles/vorbis.xml
+share/banshee-1/audio-profiles/wav.xml
+share/banshee-1/audio-profiles/wavpack.xml
+share/banshee-1/audio-profiles/wma.xml
+share/banshee-1/icons/hicolor/16x16/actions
+share/banshee-1/icons/hicolor/16x16/categories/podcast.png
+share/banshee-1/icons/hicolor/16x16/categories/source-playlist.png
+share/banshee-1/icons/hicolor/16x16/categories/source-smart-playlist.png
+share/banshee-1/icons/hicolor/16x16/status
+share/banshee-1/icons/hicolor/22x22/actions
+share/banshee-1/icons/hicolor/22x22/categories/lastfm-audioscrobbler.png
+share/banshee-1/icons/hicolor/22x22/categories/lastfm-neighbour.png
+share/banshee-1/icons/hicolor/22x22/categories/lastfm-personal.png
+share/banshee-1/icons/hicolor/22x22/categories/lastfm-recommended.png
+share/banshee-1/icons/hicolor/22x22/categories/lastfm-tag.png
+share/banshee-1/icons/hicolor/22x22/categories/podcast.png
+share/banshee-1/icons/hicolor/22x22/categories/radio.png
+share/banshee-1/icons/hicolor/22x22/categories/source-playlist.png
+share/banshee-1/icons/hicolor/22x22/categories/source-smart-playlist.png
+share/banshee-1/icons/hicolor/48x48/actions
+share/banshee-1/icons/hicolor/48x48/categories/podcast.png
+share/banshee-1/icons/hicolor/48x48/categories/radio.png
+share/banshee-1/icons/hicolor/scalable/categories/radio.svg
+share/dbus-1/services/org.bansheeproject.Banshee.service
+share/locale/ar/LC_MESSAGES/banshee-1.mo
+share/locale/be@latin/LC_MESSAGES/banshee-1.mo
+share/locale/bg/LC_MESSAGES/banshee-1.mo
+share/locale/ca/LC_MESSAGES/banshee-1.mo
+share/locale/cs/LC_MESSAGES/banshee-1.mo
+share/locale/da/LC_MESSAGES/banshee-1.mo
+share/locale/de/LC_MESSAGES/banshee-1.mo
+share/locale/dz/LC_MESSAGES/banshee-1.mo
+share/locale/en_CA/LC_MESSAGES/banshee-1.mo
+share/locale/en_GB/LC_MESSAGES/banshee-1.mo
+share/locale/es/LC_MESSAGES/banshee-1.mo
+share/locale/fi/LC_MESSAGES/banshee-1.mo
+share/locale/fr/LC_MESSAGES/banshee-1.mo
+share/locale/gl/LC_MESSAGES/banshee-1.mo
+share/locale/he/LC_MESSAGES/banshee-1.mo
+share/locale/hu/LC_MESSAGES/banshee-1.mo
+share/locale/it/LC_MESSAGES/banshee-1.mo
+share/locale/ja/LC_MESSAGES/banshee-1.mo
+share/locale/lt/LC_MESSAGES/banshee-1.mo
+share/locale/lv/LC_MESSAGES/banshee-1.mo
+share/locale/mk/LC_MESSAGES/banshee-1.mo
+share/locale/nb/LC_MESSAGES/banshee-1.mo
+share/locale/nl/LC_MESSAGES/banshee-1.mo
+share/locale/oc/LC_MESSAGES/banshee-1.mo
+share/locale/pa/LC_MESSAGES/banshee-1.mo
+share/locale/pl/LC_MESSAGES/banshee-1.mo
+share/locale/pt/LC_MESSAGES/banshee-1.mo
+share/locale/pt_BR/LC_MESSAGES/banshee-1.mo
+share/locale/ru/LC_MESSAGES/banshee-1.mo
+share/locale/sl/LC_MESSAGES/banshee-1.mo
+share/locale/sr/LC_MESSAGES/banshee-1.mo
+share/locale/sr@Latn/LC_MESSAGES/banshee-1.mo
+share/locale/sv/LC_MESSAGES/banshee-1.mo
+share/locale/th/LC_MESSAGES/banshee-1.mo
+share/locale/vi/LC_MESSAGES/banshee-1.mo
+share/locale/zh_CN/LC_MESSAGES/banshee-1.mo
+share/locale/zh_HK/LC_MESSAGES/banshee-1.mo
+share/locale/zh_TW/LC_MESSAGES/banshee-1.mo
+@dirrm share/banshee-1/icons/hicolor/scalable/categories
+@dirrm share/banshee-1/icons/hicolor/scalable
+@dirrm share/banshee-1/icons/hicolor/48x48/categories
+@dirrm share/banshee-1/icons/hicolor/48x48
+@dirrm share/banshee-1/icons/hicolor/32x32/actions
+@dirrm share/banshee-1/icons/hicolor/32x32
+@dirrm share/banshee-1/icons/hicolor/22x22/categories
+@dirrm share/banshee-1/icons/hicolor/22x22
+@dirrm share/banshee-1/icons/hicolor/16x16/categories
+@dirrm share/banshee-1/icons/hicolor/16x16
+@dirrm share/banshee-1/icons/hicolor
+@dirrm share/banshee-1/icons
+@dirrm share/banshee-1/audio-profiles
+@dirrm share/banshee-1
+@dirrm lib/banshee-1/gstreamer-0.10
+@dirrm lib/banshee-1/Extensions
+@dirrm lib/banshee-1/Backends
+@dirrm lib/banshee-1