aboutsummaryrefslogtreecommitdiff
path: root/multimedia
diff options
context:
space:
mode:
authorFlorent Thoumie <flz@FreeBSD.org>2008-08-28 20:21:11 +0000
committerFlorent Thoumie <flz@FreeBSD.org>2008-08-28 20:21:11 +0000
commitfe6b276091ce2980b63e1b347c0c85e288d5b91e (patch)
tree05f43e072efe1fa843a57695381da29f22532a6f /multimedia
parentffaa71bb0906150cab51ab41cc7a02b699bc3886 (diff)
downloadports-fe6b276091ce2980b63e1b347c0c85e288d5b91e.tar.gz
ports-fe6b276091ce2980b63e1b347c0c85e288d5b91e.zip
- Add MTP support (enable by default).
- Install missing icons.
Notes
Notes: svn path=/head/; revision=219388
Diffstat (limited to 'multimedia')
-rw-r--r--multimedia/banshee/Makefile43
-rw-r--r--multimedia/banshee/pkg-plist32
2 files changed, 61 insertions, 14 deletions
diff --git a/multimedia/banshee/Makefile b/multimedia/banshee/Makefile
index 476222939f26..733c47d8ed37 100644
--- a/multimedia/banshee/Makefile
+++ b/multimedia/banshee/Makefile
@@ -7,6 +7,7 @@
PORTNAME= banshee
PORTVERSION= 1.2.1
+PORTREVISION= 1
CATEGORIES= multimedia audio
MASTER_SITES= http://download.banshee-project.org/banshee/
DISTNAME= ${PORTNAME}-1-${PORTVERSION}
@@ -21,10 +22,10 @@ LIB_PC_DEPENDS= ${LOCALBASE}/libdata/pkgconfig/mono.pc:${PORTSDIR}/lang/mono \
${LOCALBASE}/libdata/pkgconfig/ndesk-dbus-glib-1.0.pc:${PORTSDIR}/devel/ndesk-dbus-glib \
${LOCALBASE}/libdata/pkgconfig/taglib-sharp.pc:${PORTSDIR}/audio/taglib-sharp \
${LOCALBASE}/libdata/pkgconfig/mono-zeroconf.pc:${PORTSDIR}/net/mono-zeroconf \
- ${LOCALBASE}/libdata/pkgconfig/mono-addins.pc:${PORTSDIR}/devel/mono-addins \
- ${LOCALBASE}/libdata/pkgconfig/sqlite3.pc:${PORTSDIR}/databases/sqlite3
+ ${LOCALBASE}/libdata/pkgconfig/mono-addins.pc:${PORTSDIR}/devel/mono-addins
-OPTIONS= DOCS "Install documentation" on
+OPTIONS= DOCS "Install documentation" on \
+ MTP "Enable MTP support" on
USE_BZIP2= yes
USE_GMAKE= yes
@@ -35,9 +36,13 @@ USE_GSTREAMER= yes
USE_GETTEXT= yes
USE_LDCONFIG= ${PREFIX}/lib/${PORTNAME}-1
USE_XORG= xrandr xxf86vm
+USE_SQLITE= yes
INSTALLS_ICONS= yes
CONFIGURE_TARGET= --build=${ARCH}-portbld-freebsd${OSREL}
-CONFIGURE_ARGS+= --disable-boo --disable-ipod --disable-mtp
+CONFIGURE_ARGS+= --disable-boo --disable-ipod
+
+# Need absolute path for build/icon-install-theme.
+INSTALL= /usr/bin/install
.include <bsd.port.pre.mk>
.include "${.CURDIR}/../../lang/mono/bsd.mono.mk"
@@ -48,6 +53,14 @@ BUILD_DEPENDS+= ${LOCALBASE}/bin/monodocer:${PORTSDIR}/devel/monodoc
CONFIGURE_ARGS+= --disable-docs
.endif
+.if !defined(WITHOUT_MTP)
+LIB_DEPENDS+= mtp.8:${PORTSDIR}/audio/libmtp
+PLIST_SUB+= OPT_MTP=""
+.else
+CONFIGURE_ARGS+= --disable-mtp
+PLIST_SUB+= OPT_MTP="@comment "
+.endif
+
post-patch:
@${REINPLACE_CMD} 's|#!/bin/bash|#!/bin/sh|' \
${WRKSRC}/src/Clients/banshee-1.in \
@@ -57,24 +70,26 @@ post-patch:
${WRKSRC}/build/private-icon-theme-installer
@${REINPLACE_CMD} 's|-a banshee-1||' \
${WRKSRC}/src/Clients/banshee-1.in
-# @${REINPLACE_CMD} 's|sed -r|sed|' \
+ @${REINPLACE_CMD} 's|sed -r|sed -E|' \
+ ${WRKSRC}/data/icon-theme-hicolor/Makefile.in
# ${WRKSRC}/configure \
-# ${WRKSRC}/data/icon-theme-hicolor/Makefile.in
# XXX - This is gross.
post-configure:
- @${REINPLACE_CMD} -e 's|^\(MSGFMT =\)|\1 ${LOCALBASE}/bin/msgfmt|' \
- -e 's|^\(GMSGFMT =\)|\1 ${LOCALBASE}/bin/msgfmt|' \
- ${WRKSRC}/po/Makefile
+ @${REINPLACE_CMD} -e 's|^\(MSGFMT =\).*|\1 ${LOCALBASE}/bin/msgfmt|' \
+ -e 's|^\(GMSGFMT =\).*|\1 ${LOCALBASE}/bin/msgfmt|' \
+ ${WRKSRC}/po/Makefile
+# XXX - Really ugly too.
pre-build:
-.for i in 16x16 22x22 48x48 scalable
- ${MKDIR} ${WRKSRC}/bin/share/banshee-1/icons/hicolor/$i/categories
-.endfor
+ ${MKDIR} ${WRKSRC}/bin/share/banshee-1/icons/hicolor/scalable/
+# XXX - This one is the best.
pre-install:
-.for i in 16x16 22x22 48x48 scalable
- ${MKDIR} ${PREFIX}/share/banshee-1/icons/hicolor/$i/categories
+.for i in 16x16 22x22 32x32 48x48 scalable
+. for j in actions categories status
+ ${MKDIR} ${PREFIX}/share/banshee-1/icons/hicolor/$i/$j/
+. endfor
.endfor
.include <bsd.port.post.mk>
diff --git a/multimedia/banshee/pkg-plist b/multimedia/banshee/pkg-plist
index 29c8b938f4ed..539ed146f437 100644
--- a/multimedia/banshee/pkg-plist
+++ b/multimedia/banshee/pkg-plist
@@ -32,6 +32,8 @@ lib/banshee-1/Extensions/Banshee.Daap.dll
lib/banshee-1/Extensions/Banshee.Daap.dll.mdb
lib/banshee-1/Extensions/Banshee.Dap.MassStorage.dll
lib/banshee-1/Extensions/Banshee.Dap.MassStorage.dll.mdb
+%%OPT_MTP%%lib/banshee-1/Extensions/Banshee.Dap.Mtp.dll
+%%OPT_MTP%%lib/banshee-1/Extensions/Banshee.Dap.Mtp.dll.mdb
lib/banshee-1/Extensions/Banshee.Dap.dll
lib/banshee-1/Extensions/Banshee.Dap.dll.mdb
lib/banshee-1/Extensions/Banshee.FileSystemQueue.dll
@@ -68,6 +70,9 @@ lib/banshee-1/Migo.dll
lib/banshee-1/Migo.dll.mdb
lib/banshee-1/Mono.Media.dll
lib/banshee-1/Mono.Media.dll.mdb
+%%OPT_MTP%%lib/banshee-1/Mtp.dll
+%%OPT_MTP%%lib/banshee-1/Mtp.dll.config
+%%OPT_MTP%%lib/banshee-1/Mtp.dll.mdb
lib/banshee-1/MusicBrainz.dll
lib/banshee-1/MusicBrainz.dll.mdb
lib/banshee-1/Nereid.exe
@@ -104,11 +109,20 @@ share/banshee-1/audio-profiles/wav.xml
share/banshee-1/audio-profiles/wavpack.xml
share/banshee-1/audio-profiles/wma.xml
share/banshee-1/icons/hicolor/16x16/actions
+share/banshee-1/icons/hicolor/16x16/actions/media-import-audio-cd.png
+share/banshee-1/icons/hicolor/16x16/actions/media-repeat-all.png
+share/banshee-1/icons/hicolor/16x16/actions/media-repeat-none.png
+share/banshee-1/icons/hicolor/16x16/actions/media-repeat-single.png
+share/banshee-1/icons/hicolor/16x16/actions/media-write-cd.png
share/banshee-1/icons/hicolor/16x16/categories/podcast.png
share/banshee-1/icons/hicolor/16x16/categories/source-playlist.png
share/banshee-1/icons/hicolor/16x16/categories/source-smart-playlist.png
share/banshee-1/icons/hicolor/16x16/status
+share/banshee-1/icons/hicolor/16x16/status/podcast-new.png
share/banshee-1/icons/hicolor/22x22/actions
+share/banshee-1/icons/hicolor/22x22/actions/encode.png
+share/banshee-1/icons/hicolor/22x22/actions/media-import-audio-cd.png
+share/banshee-1/icons/hicolor/22x22/actions/media-write-cd.png
share/banshee-1/icons/hicolor/22x22/categories/lastfm-audioscrobbler.png
share/banshee-1/icons/hicolor/22x22/categories/lastfm-neighbour.png
share/banshee-1/icons/hicolor/22x22/categories/lastfm-personal.png
@@ -118,11 +132,19 @@ share/banshee-1/icons/hicolor/22x22/categories/podcast.png
share/banshee-1/icons/hicolor/22x22/categories/radio.png
share/banshee-1/icons/hicolor/22x22/categories/source-playlist.png
share/banshee-1/icons/hicolor/22x22/categories/source-smart-playlist.png
+share/banshee-1/icons/hicolor/32x32/actions/media-write-cd.png
share/banshee-1/icons/hicolor/48x48/actions
+share/banshee-1/icons/hicolor/48x48/actions/media-write-cd.png
share/banshee-1/icons/hicolor/48x48/categories/podcast.png
share/banshee-1/icons/hicolor/48x48/categories/radio.png
share/banshee-1/icons/hicolor/scalable/categories/radio.svg
share/dbus-1/services/org.bansheeproject.Banshee.service
+share/icons/hicolor/16x16/apps/media-player-banshee.png
+share/icons/hicolor/192x192/apps/media-player-banshee.png
+share/icons/hicolor/22x22/apps/media-player-banshee.png
+share/icons/hicolor/24x24/apps/media-player-banshee.png
+share/icons/hicolor/32x32/apps/media-player-banshee.png
+share/icons/hicolor/48x48/apps/media-player-banshee.png
share/locale/ar/LC_MESSAGES/banshee-1.mo
share/locale/be@latin/LC_MESSAGES/banshee-1.mo
share/locale/bg/LC_MESSAGES/banshee-1.mo
@@ -161,15 +183,25 @@ share/locale/vi/LC_MESSAGES/banshee-1.mo
share/locale/zh_CN/LC_MESSAGES/banshee-1.mo
share/locale/zh_HK/LC_MESSAGES/banshee-1.mo
share/locale/zh_TW/LC_MESSAGES/banshee-1.mo
+@dirrm share/banshee-1/icons/hicolor/scalable/status
@dirrm share/banshee-1/icons/hicolor/scalable/categories
+@dirrm share/banshee-1/icons/hicolor/scalable/actions
@dirrm share/banshee-1/icons/hicolor/scalable
+@dirrm share/banshee-1/icons/hicolor/48x48/status
@dirrm share/banshee-1/icons/hicolor/48x48/categories
+@dirrm share/banshee-1/icons/hicolor/48x48/actions
@dirrm share/banshee-1/icons/hicolor/48x48
+@dirrm share/banshee-1/icons/hicolor/32x32/status
+@dirrm share/banshee-1/icons/hicolor/32x32/categories
@dirrm share/banshee-1/icons/hicolor/32x32/actions
@dirrm share/banshee-1/icons/hicolor/32x32
+@dirrm share/banshee-1/icons/hicolor/22x22/status
@dirrm share/banshee-1/icons/hicolor/22x22/categories
+@dirrm share/banshee-1/icons/hicolor/22x22/actions
@dirrm share/banshee-1/icons/hicolor/22x22
+@dirrm share/banshee-1/icons/hicolor/16x16/status
@dirrm share/banshee-1/icons/hicolor/16x16/categories
+@dirrm share/banshee-1/icons/hicolor/16x16/actions
@dirrm share/banshee-1/icons/hicolor/16x16
@dirrm share/banshee-1/icons/hicolor
@dirrm share/banshee-1/icons