aboutsummaryrefslogtreecommitdiff
path: root/multimedia
diff options
context:
space:
mode:
authorPierre Beyssac <pb@FreeBSD.org>2004-12-20 22:06:31 +0000
committerPierre Beyssac <pb@FreeBSD.org>2004-12-20 22:06:31 +0000
commit1ff5b2bb4ecaff3cd1c15a9c774016a469044fe1 (patch)
treea490326851d3ca64ec0c5b076658323ed8f8af4a /multimedia
parentad4b02ae04d36a6dad4db5e2225c1e957da57449 (diff)
downloadports-1ff5b2bb4ecaff3cd1c15a9c774016a469044fe1.tar.gz
ports-1ff5b2bb4ecaff3cd1c15a9c774016a469044fe1.zip
Fix bug in menu creation caused by bad ImageMagick interaction.
PR: ports/75289 Submitted by: Andy Sparrow <spadger@best.com>
Notes
Notes: svn path=/head/; revision=124641
Diffstat (limited to 'multimedia')
-rw-r--r--multimedia/dvdauthor/Makefile2
-rw-r--r--multimedia/dvdauthor/files/patch-subgen-image.c11
2 files changed, 12 insertions, 1 deletions
diff --git a/multimedia/dvdauthor/Makefile b/multimedia/dvdauthor/Makefile
index f6890f7ea0c4..67d40274f79e 100644
--- a/multimedia/dvdauthor/Makefile
+++ b/multimedia/dvdauthor/Makefile
@@ -7,7 +7,7 @@
PORTNAME= dvdauthor
PORTVERSION= 0.6.10
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= multimedia
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME}
diff --git a/multimedia/dvdauthor/files/patch-subgen-image.c b/multimedia/dvdauthor/files/patch-subgen-image.c
new file mode 100644
index 000000000000..743989f996fd
--- /dev/null
+++ b/multimedia/dvdauthor/files/patch-subgen-image.c
@@ -0,0 +1,11 @@
+--- src/subgen-image.c.orig Sun Dec 19 22:38:27 2004
++++ src/subgen-image.c Sun Dec 19 22:38:44 2004
+@@ -177,7 +177,7 @@
+ p.r=pdata[x*4];
+ p.g=pdata[x*4+1];
+ p.b=pdata[x*4+2];
+- p.t=255-pdata[x*4+3];
++ p.t=pdata[x*4+3];
+ putpixel(s,y*s->width+x,&p);
+ }
+ }