aboutsummaryrefslogtreecommitdiff
path: root/multimedia
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2008-04-29 21:34:37 +0000
committerMartin Wilke <miwi@FreeBSD.org>2008-04-29 21:34:37 +0000
commit5f86f5921dee505c4de4cb3ab23047565167aaa9 (patch)
tree1c9778eda158762154f32363e53c5ba53748dd7f /multimedia
parentceabe272a7e49d14d6b3dcac853bb72ff4ec79aa (diff)
downloadports-5f86f5921dee505c4de4cb3ab23047565167aaa9.tar.gz
ports-5f86f5921dee505c4de4cb3ab23047565167aaa9.zip
MediaInfo supplies technical and tag information about a video or audio file.
Supported formats: Video: AVI/OGM/MKV/MPG/VOB/MP4/3GP/... Audio: MP3/OGG/MKA/MP4/AAC/... WWW: http://mediainfo.sourceforge.net/ PR: ports/123196 Submitted by: freebsd-ports at evilcode.net
Notes
Notes: svn path=/head/; revision=212289
Diffstat (limited to 'multimedia')
-rw-r--r--multimedia/Makefile1
-rw-r--r--multimedia/mediainfo/Makefile31
-rw-r--r--multimedia/mediainfo/distinfo3
-rw-r--r--multimedia/mediainfo/files/patch-cli_compile8
-rw-r--r--multimedia/mediainfo/files/patch-int128s13
-rw-r--r--multimedia/mediainfo/files/patch-int128u12
-rw-r--r--multimedia/mediainfo/pkg-descr6
7 files changed, 74 insertions, 0 deletions
diff --git a/multimedia/Makefile b/multimedia/Makefile
index a81deada56b3..b26ec4a37622 100644
--- a/multimedia/Makefile
+++ b/multimedia/Makefile
@@ -134,6 +134,7 @@
SUBDIR += mandvd
SUBDIR += manencode
SUBDIR += manslide
+ SUBDIR += mediainfo
SUBDIR += mencoder
SUBDIR += mimms
SUBDIR += miro
diff --git a/multimedia/mediainfo/Makefile b/multimedia/mediainfo/Makefile
new file mode 100644
index 000000000000..8d9595347288
--- /dev/null
+++ b/multimedia/mediainfo/Makefile
@@ -0,0 +1,31 @@
+# New ports collection makefile for: mediainfo
+# Date created: 24 April 2008
+# Whom: freebsd-ports@evilcode.net
+#
+# $FreeBSD$
+#
+
+PORTNAME= mediainfo
+PORTVERSION= 0.7.6.3
+DISTVERSIONSUFFIX= _CLI_GNU_FromSource
+CATEGORIES= multimedia
+MASTER_SITES= SF
+DISTNAME= MediaInfo_${PORTVERSION}${DISTVERSIONSUFFIX}
+
+MAINTAINER= freebsd-ports@evilcode.net
+COMMENT= Supplies technical and tag information about a video or audio file
+
+PLIST_FILES= bin/mediainfo
+
+USE_BZIP2= yes
+USE_DOS2UNIX= int128s.cpp int128u.cpp
+
+WRKSRC= ${WRKDIR}/MediaInfo${DISTVERSIONSUFFIX}
+
+do-build:
+ @(cd ${WRKSRC}/ && ${SH} ./CLI_Compile.sh --prefix=${PREFIX})
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/MediaInfo/Project/GNU/CLI/mediainfo ${PREFIX}/bin
+
+.include <bsd.port.mk>
diff --git a/multimedia/mediainfo/distinfo b/multimedia/mediainfo/distinfo
new file mode 100644
index 000000000000..7f6316557d71
--- /dev/null
+++ b/multimedia/mediainfo/distinfo
@@ -0,0 +1,3 @@
+MD5 (MediaInfo_0.7.6.3_CLI_GNU_FromSource.tar.bz2) = 08cd71f75eb4feb42a7d5f8fd25c4cd6
+SHA256 (MediaInfo_0.7.6.3_CLI_GNU_FromSource.tar.bz2) = ae4aaf6f6c39c466111d5d9bb6beb739d57e08631242cc7997ecbd6a4d04642c
+SIZE (MediaInfo_0.7.6.3_CLI_GNU_FromSource.tar.bz2) = 1052024
diff --git a/multimedia/mediainfo/files/patch-cli_compile b/multimedia/mediainfo/files/patch-cli_compile
new file mode 100644
index 000000000000..9999083e3484
--- /dev/null
+++ b/multimedia/mediainfo/files/patch-cli_compile
@@ -0,0 +1,8 @@
+--- CLI_Compile.sh.old 2008-04-28 20:15:04.000000000 -0700
++++ CLI_Compile.sh 2008-04-28 20:15:16.000000000 -0700
+@@ -102,4 +102,3 @@
+ # Going home
+ cd $Home
+ echo "MediaInfo executable is in MediaInfo/Project/GNU/CLI"
+-echo "For installing, cd MediaInfo/Project/GNU/CLI && make install"
+\ No newline at end of file
diff --git a/multimedia/mediainfo/files/patch-int128s b/multimedia/mediainfo/files/patch-int128s
new file mode 100644
index 000000000000..46410c789065
--- /dev/null
+++ b/multimedia/mediainfo/files/patch-int128s
@@ -0,0 +1,13 @@
+--- ZenLib/Source/ZenLib/int128s.cpp 2008-04-12 10:52:16.000000000 -0700
++++ ZenLib/Source/ZenLib/int128s.cpp 2008-04-24 23:30:33.000000000 -0700
+@@ -47,6 +47,9 @@
+ #if defined (__MONTAVISTA__) || defined (__ARMEL__)
+ #define fmodl fmod
+ #endif
++#if defined(__FreeBSD__) || defined(__OpenBSD__) || defined(__NetBSD__)
++ #define fmodl fmod
++#endif
+ using namespace std;
+
+ namespace ZenLib
+
diff --git a/multimedia/mediainfo/files/patch-int128u b/multimedia/mediainfo/files/patch-int128u
new file mode 100644
index 000000000000..ea3df52aa2e8
--- /dev/null
+++ b/multimedia/mediainfo/files/patch-int128u
@@ -0,0 +1,12 @@
+--- ZenLib/Source/ZenLib/int128u.cpp 2008-04-12 10:52:16.000000000 -0700
++++ ZenLib/Source/ZenLib/int128u.cpp 2008-04-24 23:31:13.000000000 -0700
+@@ -47,6 +47,9 @@
+ #if defined (__MONTAVISTA__) || defined (__ARMEL__)
+ #define fmodl fmod
+ #endif
++#if defined(__FreeBSD__) || defined(__OpenBSD__) || defined(__NetBSD__)
++ #define fmodl fmod
++#endif
+ using namespace std;
+
+ namespace ZenLib
diff --git a/multimedia/mediainfo/pkg-descr b/multimedia/mediainfo/pkg-descr
new file mode 100644
index 000000000000..74bc8af37ea0
--- /dev/null
+++ b/multimedia/mediainfo/pkg-descr
@@ -0,0 +1,6 @@
+MediaInfo supplies technical and tag information about a video or audio file.
+Supported formats:
+ Video: AVI/OGM/MKV/MPG/VOB/MP4/3GP/...
+ Audio: MP3/OGG/MKA/MP4/AAC/...
+
+WWW: http://mediainfo.sourceforge.net/