aboutsummaryrefslogtreecommitdiff
path: root/multimedia
diff options
context:
space:
mode:
authorMario Sergio Fujikawa Ferreira <lioux@FreeBSD.org>2005-01-08 21:10:10 +0000
committerMario Sergio Fujikawa Ferreira <lioux@FreeBSD.org>2005-01-08 21:10:10 +0000
commit6b10375f58d627e686a9e0a32461fb864412b678 (patch)
tree2c81af1fd33f1dd250a8e4cf6b757d15088d00ec /multimedia
parent905a5dbbdfc5d51f271d4403c94f0454b03a6d7d (diff)
downloadports-6b10375f58d627e686a9e0a32461fb864412b678.tar.gz
ports-6b10375f58d627e686a9e0a32461fb864412b678.zip
o New port cupid version 0.0.1: GNOME Gstreamer based video/audio
capture solution o Video capture does not work since there is no gstreamer video source plugin for FreeBSD just yet
Notes
Notes: svn path=/head/; revision=125881
Diffstat (limited to 'multimedia')
-rw-r--r--multimedia/Makefile1
-rw-r--r--multimedia/cupid/Makefile38
-rw-r--r--multimedia/cupid/distinfo2
-rw-r--r--multimedia/cupid/pkg-descr13
-rw-r--r--multimedia/cupid/pkg-plist33
5 files changed, 87 insertions, 0 deletions
diff --git a/multimedia/Makefile b/multimedia/Makefile
index eb2f0db9dac2..65fb858fbb97 100644
--- a/multimedia/Makefile
+++ b/multimedia/Makefile
@@ -11,6 +11,7 @@
SUBDIR += bmp-extra-plugins
SUBDIR += bsdbktr_tvtune
SUBDIR += camserv
+ SUBDIR += cupid
SUBDIR += dirac
SUBDIR += dtv
SUBDIR += dumpmpeg
diff --git a/multimedia/cupid/Makefile b/multimedia/cupid/Makefile
new file mode 100644
index 000000000000..46a7082b17fd
--- /dev/null
+++ b/multimedia/cupid/Makefile
@@ -0,0 +1,38 @@
+# New ports collection makefile for: Cupid gstreamer recorder
+# Date created: Thu Jan 6 06:00:19 UTC 2005
+# Whom: Mario Sergio Fujikawa Ferreira <lioux@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= cupid
+PORTVERSION= 0.0.1
+CATEGORIES= multimedia audio gnome
+MASTER_SITES= http://gstreamer.freedesktop.org/src/gst-recorder/
+DIST_SUBDIR= gnome2
+
+MAINTAINER= lioux@FreeBSD.org
+COMMENT= GNOME Gstreamer based video/audio capture solution
+
+USE_GNOME= \
+ gnomehack \
+ gnomehier \
+ gnomeprefix \
+ gconf2 \
+ gnomevfs2 \
+ gstreamerplugins \
+ gtk20 \
+ intlhack \
+ intltool \
+ libbonobo \
+ libgnome \
+ libgnomeui \
+ pkgconfig
+USE_X_PREFIX= yes
+GNU_CONFIGURE= yes
+USE_GMAKE= yes
+
+GCONF_SCHEMAS= ${PORTNAME}.schemas
+INSTALLS_OMF= yes
+
+.include <bsd.port.mk>
diff --git a/multimedia/cupid/distinfo b/multimedia/cupid/distinfo
new file mode 100644
index 000000000000..781e8ccf2eff
--- /dev/null
+++ b/multimedia/cupid/distinfo
@@ -0,0 +1,2 @@
+MD5 (gnome2/cupid-0.0.1.tar.gz) = 0f9683b1ceb7e2939143110bb4b34f08
+SIZE (gnome2/cupid-0.0.1.tar.gz) = 493691
diff --git a/multimedia/cupid/pkg-descr b/multimedia/cupid/pkg-descr
new file mode 100644
index 000000000000..70593ae5546f
--- /dev/null
+++ b/multimedia/cupid/pkg-descr
@@ -0,0 +1,13 @@
+[ excerpt from developer's web site ]
+
+Cupid is a modern, complete video/audio capture solution for the
+Linux/GNOME desktop. It is based on the GStreamer multimedia
+framework, which is the de facto multimedia framework on the Linux
+and UNIX desktop. Using GStreamer, it supports a variety of container
+formats and video/audio codecs. Likewise, it supports all the current
+video and audio kernel interfaces, and can be extended to supports
+other systems than Linux simply by writing a GStreamer plugin.
+
+WWW: http://ronald.bitfreak.net/me/cupid.php
+
+-- lioux@FreeBSD.org
diff --git a/multimedia/cupid/pkg-plist b/multimedia/cupid/pkg-plist
new file mode 100644
index 000000000000..a8b42b37e97a
--- /dev/null
+++ b/multimedia/cupid/pkg-plist
@@ -0,0 +1,33 @@
+bin/cupid
+share/gnome/applications/cupid.desktop
+share/gnome/cupid/pixmaps/brightness.png
+share/gnome/cupid/pixmaps/contrast.png
+share/gnome/cupid/pixmaps/pause.png
+share/gnome/cupid/pixmaps/play.png
+share/gnome/cupid/pixmaps/record.png
+share/gnome/cupid/pixmaps/saturation.png
+share/gnome/cupid/pixmaps/slider.png
+share/gnome/cupid/pixmaps/stop.png
+share/gnome/help/cupid/C/cupid.xml
+share/gnome/help/cupid/C/figures/cupid_druid.png
+share/gnome/help/cupid/C/figures/cupid_window.png
+share/gnome/help/cupid/C/legal.xml
+share/gnome/omf/cupid/cupid-C.omf
+share/gnome/pixmaps/cupid.png
+@unexec rmdir %D/share/gnome/pixmaps 2>/dev/null || true
+@dirrm share/gnome/omf/cupid
+@unexec rmdir %D/share/gnome/omf 2>/dev/null || true
+@dirrm share/gnome/help/cupid/C/figures
+@dirrm share/gnome/help/cupid/C
+@dirrm share/gnome/help/cupid
+@unexec rmdir %D/share/gnome/help 2>/dev/null || true
+@dirrm share/gnome/cupid/pixmaps
+@dirrm share/gnome/cupid
+@unexec rmdir %D/share/gnome/applications 2>/dev/null || true
+@unexec rmdir %D/share/gnome 2>/dev/null || true
+@unexec rmdir %D/etc/gconf/schemas 2>/dev/null || true
+@unexec rmdir %D/etc/gconf/gconf.xml.defaults/schemas/apps 2>/dev/null || true
+@unexec rmdir %D/etc/gconf/gconf.xml.defaults/schemas 2>/dev/null || true
+@unexec rmdir %D/etc/gconf/gconf.xml.defaults/apps 2>/dev/null || true
+@unexec rmdir %D/etc/gconf/gconf.xml.defaults 2>/dev/null || true
+@unexec rmdir %D/etc/gconf 2>/dev/null || true