aboutsummaryrefslogtreecommitdiff
path: root/multimedia
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2009-12-29 11:16:28 +0000
committerMartin Wilke <miwi@FreeBSD.org>2009-12-29 11:16:28 +0000
commit70e197b6fb7f432805ad98708e0d25ccf4e52bf6 (patch)
treebf70e7a3914cbce030636fb555029a26ba10a40f /multimedia
parent09d52b11121fef4c90e0c4bd5603783c9d8e25c2 (diff)
downloadports-70e197b6fb7f432805ad98708e0d25ccf4e52bf6.tar.gz
ports-70e197b6fb7f432805ad98708e0d25ccf4e52bf6.zip
- Update to 2.5.4
PR: 142041 Submitted by: Ports Fury Tested by: nox
Notes
Notes: svn path=/head/; revision=246850
Diffstat (limited to 'multimedia')
-rw-r--r--multimedia/miro/Makefile13
-rw-r--r--multimedia/miro/distinfo6
-rw-r--r--multimedia/miro/files/patch-platform_gtk-x11_setup.py25
-rw-r--r--multimedia/miro/pkg-plist6
4 files changed, 31 insertions, 19 deletions
diff --git a/multimedia/miro/Makefile b/multimedia/miro/Makefile
index 7bcdedaf4349..fa791450fe86 100644
--- a/multimedia/miro/Makefile
+++ b/multimedia/miro/Makefile
@@ -5,9 +5,8 @@
# $FreeBSD$
#
-PORTNAME= Miro
-PORTVERSION= 2.5.2
-PORTREVISION= 1
+PORTNAME= miro
+PORTVERSION= 2.5.4
CATEGORIES= multimedia
MASTER_SITES= ftp://ftp.osuosl.org/pub/pculture.org/miro/src/ \
http://ftp.osuosl.org/pub/pculture.org/miro/src/
@@ -28,6 +27,8 @@ RUN_DEPENDS= ${PYTHON_SITELIBDIR}/_bsddb.so:${PORTSDIR}/databases/py-bsddb \
BUILD_WRKSRC= ${WRKSRC}/platform/gtk-x11
INSTALL_WRKSRC= ${WRKSRC}/platform/gtk-x11
+CONFLICTS= Miro-[0-9]*
+
USE_GCC= 4.3+
USE_GNOME= gtk20 pygnomeextras
USE_GECKO= libxul seamonkey
@@ -36,7 +37,6 @@ USE_PYTHON= yes
WANT_GSTREAMER= yes
USE_GETTEXT= yes
USE_PYDISTUTILS= yes
-PYDISTUTILS_PKGNAME= ${PORTNAME:L}
MAKE_ENV= CPPFLAGS="${CPPFLAGS}"
INSTALLS_ICONS= yes
INSTALLS_EGGINFO= yes
@@ -44,8 +44,6 @@ INSTALLS_EGGINFO= yes
MANCOMPRESSED= yes
MAN1= miro.1 miro.real.1
-DATADIR= ${PREFIX}/share/${PORTNAME:L}
-
CPPFLAGS= -I${LOCALBASE}/include ${PTHREAD_CFLAGS}
.include <bsd.port.pre.mk>
@@ -69,7 +67,8 @@ XULRUNNER_19= False
post-patch:
.for file in setup.py plat/resources.py
- ${REINPLACE_CMD} -e 's|%%XPCOM_LIB%%|${XPCOM_LIB}|g ; \
+ ${REINPLACE_CMD} -e 's|%%XPCOM_RUNTIME_PATH%%|${LOCALBASE}/lib/${GECKO}|g ; \
+ s|%%XPCOM_LIB%%|${XPCOM_LIB}|g ; \
s|%%GTKMOZEMBED_LIB%%|${GTKMOZEMBED_LIB}|g ; \
s|%%XULRUNNER_19%%|${XULRUNNER_19}|g ; \
s|%%LOCALBASE%%|${LOCALBASE}|g ; \
diff --git a/multimedia/miro/distinfo b/multimedia/miro/distinfo
index 4c2ecf939abd..6a2d85596ddd 100644
--- a/multimedia/miro/distinfo
+++ b/multimedia/miro/distinfo
@@ -1,3 +1,3 @@
-MD5 (Miro-2.5.2.tar.gz) = e4e6a6979949c001ab06e813db7da06f
-SHA256 (Miro-2.5.2.tar.gz) = 3564f934140e7a6d79654d391a1fcb7311ad7a3fdb3149d0554444bc56d289dd
-SIZE (Miro-2.5.2.tar.gz) = 9734697
+MD5 (miro-2.5.4.tar.gz) = d0ae2bf0463201c6b6dc7367f1fa8b3c
+SHA256 (miro-2.5.4.tar.gz) = 43f18abfc8cc7cdbb84fb5de2136397080e4c153881498b18970c81a671b0f67
+SIZE (miro-2.5.4.tar.gz) = 10032329
diff --git a/multimedia/miro/files/patch-platform_gtk-x11_setup.py b/multimedia/miro/files/patch-platform_gtk-x11_setup.py
index 493bb897de3e..d3fda9aa05b7 100644
--- a/multimedia/miro/files/patch-platform_gtk-x11_setup.py
+++ b/multimedia/miro/files/patch-platform_gtk-x11_setup.py
@@ -1,5 +1,14 @@
---- platform/gtk-x11/setup.py.orig 2009-07-25 12:41:12.000000000 +0900
-+++ platform/gtk-x11/setup.py 2009-07-30 15:52:08.000000000 +0900
+--- platform/gtk-x11/setup.py.orig 2009-12-03 01:40:42.000000000 +0900
++++ platform/gtk-x11/setup.py 2009-12-21 06:10:08.000000000 +0900
+@@ -70,7 +70,7 @@
+ # Examples:
+ # XPCOM_RUNTIME_PATH = "/usr/lib/firefox"
+ # XPCOM_RUNTIME_PATH = "/usr/lib/xulrunner-1.9.0.1"
+-XPCOM_RUNTIME_PATH = None
++XPCOM_RUNTIME_PATH = "%%XPCOM_RUNTIME_PATH%%"
+
+ # Location of xulrunner/firefox components for gtkmozembed.set_comp_path.
+ # See documentation for set_comp_path here:
@@ -112,14 +112,15 @@
# XPCOM_LIB = "firefox-xpcom"
# GTKMOZEMBED_LIB = "firefox-gtkmozembed"
@@ -143,17 +152,17 @@
+ dest = '%%PREFIX%%/share/miro/resources/app.config'
config_file = util.read_simple_config_file(source)
- print "Trying to figure out the svn revision...."
-@@ -737,7 +743,7 @@
-
- for source in glob (os.path.join (locale_dir, "*.mo")):
+ print "Trying to figure out the git revision...."
+@@ -739,7 +745,7 @@
lang = os.path.basename(source)[:-3]
+ if 'LINGUAS' in os.environ and lang not in os.environ['LINGUAS']:
+ continue
- dest = '/usr/share/locale/%s/LC_MESSAGES/miro.mo' % lang
+ dest = '%%PREFIX%%/share/locale/%s/LC_MESSAGES/miro.mo' % lang
if self.root:
dest = change_root(self.root, dest)
self.mkpath(os.path.dirname(dest))
-@@ -766,7 +772,7 @@
+@@ -768,7 +774,7 @@
#### install_theme installs a specified theme .zip
class install_theme(Command):
@@ -162,7 +171,7 @@
user_options = [("theme=", None, 'ZIP file containing the theme')]
def initialize_options(self):
-@@ -794,7 +800,7 @@
+@@ -796,7 +802,7 @@
raise DistutilsOptionError, "invalid theme file"
self.zipfile = zf
self.theme_name = themeName
diff --git a/multimedia/miro/pkg-plist b/multimedia/miro/pkg-plist
index 9f7da58c9341..e26b9b1abf7a 100644
--- a/multimedia/miro/pkg-plist
+++ b/multimedia/miro/pkg-plist
@@ -660,6 +660,7 @@ share/locale/km/LC_MESSAGES/miro.mo
share/locale/kn/LC_MESSAGES/miro.mo
share/locale/ko/LC_MESSAGES/miro.mo
share/locale/ku/LC_MESSAGES/miro.mo
+share/locale/lb/LC_MESSAGES/miro.mo
share/locale/lt/LC_MESSAGES/miro.mo
share/locale/lv/LC_MESSAGES/miro.mo
share/locale/mk/LC_MESSAGES/miro.mo
@@ -841,7 +842,7 @@ share/mime/packages/miro.xml
%%DATADIR%%/resources/searchengines/bliptv.xml
%%DATADIR%%/resources/searchengines/blogdigger.xml
%%DATADIR%%/resources/searchengines/dailymotion.xml
-%%DATADIR%%/resources/searchengines/everyzing.xml
+%%DATADIR%%/resources/searchengines/everyzing.xml.disabled
%%DATADIR%%/resources/searchengines/google.xml
%%DATADIR%%/resources/searchengines/metavid.xml
%%DATADIR%%/resources/searchengines/mininova.xml
@@ -866,6 +867,7 @@ share/mime/packages/miro.xml
%%DATADIR%%/resources/testdata/olddatabase.bug.3163
%%DATADIR%%/resources/testdata/olddatabase.bug.4039
%%DATADIR%%/resources/testdata/olddatabase.bug.4039.part2
+%%DATADIR%%/resources/testdata/olddatabase.empty_feedparser_output_test
%%DATADIR%%/resources/testdata/olddatabase.predbupgrade88
%%DATADIR%%/resources/testdata/olddatabase.v71
%%DATADIR%%/resources/testdata/olddatabase.v78
@@ -909,6 +911,8 @@ share/pixmaps/miro.xpm
@dirrmtry share/locale/km
@dirrmtry share/locale/kk/LC_MESSAGES
@dirrmtry share/locale/kk
+@dirrmtry share/locale/lb/LC_MESSAGES
+@dirrmtry share/locale/lb
@dirrmtry share/locale/fy/LC_MESSAGES
@dirrmtry share/locale/fy
@dirrmtry share/locale/fo/LC_MESSAGES