aboutsummaryrefslogtreecommitdiff
path: root/multimedia
diff options
context:
space:
mode:
authorStanislav Sedov <stas@FreeBSD.org>2010-12-23 08:59:07 +0000
committerStanislav Sedov <stas@FreeBSD.org>2010-12-23 08:59:07 +0000
commitb7e48f54aa6c42a641c79f6571f0223d44d6eef5 (patch)
tree485b6fd6f1b577bc9a134cf87feba84b09ede47d /multimedia
parenta097548a9406b453a173a2a7d1cf2b88a5793b5c (diff)
downloadports-b7e48f54aa6c42a641c79f6571f0223d44d6eef5.tar.gz
ports-b7e48f54aa6c42a641c79f6571f0223d44d6eef5.zip
- Use getopt_long from libc, rather than the bundled implementation.
The bundled implementation fails to compile. - Bump portrevision. Approved by: maintainer timeout (multimedia@, 14 days)
Notes
Notes: svn path=/head/; revision=266782
Diffstat (limited to 'multimedia')
-rw-r--r--multimedia/mpeg4ip/Makefile2
-rw-r--r--multimedia/mpeg4ip/files/patch-configure33
-rw-r--r--multimedia/mpeg4ip/files/patch-mpeg4ip_config.h.in27
3 files changed, 30 insertions, 32 deletions
diff --git a/multimedia/mpeg4ip/Makefile b/multimedia/mpeg4ip/Makefile
index 325a78584ab5..1140aa3d5e48 100644
--- a/multimedia/mpeg4ip/Makefile
+++ b/multimedia/mpeg4ip/Makefile
@@ -7,7 +7,7 @@
PORTNAME= mpeg4ip
PORTVERSION= 1.6.1
-PORTREVISION= 14
+PORTREVISION= 15
CATEGORIES= multimedia audio ipv6 net
MASTER_SITES= LOCAL/ahze
# http://sourceforge.net/forum/forum.php?thread_id=1839453&forum_id=59136
diff --git a/multimedia/mpeg4ip/files/patch-configure b/multimedia/mpeg4ip/files/patch-configure
index ac538a3ecee4..bf06ac088aa1 100644
--- a/multimedia/mpeg4ip/files/patch-configure
+++ b/multimedia/mpeg4ip/files/patch-configure
@@ -1,6 +1,31 @@
---- configure.orig Thu May 19 04:55:17 2005
-+++ configure Thu May 19 04:56:09 2005
-@@ -26062,8 +26062,8 @@
+--- configure.orig 2010-12-09 12:24:43.000000000 -0800
++++ configure 2010-12-09 12:25:28.000000000 -0800
+@@ -24544,13 +24544,12 @@
+ fi
+
+
+-{ echo "$as_me:$LINENO: checking for getopt_long in -lgnugetopt" >&5
+-echo $ECHO_N "checking for getopt_long in -lgnugetopt... $ECHO_C" >&6; }
++{ echo "$as_me:$LINENO: checking for getopt_long in -lc" >&5
++echo $ECHO_N "checking for getopt_long in -lc... $ECHO_C" >&6; }
+ if test "${ac_cv_lib_gnugetopt_getopt_long+set}" = set; then
+ echo $ECHO_N "(cached) $ECHO_C" >&6
+ else
+ ac_check_lib_save_LIBS=$LIBS
+-LIBS="-lgnugetopt $LIBS"
+ cat >conftest.$ac_ext <<_ACEOF
+ /* confdefs.h. */
+ _ACEOF
+@@ -24610,8 +24609,6 @@
+ #define HAVE_LIBGNUGETOPT 1
+ _ACEOF
+
+- LIBS="-lgnugetopt $LIBS"
+-
+ fi
+
+ { echo "$as_me:$LINENO: checking for library containing inet_addr" >&5
+@@ -26431,8 +26428,8 @@
if test x$have_ffmpeg_arg = xtrue; then
{ echo "$as_me:$LINENO: have enable ffmpeg $enable_ffmpeg" >&5
echo "$as_me: have enable ffmpeg $enable_ffmpeg" >&6;}
@@ -10,4 +35,4 @@
+ FFMPEG_LIB="${enable_ffmpeg}/lib/libavcodec.a -lz"
saveCFLAGS="$CFLAGS"
CFLAGS="$CFLAGS $FFMPEG_INC"
- echo "$as_me:$LINENO: checking for AVRational" >&5
+ { echo "$as_me:$LINENO: checking for AVRational" >&5
diff --git a/multimedia/mpeg4ip/files/patch-mpeg4ip_config.h.in b/multimedia/mpeg4ip/files/patch-mpeg4ip_config.h.in
index 8bfb7a0aff76..e69de29bb2d1 100644
--- a/multimedia/mpeg4ip/files/patch-mpeg4ip_config.h.in
+++ b/multimedia/mpeg4ip/files/patch-mpeg4ip_config.h.in
@@ -1,27 +0,0 @@
---- mpeg4ip_config.h.in.orig Tue May 18 13:31:06 2004
-+++ mpeg4ip_config.h.in Wed Sep 29 14:40:59 2004
-@@ -25,16 +25,12 @@
- #undef HAVE_FPOS_T___POS
-
- /* Define to 1 if you have the `getopt' function. */
--#undef HAVE_GETOPT
-
- /* Define to 1 if you have the <getopt.h> header file. */
--#undef HAVE_GETOPT_H
-
- /* Define to 1 if you have the `getopt_long' function. */
--#undef HAVE_GETOPT_LONG
-
- /* Define to 1 if you have the `getopt_long_only' function. */
--#undef HAVE_GETOPT_LONG_ONLY
-
- /* Define to 1 if you have the `getrusage' function. */
- #undef HAVE_GETRUSAGE
-@@ -67,7 +63,6 @@
- #undef HAVE_IPv6
-
- /* Define to 1 if you have the `gnugetopt' library (-lgnugetopt). */
--#undef HAVE_LIBGNUGETOPT
-
- /* have libmpeg2 decoder library */
- #undef HAVE_LIBMPEG2