aboutsummaryrefslogtreecommitdiff
path: root/net-im/centericq
diff options
context:
space:
mode:
authorChris Piazza <cpiazza@FreeBSD.org>1999-12-25 21:51:44 +0000
committerChris Piazza <cpiazza@FreeBSD.org>1999-12-25 21:51:44 +0000
commit50376c6eded6a3fb3c51509d48b1d523f97957a2 (patch)
treea6fb4c3c61f075c3105fcbc33e4bc9d9770087f1 /net-im/centericq
parent597d36d75b3925422901ef9f6b3f72ecedfe31a1 (diff)
downloadports-50376c6eded6a3fb3c51509d48b1d523f97957a2.tar.gz
ports-50376c6eded6a3fb3c51509d48b1d523f97957a2.zip
An ncurses based window- and menu-driven ICQ client. It is fully
featured and includes the ability to associate sounds with certain events. Requested by: Brent Kearneys <brent@kearneys.ca>
Notes
Notes: svn path=/head/; revision=24090
Diffstat (limited to 'net-im/centericq')
-rw-r--r--net-im/centericq/Makefile29
-rw-r--r--net-im/centericq/distinfo1
-rw-r--r--net-im/centericq/files/patch-aa35
-rw-r--r--net-im/centericq/files/patch-ab22
-rw-r--r--net-im/centericq/files/patch-ac11
-rw-r--r--net-im/centericq/pkg-comment1
-rw-r--r--net-im/centericq/pkg-descr5
-rw-r--r--net-im/centericq/pkg-plist7
8 files changed, 111 insertions, 0 deletions
diff --git a/net-im/centericq/Makefile b/net-im/centericq/Makefile
new file mode 100644
index 000000000000..5ba13655a99a
--- /dev/null
+++ b/net-im/centericq/Makefile
@@ -0,0 +1,29 @@
+# New ports collection makefile for: centericq
+# Version required: 2.0.0
+# Date created: 25 December 1999
+# Whom: Chris Piazza <cpiazza@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+DISTNAME= center-2.0.0
+CATEGORIES= net
+MASTER_SITES= http://konst.org.ua/download/
+
+MAINTAINER= cpiazza@FreeBSD.org
+
+WRKSRC= ${WRKDIR}/center
+USE_GMAKE= yes
+
+post-patch:
+ @${PERL} -pi -e 's:__PREFIX__:${PREFIX}:' ${WRKSRC}/centerICQ.cc
+
+pre-build:
+ @(cd ${WRKDIR}/ktools/src; ${SETENV} CFLAGS="${CFLAGS}" CXXFLAGS="${CXXFLAGS}" ${GMAKE} ${MAKE_ARGS} )
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/center ${PREFIX}/bin
+ @${MKDIR} ${PREFIX}/share/center
+ ${INSTALL_DATA} ${WRKSRC}/sound/* ${PREFIX}/share/center
+
+.include <bsd.port.mk>
diff --git a/net-im/centericq/distinfo b/net-im/centericq/distinfo
new file mode 100644
index 000000000000..a5d14f25c6a1
--- /dev/null
+++ b/net-im/centericq/distinfo
@@ -0,0 +1 @@
+MD5 (center-2.0.0.tar.gz) = c7fe346cdd8a49242fe833c14584023a
diff --git a/net-im/centericq/files/patch-aa b/net-im/centericq/files/patch-aa
new file mode 100644
index 000000000000..ab31bf61fe63
--- /dev/null
+++ b/net-im/centericq/files/patch-aa
@@ -0,0 +1,35 @@
+--- ../ktools/src/Makefile.orig Wed Nov 24 12:22:50 1999
++++ ../ktools/src/Makefile Sat Dec 25 13:32:33 1999
+@@ -1,15 +1,15 @@
+ # macros and variables
+
+-CC = gcc
+-CPP = g++
++CC ?= gcc
++CPP = ${CXX}
+ RANLIB = ranlib
+
+ INSTDIR = .
+ INSTDIR_LIB = $(INSTDIR)
+
+-CFLAGS = #-g -Wall -DUNIX
++CFLAGS += #-g -Wall -DUNIX
+
+-INCLUDE = -I/usr/include -I../include
++INCLUDE = -I../include
+ OBJS = konst.fs.o konst.process.o konst.interface.o konst.string.o konst.socket.o konst.parser.o konst.logic.o
+
+ #
+@@ -31,10 +31,10 @@
+ all: $(LIB)
+
+ %.o : %.cc
+- $(CPP) $*.cc -c $(INCLUDE) $(SSLINCL) -o $*.o
++ $(CPP) ${CXXFLAGS} $*.cc -c $(INCLUDE) $(SSLINCL) -o $*.o
+
+ %.o : %.c
+- $(CC) $*.c -c $(INCLUDE) $(SSLINCL) -o $*.o
++ $(CC) ${CFLAGS} $*.c -c $(INCLUDE) $(SSLINCL) -o $*.o
+
+ clean:
+ rm -f *.o $(LIB); \
diff --git a/net-im/centericq/files/patch-ab b/net-im/centericq/files/patch-ab
new file mode 100644
index 000000000000..ab89c230f19f
--- /dev/null
+++ b/net-im/centericq/files/patch-ab
@@ -0,0 +1,22 @@
+--- Makefile.orig Sat Dec 25 13:35:19 1999
++++ Makefile Sat Dec 25 13:36:05 1999
+@@ -1,14 +1,14 @@
+ # macros and variables
+-CC = gcc
+-CPP = g++
++CC ?= gcc
++CPP = ${CXX}
+
+ PROG1 = center
+-CFLAGS = #-g -Wall -DUNIX
++CFLAGS += #-g -Wall -DUNIX
+
+-INCLUDE = -I/usr/include -I../ktools/include
++INCLUDE = -I../ktools/include
+ KTLIBDIR = ../ktools
+ LIB = $(KTLIBDIR)/libkonst.a
+-LIBDIR = -L/usr/lib -L/usr/local/lib
++LIBDIR = -L${LOCALBASE}/lib -L${PREFIX}/lib
+ OBJS = centerICQ.o centerinfo.o phonebook.o icqlib.o center.o centersearch.o
+
+ # targets
diff --git a/net-im/centericq/files/patch-ac b/net-im/centericq/files/patch-ac
new file mode 100644
index 000000000000..44f173e5fad8
--- /dev/null
+++ b/net-im/centericq/files/patch-ac
@@ -0,0 +1,11 @@
+--- centerICQ.cc.orig Sat Dec 25 13:37:57 1999
++++ centerICQ.cc Sat Dec 25 13:38:46 1999
+@@ -1680,7 +1680,7 @@
+ mkdir(buf, S_IREAD | S_IWRITE | S_IEXEC);
+
+ if(QanswerY) {
+- sprintf(fname, "cp /usr/local/lib/center/*.wav %s/.center", getenv("HOME"));
++ sprintf(fname, "cp __PREFIX__/share/center/*.wav %s/.center", getenv("HOME"));
+ system(fname);
+ }
+
diff --git a/net-im/centericq/pkg-comment b/net-im/centericq/pkg-comment
new file mode 100644
index 000000000000..7d3a12164bf8
--- /dev/null
+++ b/net-im/centericq/pkg-comment
@@ -0,0 +1 @@
+An ICQ client with a useful ncurses menu and window-based interface.
diff --git a/net-im/centericq/pkg-descr b/net-im/centericq/pkg-descr
new file mode 100644
index 000000000000..7f09d4d670ce
--- /dev/null
+++ b/net-im/centericq/pkg-descr
@@ -0,0 +1,5 @@
+A textmode nucurses based window- and menu-driven ICQ client. It is
+fully featured and also includes the ability to associate sounds to
+certain events.
+
+WWW: http://konst.org.ua/software.centericq.html
diff --git a/net-im/centericq/pkg-plist b/net-im/centericq/pkg-plist
new file mode 100644
index 000000000000..59feab2efacf
--- /dev/null
+++ b/net-im/centericq/pkg-plist
@@ -0,0 +1,7 @@
+bin/center
+share/center/Contact.wav
+share/center/Message.wav
+share/center/Online.wav
+share/center/email.wav
+share/center/url.wav
+@dirrm share/center