aboutsummaryrefslogtreecommitdiff
path: root/net-im/cjc
diff options
context:
space:
mode:
authorWilliam Grzybowski <wg@FreeBSD.org>2013-12-15 15:59:14 +0000
committerWilliam Grzybowski <wg@FreeBSD.org>2013-12-15 15:59:14 +0000
commit6481746272d06a862b25985f8e64f19cbe66a9c7 (patch)
tree2cf7039e1f0f6ce418c713fbe7f5095e80002114 /net-im/cjc
parentf4305bab6d54aa46801719232a4de521d2f97532 (diff)
downloadports-6481746272d06a862b25985f8e64f19cbe66a9c7.tar.gz
ports-6481746272d06a862b25985f8e64f19cbe66a9c7.zip
net-im/cjc: fix python usage and minor fixes
- Fix python usage to remove implicit dependency on lang/python - Restrict to python 2.x - Remove uselesss LICENSE_FILE - Use new options for docs Reported by: exp-run (PR 184591)
Notes
Notes: svn path=/head/; revision=336550
Diffstat (limited to 'net-im/cjc')
-rw-r--r--net-im/cjc/Makefile10
1 files changed, 6 insertions, 4 deletions
diff --git a/net-im/cjc/Makefile b/net-im/cjc/Makefile
index c3f06853824d..9370ab3a16bb 100644
--- a/net-im/cjc/Makefile
+++ b/net-im/cjc/Makefile
@@ -10,11 +10,10 @@ MAINTAINER= ports@FreeBSD.org
COMMENT= The Console Jabber Client
LICENSE= GPLv2
-LICENSE_FILE= ${WRKSRC}/COPYING
RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}pyxmpp>=1.1.0:${PORTSDIR}/net-im/py-pyxmpp
-USE_PYTHON= 2.6+
+USE_PYTHON= 2
NO_STAGE= yes
post-patch:
@@ -25,10 +24,13 @@ post-patch:
/pkg_docdir/s|^|#|g ; \
s|INSTALL=.*|INSTALL=${INSTALL}| ; \
s|INSTALL_DATA=.*|INSTALL_DATA=${INSTALL_DATA}| ; \
- s|INSTALL_DIR=.*|INSTALL_DIR=${MKDIR}|g" ${WRKSRC}/Makefile
+ s|INSTALL_DIR=.*|INSTALL_DIR=${MKDIR}|g ; \
+ s|python |${PYTHON_CMD} |g" ${WRKSRC}/Makefile
+
+.include <bsd.port.options.mk>
post-install:
-.if !defined(NOPORTDOCS)
+.if ${PORT_OPTIONS:MDOCS}
@${MKDIR} ${DOCSDIR}
${INSTALL_DATA} ${WRKSRC}/doc/manual.html ${DOCSDIR}
${INSTALL_DATA} ${WRKSRC}/ChangeLog ${DOCSDIR}