aboutsummaryrefslogtreecommitdiff
path: root/net-im/gnomeicu/Makefile
diff options
context:
space:
mode:
authorJacques Vidrine <nectar@FreeBSD.org>1999-03-18 22:32:43 +0000
committerJacques Vidrine <nectar@FreeBSD.org>1999-03-18 22:32:43 +0000
commit2a668f8673ed69c4140b8e93763ac1628831ea9d (patch)
tree88c6d73c41ef1d5b9d5bff5ed874f5372d0e1bc0 /net-im/gnomeicu/Makefile
parent2d4fd20afba28c68eacb8d8b913c4e1023021ab9 (diff)
downloadports-2a668f8673ed69c4140b8e93763ac1628831ea9d.tar.gz
ports-2a668f8673ed69c4140b8e93763ac1628831ea9d.zip
gnomeicu is actually the new name for gtkicq. Fix mistake of
importing gnomeicu as a new port: * repository copy of ports/net/gtkicq to ports/net/gnome-icu [asami] * update ports/net/gnome-icu to 0.62a * remove ports/net/gtkicq * remove ports/net/gnomeicu PKGNAME remains gnomeicu-0.62a. It is expected that after some time has passed, that we can rename the port directory from gnome-icu to gnomeicu.
Notes
Notes: svn path=/head/; revision=17283
Diffstat (limited to 'net-im/gnomeicu/Makefile')
-rw-r--r--net-im/gnomeicu/Makefile40
1 files changed, 16 insertions, 24 deletions
diff --git a/net-im/gnomeicu/Makefile b/net-im/gnomeicu/Makefile
index f1a521e614e6..0ef5f23d8700 100644
--- a/net-im/gnomeicu/Makefile
+++ b/net-im/gnomeicu/Makefile
@@ -1,32 +1,24 @@
-# New ports collection makefile for: gtkicq
-# Version required: 0.56
-# Date created: Oct 15 1998
-# Whom: Vanilla Pooh Shu <vanilla@FreeBSD.ORG>
+# Ports collection Makefile for: GnomeICU
+# Version required: 0.62a
+# Date created: 03/16/1999
+# Whom: nectar@FreeBSD.ORG
#
-# $Id: Makefile,v 1.5 1999/01/12 16:50:45 vanilla Exp $
+# $Id: Makefile,v 1.1.1.1 1999/03/16 08:59:57 nectar Exp $
#
-DISTNAME= gtkicq-0.56
-CATEGORIES= net
-MASTER_SITES= ftp://ftp.bse.bg/pub/Unix/icq/ \
- ftp://ftp.infodrom.north.de/pub/unix/gtk-etc/apps/gtkicq/ \
- ftp://ftp.rnd.runnet.ru/pub/unix/GUI_Toolkits/gtk/
+DISTNAME= gnomeicu-0.62a
+CATEGORIES= net gnome
+MASTER_SITES= ftp://gnomeicu.gdev.net/pub/gnomeicu/ \
+ http://www.nectar.com/distfiles/
-MAINTAINER= nacai@iname.com
+LIB_DEPENDS= gnome.1:${PORTSDIR}/x11/gnomelibs \
+ gdk_imlib.3:${PORTSDIR}/graphics/imlib
-LIB_DEPENDS= gnome.1:${PORTSDIR}/x11/gnomelibs \
- panel_applet.0:${PORTSDIR}/x11/gnomecore
+MAINTAINER= nectar@FreeBSD.ORG
-BROKEN= "gtkicq 0.58 is out"
-
-USE_X_PREFIX= yes
-USE_GMAKE= yes
-GNU_CONFIGURE= yes
-CONFIGURE_ARGS= --localstatedir=${PREFIX}/share/gnome \
- --datadir=${PREFIX}/share/gnome \
- --with-gnome=${X11BASE}
-CONFIGURE_ENV= CPPFLAGS="${CFLAGS} -I${LOCALBASE}/include \
- -I${X11BASE}/include" \
- LIBS="-L${LOCALBASE}/lib -L${X11BASE}/lib -lxpg4"
+USE_X_PREFIX= YES
+GNU_CONFIGURE= YES
+CONFIGURE_ENV= GTK_CONFIG="${X11BASE}/bin/gtk12-config"
+CONFIGURE_ARGS= --datadir=${PREFIX}/share/gnome
.include <bsd.port.mk>