aboutsummaryrefslogtreecommitdiff
path: root/net-im/jabber-pymsn
diff options
context:
space:
mode:
authorRenato Botelho <garga@FreeBSD.org>2006-01-25 09:18:20 +0000
committerRenato Botelho <garga@FreeBSD.org>2006-01-25 09:18:20 +0000
commitf5d72ccb3ce4e9e24b292fea035150e7b0d3138f (patch)
treedba8ab3d74629724d07ec14d6b4d85da0ef549fc /net-im/jabber-pymsn
parentda8c3a42d81c02076e6340859dc6fd749d009d05 (diff)
downloadports-f5d72ccb3ce4e9e24b292fea035150e7b0d3138f.tar.gz
ports-f5d72ccb3ce4e9e24b292fea035150e7b0d3138f.zip
- Fix installation of rc.d script [1]
- Bump PORTREVISION - Rework on rc.d script - Remove obsolete USE_REINPLACE PR: ports/92259 Submitted by: garga Approved by: maintainer Reported by: krismail [1]
Notes
Notes: svn path=/head/; revision=154406
Diffstat (limited to 'net-im/jabber-pymsn')
-rw-r--r--net-im/jabber-pymsn/Makefile3
-rw-r--r--net-im/jabber-pymsn/files/jabber-pymsn-transport.sh.in24
2 files changed, 13 insertions, 14 deletions
diff --git a/net-im/jabber-pymsn/Makefile b/net-im/jabber-pymsn/Makefile
index 9ef009cad278..2c1f9abd2615 100644
--- a/net-im/jabber-pymsn/Makefile
+++ b/net-im/jabber-pymsn/Makefile
@@ -6,6 +6,7 @@
PORTNAME= pymsn
PORTVERSION= 0.10.2
+PORTREVISION= 1
CATEGORIES= net-im
MASTER_SITES= http://msn-transport.jabberstudio.org/tarballs/
PKGNAMEPREFIX= jabber-
@@ -21,7 +22,6 @@ RUN_DEPENDS= ${PYTHON_SITELIBDIR}/OpenSSL/__init__.py:${PORTSDIR}/security/py-op
NO_BUILD= yes
USE_PYTHON= yes
-USE_REINPLACE= yes
USE_RC_SUBR= jabber-pymsn-transport.sh
SUB_FILES= pkg-message
@@ -55,7 +55,6 @@ do-install:
${CP} -pPR ${WRKSRC}/src/* ${INST_DIR}/
${CHMOD} 755 ${INST_DIR}/main.py
[ -f ${INST_DIR}/config.py ] || ${CP} ${INST_DIR}/config.py.sample ${INST_DIR}/config.py
- ${INSTALL_SCRIPT} -m 751 ${WRKDIR}/${PKGBASE}.sh ${PREFIX}/etc/rc.d/${PKGBASE}.sh
@${MKDIR} ${EXAMPLESDIR}/etc
${INSTALL_DATA} ${WRKSRC}/config-example.xml ${EXAMPLESDIR}/etc/jabber-pymsn.xml
[ -f ${PREFIX}/etc/jabber-pymsn.xml ] || ${CP} ${EXAMPLESDIR}/etc/jabber-pymsn.xml ${PREFIX}/etc/jabber-pymsn.xml
diff --git a/net-im/jabber-pymsn/files/jabber-pymsn-transport.sh.in b/net-im/jabber-pymsn/files/jabber-pymsn-transport.sh.in
index 071613156acc..cfdd3dcf94dd 100644
--- a/net-im/jabber-pymsn/files/jabber-pymsn-transport.sh.in
+++ b/net-im/jabber-pymsn/files/jabber-pymsn-transport.sh.in
@@ -1,8 +1,7 @@
#!/bin/sh
-
-# Start or stop jabber-pymsn
+#
# $FreeBSD$
-
+#
# PROVIDE: jabber_pymsn
# REQUIRE: DAEMON
# BEFORE: LOGIN
@@ -12,22 +11,23 @@
# /etc/rc.conf
# /etc/rc.conf.local
#
-# DO NOT CHANGE THESE DEFAULT VALUES HERE
-#
-jabber_pymsn_dir=${jabberd_pymsn_dir-"%%PREFIX%%/lib/jabber/pymsn"}
-jabber_pymsn_piddir=${jabberd_pymsn_piddir-"/var/jabberd/pid"}
-jabber_pymsn_enable=${jabberd_pymsn_enable-"NO"}
. %%RC_SUBR%%
name="jabber_pymsn"
rcvar=`set_rcvar`
-command_interpreter="%%PYTHON_CMD%%"
-command="${jabber_pymsn_dir}/main.py"
-command_args="&"
+
+load_rc_config $name
+
+: ${jabber_pymsn_dir="%%PREFIX%%/lib/jabber/pymsn"}
+: ${jabber_pymsn_piddir="/var/jabberd/pid"}
+: ${jabber_pymsn_enable="NO"}
+
jabber_pymsn_chdir=${jabber_pymsn_dir}
pidfile="${jabber_pymsn_piddir}/pymsn.pid"
+command_interpreter="%%PYTHON_CMD%%"
+command="${jabber_pymsn_dir}/main.py"
+command_args="-o pid=${pidfile} &"
-load_rc_config $name
run_rc_command "$1"