aboutsummaryrefslogtreecommitdiff
path: root/net-im/jabber
diff options
context:
space:
mode:
authorRenato Botelho <garga@FreeBSD.org>2006-09-03 12:53:16 +0000
committerRenato Botelho <garga@FreeBSD.org>2006-09-03 12:53:16 +0000
commitc65763847e04708512591461a2857f2e8e5f16af (patch)
treed5202734d51665ce25de487e6168c593b4ca092b /net-im/jabber
parent718b1278a839eae5dcb2ae4337a93d4f92e6c78b (diff)
downloadports-c65763847e04708512591461a2857f2e8e5f16af.tar.gz
ports-c65763847e04708512591461a2857f2e8e5f16af.zip
- Fix fd_set vulnerability and save this port to be removed
- Bump PORTREVISION Provided by: author
Notes
Notes: svn path=/head/; revision=172045
Diffstat (limited to 'net-im/jabber')
-rw-r--r--net-im/jabber/Makefile3
-rw-r--r--net-im/jabber/files/patch-jabberd_mio.c16
2 files changed, 17 insertions, 2 deletions
diff --git a/net-im/jabber/Makefile b/net-im/jabber/Makefile
index 21398a457941..ae4acc2c1917 100644
--- a/net-im/jabber/Makefile
+++ b/net-im/jabber/Makefile
@@ -7,6 +7,7 @@
PORTNAME= jabber
PORTVERSION= 1.4.3.1
+PORTREVISION= 1
PORTEPOCH= 1
CATEGORIES= net-im
MASTER_SITES= http://devel.amessage.info/jabberd14/
@@ -19,8 +20,6 @@ COMMENT= Online presence and instant messaging server
LIB_DEPENDS= pth.20:${PORTSDIR}/devel/pth \
expat.6:${PORTSDIR}/textproc/expat2
-DEPRECATED= fd_set -- bitmap index overflow in multiple applications.
-
USE_RC_SUBR= jabberd.sh
USE_BZIP2= yes
GNU_CONFIGURE= yes
diff --git a/net-im/jabber/files/patch-jabberd_mio.c b/net-im/jabber/files/patch-jabberd_mio.c
new file mode 100644
index 000000000000..24a2714d2a89
--- /dev/null
+++ b/net-im/jabber/files/patch-jabberd_mio.c
@@ -0,0 +1,16 @@
+--- jabberd/mio.c.orig Wed Nov 12 22:19:08 2003
++++ jabberd/mio.c Sun Sep 3 09:40:22 2006
+@@ -530,6 +530,13 @@
+ return NULL;
+ }
+
++ /* do not accept a higher fd than FD_SET, or FD_CLR can handle */
++ if (fd >= FD_SETSIZE) {
++ log_warn(NULL, "could not accept incomming connection, maximum number of connections reached (%i)", FD_SETSIZE);
++ close(fd);
++ return NULL;
++ }
++
+ #ifdef WITH_IPV6
+ allow = _mio_allow_check(inet_ntop(AF_INET6, &serv_addr.sin6_addr, addr_str, sizeof(addr_str)));
+ deny = _mio_deny_check(addr_str);