aboutsummaryrefslogtreecommitdiff
path: root/net-im/jabberd
diff options
context:
space:
mode:
authorMartin Matuska <mm@FreeBSD.org>2007-08-02 08:34:42 +0000
committerMartin Matuska <mm@FreeBSD.org>2007-08-02 08:34:42 +0000
commit14a2c73b953a1ca3d4009b17d6d3a6cbab1451f2 (patch)
tree47e3f133e7b97b6d1a6d90719206384ddcc63330 /net-im/jabberd
parent7df934cf0e11f00ccba025ab7dded593b73cf80e (diff)
downloadports-14a2c73b953a1ca3d4009b17d6d3a6cbab1451f2.tar.gz
ports-14a2c73b953a1ca3d4009b17d6d3a6cbab1451f2.zip
- Update to 2.1.12
- Remove patch-aa (included in source) Approved by: garga (mentor, implicit)
Notes
Notes: svn path=/head/; revision=196938
Diffstat (limited to 'net-im/jabberd')
-rw-r--r--net-im/jabberd/Makefile2
-rw-r--r--net-im/jabberd/distinfo6
-rw-r--r--net-im/jabberd/files/patch-aa104
3 files changed, 4 insertions, 108 deletions
diff --git a/net-im/jabberd/Makefile b/net-im/jabberd/Makefile
index 9061016ff808..cb228dc6b76c 100644
--- a/net-im/jabberd/Makefile
+++ b/net-im/jabberd/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= jabberd
-PORTVERSION= 2.1.11
+PORTVERSION= 2.1.12
CATEGORIES= net-im
MASTER_SITES= http://ftp.xiaoka.com/jabberd2/releases/
DIST_SUBDIR= jabber
diff --git a/net-im/jabberd/distinfo b/net-im/jabberd/distinfo
index db2fc369bbc1..3508129837d3 100644
--- a/net-im/jabberd/distinfo
+++ b/net-im/jabberd/distinfo
@@ -1,3 +1,3 @@
-MD5 (jabber/jabberd-2.1.11.tar.gz) = 77ddfa7d94f1f61c08fcb9bcd31bea6c
-SHA256 (jabber/jabberd-2.1.11.tar.gz) = 4432cb65cd3f5029e97565d742c122d890c6e5fcb536ba80470ee6e71497fa4a
-SIZE (jabber/jabberd-2.1.11.tar.gz) = 1394797
+MD5 (jabber/jabberd-2.1.12.tar.gz) = 8e1baf571efd2440d9873baa4462c94e
+SHA256 (jabber/jabberd-2.1.12.tar.gz) = 052af1fd8a7e4de78dae923700fea145235e645c16c656518e2b7f0304397749
+SIZE (jabber/jabberd-2.1.12.tar.gz) = 1397306
diff --git a/net-im/jabberd/files/patch-aa b/net-im/jabberd/files/patch-aa
deleted file mode 100644
index 72f650a61d9d..000000000000
--- a/net-im/jabberd/files/patch-aa
+++ /dev/null
@@ -1,104 +0,0 @@
-Index: sm/mod_privacy.c
-===================================================================
---- sm/mod_privacy.c (revision 310)
-+++ sm/mod_privacy.c (working copy)
-@@ -205,7 +205,7 @@
- continue;
- }
-
-- pool_cleanup(zlist->p, free, zitem->jid);
-+ pool_cleanup(zlist->p, jid_free, zitem->jid);
-
- log_debug(ZONE, "jid item with value '%s'", jid_full(zitem->jid));
-
-@@ -696,7 +696,7 @@
- return -stanza_err_BAD_REQUEST;
- }
-
-- pool_cleanup(p, free, zitem->jid);
-+ pool_cleanup(p, jid_free, zitem->jid);
-
- log_debug(ZONE, "jid item with value '%s'", jid_full(zitem->jid));
-
-Index: sm/main.c
-===================================================================
---- sm/main.c (revision 310)
-+++ sm/main.c (working copy)
-@@ -392,6 +392,7 @@
- xhash_free(sm->acls);
- xhash_free(sm->features);
- xhash_free(sm->xmlns);
-+ xhash_free(sm->xmlns_refcount);
- xhash_free(sm->users);
-
- sx_free(sm->router);
-Index: c2s/main.c
-===================================================================
---- c2s/main.c (revision 310)
-+++ c2s/main.c (working copy)
-@@ -698,6 +698,7 @@
- if(sess->ip != NULL) free(sess->ip);
- if(sess->result != NULL) nad_free(sess->result);
- if(sess->jid != NULL) jid_free(sess->jid);
-+ if(sess->rate != NULL) rate_free(sess->rate);
-
- free(sess);
- }
-Index: sx/sasl_gsasl.c
-===================================================================
---- sx/sasl_gsasl.c (revision 310)
-+++ sx/sasl_gsasl.c (working copy)
-@@ -338,6 +338,7 @@
- if(ret != GSASL_OK && ret != GSASL_NEEDS_MORE) {
- _sx_debug(ZONE, "gsasl_step failed, no sasl for this conn; (%d): %s", ret, gsasl_strerror(ret));
- _sx_nad_write(s, _sx_sasl_failure(s, _sasl_err_MALFORMED_REQUEST), 0);
-+ if(buf != NULL) free(buf);
- return;
- }
- }
-@@ -350,6 +351,7 @@
- if(ret != GSASL_OK && ret != GSASL_NEEDS_MORE) {
- _sx_debug(ZONE, "gsasl_step failed, no sasl for this conn; (%d): %s", ret, gsasl_strerror(ret));
- _sx_nad_write(s, _sx_sasl_failure(s, _sasl_err_MALFORMED_REQUEST), 0);
-+ if(buf != NULL) free(buf);
- return;
- }
-
-Index: mio/mio_impl.h
-===================================================================
---- mio/mio_impl.h (revision 310)
-+++ mio/mio_impl.h (working copy)
-@@ -133,6 +133,7 @@
- FD(m,fd)->type = type_CLOSED;
- FD(m,fd)->app = NULL;
- FD(m,fd)->arg = NULL;
-+ MIO_FREE_FD(m, fd);
- }
-
- /** internally accept an incoming connection from a listen sock */
-@@ -259,12 +260,6 @@
- if(ACT(m, fd, action_WRITE, NULL) == 0)
- MIO_UNSET_WRITE(m, FD(m,fd));
- }
--
-- /* deferred closing fd */
-- if(FD(m,fd)->type == type_CLOSED)
-- {
-- MIO_FREE_FD(m, fd);
-- }
- }
- }
-
-Index: util/jid.c
-===================================================================
---- util/jid.c (revision 310)
-+++ util/jid.c (working copy)
-@@ -332,7 +332,7 @@
- else {
- /* allocate new data buffer */
- jid->jid_data_len = node_l+domain_l+resource_l+3;
-- jid->jid_data = malloc(jid->jid_data_len);
-+ jid->jid_data = realloc(jid->jid_data, jid->jid_data_len);
- }
-
- /* copy to buffer */