aboutsummaryrefslogtreecommitdiff
path: root/net-im/ktp-auth-handler
diff options
context:
space:
mode:
authorAlberto Villa <avilla@FreeBSD.org>2013-05-02 21:42:57 +0000
committerAlberto Villa <avilla@FreeBSD.org>2013-05-02 21:42:57 +0000
commite1a902c8f1bc45e453cee9fe30fa16701bea0437 (patch)
tree700b72713f2f432552d1beb35041137fd3912c25 /net-im/ktp-auth-handler
parent6685af89c24cd06d1069f2c179ca6b5bfe5d9e0a (diff)
downloadports-e1a902c8f1bc45e453cee9fe30fa16701bea0437.tar.gz
ports-e1a902c8f1bc45e453cee9fe30fa16701bea0437.zip
- Add ports for KDE Telepathy modules.
None of these ports is supposed to be installed by hand. A metaport is coming in my next commit.
Notes
Notes: svn path=/head/; revision=317154
Diffstat (limited to 'net-im/ktp-auth-handler')
-rw-r--r--net-im/ktp-auth-handler/Makefile24
-rw-r--r--net-im/ktp-auth-handler/distinfo2
-rw-r--r--net-im/ktp-auth-handler/pkg-descr8
-rw-r--r--net-im/ktp-auth-handler/pkg-plist51
4 files changed, 85 insertions, 0 deletions
diff --git a/net-im/ktp-auth-handler/Makefile b/net-im/ktp-auth-handler/Makefile
new file mode 100644
index 000000000000..761a746bffcd
--- /dev/null
+++ b/net-im/ktp-auth-handler/Makefile
@@ -0,0 +1,24 @@
+# $FreeBSD$
+
+PORTNAME= ktp-auth-handler
+PORTVERSION= ${KTP_VERSION}
+CATEGORIES= net-im kde
+MASTER_SITES= ${MASTER_SITE_KDE}
+MASTER_SITE_SUBDIR= ${KTP_BRANCH}/kde-telepathy/${PORTVERSION}/src
+
+MAINTAINER= avilla@FreeBSD.org
+COMMENT= KWallet integration module for KDE Telepathy
+
+LIB_DEPENDS= qjson:${PORTSDIR}/devel/qjson \
+ qca:${PORTSDIR}/devel/qca \
+ telepathy-qt4:${PORTSDIR}/net-im/telepathy-qt4 \
+ ktpcommoninternalsprivate:${PORTSDIR}/net-im/ktp-common-internals
+
+USE_KDE4= kdehier kdeprefix kdelibs automoc4
+USE_QT4= corelib dbus gui xml webkit \
+ moc_build qmake_build rcc_build uic_build
+USES= cmake gettext
+USE_BZIP2= yes
+MAKE_JOBS_SAFE= yes
+
+.include <bsd.port.mk>
diff --git a/net-im/ktp-auth-handler/distinfo b/net-im/ktp-auth-handler/distinfo
new file mode 100644
index 000000000000..bb5ae34b1c14
--- /dev/null
+++ b/net-im/ktp-auth-handler/distinfo
@@ -0,0 +1,2 @@
+SHA256 (ktp-auth-handler-0.6.1.tar.bz2) = f743dcc230e72155ed04da21dd6b5e2d74feb042b408df3f8c3c6fbf3f9b5826
+SIZE (ktp-auth-handler-0.6.1.tar.bz2) = 42973
diff --git a/net-im/ktp-auth-handler/pkg-descr b/net-im/ktp-auth-handler/pkg-descr
new file mode 100644
index 000000000000..7c6d4cc80870
--- /dev/null
+++ b/net-im/ktp-auth-handler/pkg-descr
@@ -0,0 +1,8 @@
+The KDE Telepathy project aims to integrate real time communication
+deeply into KDE Workspaces, and to provide an infrastructure to aid
+development of collaborative features for KDE Applications.
+
+This module handles KWallet integration, and prompts/sends passwords
+to connection managers when requested.
+
+WWW: http://community.kde.org/KTp
diff --git a/net-im/ktp-auth-handler/pkg-plist b/net-im/ktp-auth-handler/pkg-plist
new file mode 100644
index 000000000000..a438be8d40a8
--- /dev/null
+++ b/net-im/ktp-auth-handler/pkg-plist
@@ -0,0 +1,51 @@
+lib/kde4/libexec/ktp-auth-handler
+share/dbus-1/services/org.freedesktop.Telepathy.Client.KTp.ConfAuthObserver.service
+share/dbus-1/services/org.freedesktop.Telepathy.Client.KTp.SASLHandler.service
+share/dbus-1/services/org.freedesktop.Telepathy.Client.KTp.TLSHandler.service
+share/locale/bs/LC_MESSAGES/ktp-auth-handler.mo
+share/locale/ca/LC_MESSAGES/ktp-auth-handler.mo
+share/locale/ca@valencia/LC_MESSAGES/ktp-auth-handler.mo
+share/locale/cs/LC_MESSAGES/ktp-auth-handler.mo
+share/locale/da/LC_MESSAGES/ktp-auth-handler.mo
+share/locale/de/LC_MESSAGES/ktp-auth-handler.mo
+share/locale/el/LC_MESSAGES/ktp-auth-handler.mo
+share/locale/es/LC_MESSAGES/ktp-auth-handler.mo
+share/locale/et/LC_MESSAGES/ktp-auth-handler.mo
+share/locale/fi/LC_MESSAGES/ktp-auth-handler.mo
+share/locale/fr/LC_MESSAGES/ktp-auth-handler.mo
+share/locale/ga/LC_MESSAGES/ktp-auth-handler.mo
+share/locale/gl/LC_MESSAGES/ktp-auth-handler.mo
+share/locale/hu/LC_MESSAGES/ktp-auth-handler.mo
+share/locale/ia/LC_MESSAGES/ktp-auth-handler.mo
+share/locale/it/LC_MESSAGES/ktp-auth-handler.mo
+share/locale/ja/LC_MESSAGES/ktp-auth-handler.mo
+share/locale/kk/LC_MESSAGES/ktp-auth-handler.mo
+share/locale/km/LC_MESSAGES/ktp-auth-handler.mo
+share/locale/lt/LC_MESSAGES/ktp-auth-handler.mo
+share/locale/mr/LC_MESSAGES/ktp-auth-handler.mo
+share/locale/nb/LC_MESSAGES/ktp-auth-handler.mo
+share/locale/nds/LC_MESSAGES/ktp-auth-handler.mo
+share/locale/nl/LC_MESSAGES/ktp-auth-handler.mo
+share/locale/pl/LC_MESSAGES/ktp-auth-handler.mo
+share/locale/pt/LC_MESSAGES/ktp-auth-handler.mo
+share/locale/pt_BR/LC_MESSAGES/ktp-auth-handler.mo
+share/locale/ro/LC_MESSAGES/ktp-auth-handler.mo
+share/locale/ru/LC_MESSAGES/ktp-auth-handler.mo
+share/locale/sk/LC_MESSAGES/ktp-auth-handler.mo
+share/locale/sl/LC_MESSAGES/ktp-auth-handler.mo
+share/locale/sr/LC_MESSAGES/ktp-auth-handler.mo
+share/locale/sr@ijekavian/LC_MESSAGES/ktp-auth-handler.mo
+share/locale/sr@ijekavianlatin/LC_MESSAGES/ktp-auth-handler.mo
+share/locale/sr@latin/LC_MESSAGES/ktp-auth-handler.mo
+share/locale/sv/LC_MESSAGES/ktp-auth-handler.mo
+share/locale/uk/LC_MESSAGES/ktp-auth-handler.mo
+share/locale/vi/LC_MESSAGES/ktp-auth-handler.mo
+share/locale/zh_CN/LC_MESSAGES/ktp-auth-handler.mo
+share/locale/zh_TW/LC_MESSAGES/ktp-auth-handler.mo
+share/telepathy/clients/KTp.ConfAuthObserver.client
+share/telepathy/clients/KTp.SASLHandler.client
+share/telepathy/clients/KTp.TLSHandler.client
+@dirrmtry share/telepathy/clients
+@dirrmtry share/telepathy
+@dirrmtry share/locale/ia/LC_MESSAGES
+@dirrmtry share/locale/ia