aboutsummaryrefslogtreecommitdiff
path: root/net-im/libjingle
diff options
context:
space:
mode:
authorMario Sergio Fujikawa Ferreira <lioux@FreeBSD.org>2006-03-15 18:34:59 +0000
committerMario Sergio Fujikawa Ferreira <lioux@FreeBSD.org>2006-03-15 18:34:59 +0000
commit7e82c2a12391d253894a1a8e6e1ec9f584c70f3d (patch)
tree333eea41a23dde7e29d57f5ded7fae4b70bce050 /net-im/libjingle
parentf5916489f041feeca29a67c0876ab59b7a146de7 (diff)
downloadports-7e82c2a12391d253894a1a8e6e1ec9f584c70f3d.tar.gz
ports-7e82c2a12391d253894a1a8e6e1ec9f584c70f3d.zip
o net-im/libjingle source code makes assumptions about some of the
types and the architecture it is being built on. o Fix such a mistake brought up by the FreeBSD ports' building cluster on !i386 ARCHs. o Remove BROKEN status on !i386 ARCHs.
Notes
Notes: svn path=/head/; revision=157317
Diffstat (limited to 'net-im/libjingle')
-rw-r--r--net-im/libjingle/Makefile4
-rw-r--r--net-im/libjingle/files/patch-talk__session__phone__voicechannel.cc11
2 files changed, 11 insertions, 4 deletions
diff --git a/net-im/libjingle/Makefile b/net-im/libjingle/Makefile
index b6c9605c92a7..40eb31d25224 100644
--- a/net-im/libjingle/Makefile
+++ b/net-im/libjingle/Makefile
@@ -82,10 +82,6 @@ post-install:
.include <bsd.port.pre.mk>
-.if ${ARCH} != "i386"
-BROKEN= Does not compile on !i386
-.endif
-
LDFLAGS+=-L${LOCALBASE}/lib -L${OPENSSLLIB} ${PTHREAD_LIBS}
PKG_CONFIG?=${LOCALBASE}/bin/pkg-config
diff --git a/net-im/libjingle/files/patch-talk__session__phone__voicechannel.cc b/net-im/libjingle/files/patch-talk__session__phone__voicechannel.cc
new file mode 100644
index 000000000000..5532f4fbaa0d
--- /dev/null
+++ b/net-im/libjingle/files/patch-talk__session__phone__voicechannel.cc
@@ -0,0 +1,11 @@
+--- talk/session/phone/voicechannel.cc.orig Fri Mar 3 08:39:15 2006
++++ talk/session/phone/voicechannel.cc Fri Mar 3 08:39:36 2006
+@@ -159,7 +159,7 @@
+ channel_->OnPacketReceived(data, (int)len);
+ }
+
+-void VoiceChannel::SendPacket(const void *data, unsigned int len) {
++void VoiceChannel::SendPacket(const void *data, size_t len) {
+ // SendPacket gets called from MediaEngine; send to socket
+ // MediaEngine will call us on a random thread. The Send operation on the socket is
+ // special in that it can handle this.