aboutsummaryrefslogtreecommitdiff
path: root/net-im/libmsn
diff options
context:
space:
mode:
authorMax Brazhnikov <makc@FreeBSD.org>2009-01-16 21:34:44 +0000
committerMax Brazhnikov <makc@FreeBSD.org>2009-01-16 21:34:44 +0000
commita021dc52d6612c5e29712ed704dd4c8f5ce20d4c (patch)
tree8a642a226905f3bf19e414a5e41791d95ba328ee /net-im/libmsn
parent8d83f700199a1b96bc3f5c15dfb24033ea6aabb8 (diff)
downloadports-a021dc52d6612c5e29712ed704dd4c8f5ce20d4c.tar.gz
ports-a021dc52d6612c5e29712ed704dd4c8f5ce20d4c.zip
Fix build on amd64.
PR: ports/130197 Submitted by: Matt Tosto <datahead4 at gmail.com> (maintainer) Approved by: miwi (mentor)
Notes
Notes: svn path=/head/; revision=226289
Diffstat (limited to 'net-im/libmsn')
-rw-r--r--net-im/libmsn/Makefile1
-rw-r--r--net-im/libmsn/files/patch-msn__util.cpp26
-rw-r--r--net-im/libmsn/files/patch-msntest__CMakeLists.txt11
3 files changed, 27 insertions, 11 deletions
diff --git a/net-im/libmsn/Makefile b/net-im/libmsn/Makefile
index fc9994b905f4..414da062c359 100644
--- a/net-im/libmsn/Makefile
+++ b/net-im/libmsn/Makefile
@@ -8,6 +8,7 @@
PORTNAME= libmsn
DISTVERSION= 4.0-beta2
+PORTREVISION= 1
CATEGORIES= net-im
MASTER_SITES= SF
diff --git a/net-im/libmsn/files/patch-msn__util.cpp b/net-im/libmsn/files/patch-msn__util.cpp
new file mode 100644
index 000000000000..40d202ae8017
--- /dev/null
+++ b/net-im/libmsn/files/patch-msn__util.cpp
@@ -0,0 +1,26 @@
+--- ./msn/util.cpp.orig 2008-11-16 16:27:05.000000000 +0300
++++ ./msn/util.cpp 2009-01-16 20:32:29.000000000 +0300
+@@ -29,7 +29,7 @@
+ #include <fstream>
+ #include <openssl/rand.h>
+ #include <cstring>
+-#include <sys/timeb.h>
++#include <sys/time.h>
+ #include "md5.h"
+
+ #ifdef _WIN32
+@@ -352,10 +352,11 @@
+
+ std::string new_branch()
+ {
+- struct timeb t;
+- ftime(&t);
++ struct timeval t;
++ struct timezone tz;
++ gettimeofday(&t, &tz);
+ char branch[100];
+- srand(t.millitm);
++ srand(t.tv_usec);
+ unsigned int a=random();
+ srand(a);
+ unsigned short b=random();
diff --git a/net-im/libmsn/files/patch-msntest__CMakeLists.txt b/net-im/libmsn/files/patch-msntest__CMakeLists.txt
deleted file mode 100644
index 7c9fe10d25fd..000000000000
--- a/net-im/libmsn/files/patch-msntest__CMakeLists.txt
+++ /dev/null
@@ -1,11 +0,0 @@
---- ./msntest/CMakeLists.txt.orig 2008-11-13 03:41:03.000000000 +0300
-+++ ./msntest/CMakeLists.txt 2008-12-28 22:10:09.000000000 +0300
-@@ -3,7 +3,7 @@
- )
-
- add_executable (msntest ${msntest_SRCS} )
--target_link_libraries(msntest crypto msn ssl)
-+target_link_libraries(msntest crypto msn ssl compat)
-
- ########### install files ###############
- install(TARGETS msntest DESTINATION ${CMAKE_INSTALL_PREFIX}/bin)