aboutsummaryrefslogtreecommitdiff
path: root/net-im/licq-console
diff options
context:
space:
mode:
authorDirk Meyer <dinoex@FreeBSD.org>2004-10-13 12:33:21 +0000
committerDirk Meyer <dinoex@FreeBSD.org>2004-10-13 12:33:21 +0000
commit9343e5b1f8d3e95a8ed6bece2b2fb8622669d70c (patch)
tree255a7b45caf0b49234b827b6cffbacb2056a39ec /net-im/licq-console
parent5cd0be1945f3840de3e170e2f555d3f05b3a6b9b (diff)
downloadports-9343e5b1f8d3e95a8ed6bece2b2fb8622669d70c.tar.gz
ports-9343e5b1f8d3e95a8ed6bece2b2fb8622669d70c.zip
- Fix gcc regression in STABLE
Notes
Notes: svn path=/head/; revision=119219
Diffstat (limited to 'net-im/licq-console')
-rw-r--r--net-im/licq-console/Makefile11
-rw-r--r--net-im/licq-console/files/patch-window.h11
2 files changed, 21 insertions, 1 deletions
diff --git a/net-im/licq-console/Makefile b/net-im/licq-console/Makefile
index cba731a9a398..26571163efd0 100644
--- a/net-im/licq-console/Makefile
+++ b/net-im/licq-console/Makefile
@@ -14,10 +14,19 @@ LIB_DEPENDS= cdk.4:${PORTSDIR}/devel/cdk
MAINTAINER= dinoex@FreeBSD.org
COMMENT= Ncurses-based console plugin for Licq
-CONFIGURE_ENV= CPPFLAGS="${PTHREAD_CFLAGS}" \
+CONFIGURE_ENV= CPPFLAGS="${CPPFLAGS}" \
+ LDFLAGS="${LDFLAGS}" \
LIBS="${PTHREAD_LIBS}"
LICQ_PORT?= net/licq
+CPPFLAGS+= ${PTHREAD_CFLAGS}
+CPPFLAGS+= -I${LOCALBASE}/include
+LDFLAGS+= -L${LOCALBASE}/lib
.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} < 500000
+USE_GCC= 3.3
+.endif
+
.include "${PORTSDIR}/${LICQ_PORT}/Makefile.inc"
.include <bsd.port.post.mk>
diff --git a/net-im/licq-console/files/patch-window.h b/net-im/licq-console/files/patch-window.h
new file mode 100644
index 000000000000..f598519eb3fb
--- /dev/null
+++ b/net-im/licq-console/files/patch-window.h
@@ -0,0 +1,11 @@
+--- src/window.h.orig Thu Sep 30 03:51:03 2004
++++ src/window.h Wed Oct 13 14:19:58 2004
+@@ -3,7 +3,7 @@
+
+ #include <iostream>
+ extern "C" {
+-#include <cdk.h>
++#include <cdk/cdk.h>
+ }
+
+ #define COLOR_YELLOW_BLUE COLOR_YELLOW + 8