aboutsummaryrefslogtreecommitdiff
path: root/net-im/loudmouth/Makefile
diff options
context:
space:
mode:
authorJeremy Messenger <mezz@FreeBSD.org>2011-06-04 22:41:01 +0000
committerJeremy Messenger <mezz@FreeBSD.org>2011-06-04 22:41:01 +0000
commitb4c3f89c3dd294fd7d804a82ed8c150d70e102fd (patch)
tree9792e0c80aaadcc43f30e4256afa795f275052f9 /net-im/loudmouth/Makefile
parentba7d64a8cbb022be90bcc5975b5b8985f7cc0b97 (diff)
downloadports-b4c3f89c3dd294fd7d804a82ed8c150d70e102fd.tar.gz
ports-b4c3f89c3dd294fd7d804a82ed8c150d70e102fd.zip
Add OpenSSL option if you want it instead of GnuTLS. The GnuTLS is default.
PR: ports/155969 Submitted by: Zhihao Yuan <lichray@gmail.com>
Notes
Notes: svn path=/head/; revision=275077
Diffstat (limited to 'net-im/loudmouth/Makefile')
-rw-r--r--net-im/loudmouth/Makefile23
1 files changed, 16 insertions, 7 deletions
diff --git a/net-im/loudmouth/Makefile b/net-im/loudmouth/Makefile
index e703db2d5879..dad52ac49bce 100644
--- a/net-im/loudmouth/Makefile
+++ b/net-im/loudmouth/Makefile
@@ -23,19 +23,28 @@ USE_GETTEXT= yes
USE_AUTOTOOLS= libtool
USE_LDCONFIG= yes
USE_GNOME= gnomehack glib20 ltverhack
-CONFIGURE_ARGS= --disable-gtk-doc
+CONFIGURE_ARGS= --disable-gtk-doc --enable-debug=no
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LDFLAGS="-Wl,-Bsymbolic -L${LOCALBASE}/lib"
-OPTIONS= GNUTLS "Enable SSL (via GnuTLS) support" on
+OPTIONS= GNUTLS "Enable SSL (via GnuTLS) support" on \
+ OPENSSL "Enable SSL (via OpenSSL) support" off
.include <bsd.port.pre.mk>
-.if !defined(WITHOUT_GNUTLS)
-LIB_DEPENDS+= gnutls.40:${PORTSDIR}/security/gnutls
-RUN_DEPENDS+= ${LOCALBASE}/share/certs/ca-root-nss.crt:${PORTSDIR}/security/ca_root_nss
-.else
-CONFIGURE_ARGS+= --without-ssl
+.if defined(WITH_GNUTLS)
+LIB_DEPENDS+= gnutls.40:${PORTSDIR}/security/gnutls
+RUN_DEPENDS+= ${LOCALBASE}/share/certs/ca-root-nss.crt:${PORTSDIR}/security/ca_root_nss
+.endif
+
+.if defined(WITH_OPENSSL)
+USE_OPENSSL= yes
+CONFIGURE_ARGS+=--with-ssl=openssl
+RUN_DEPENDS+= ${LOCALBASE}/share/certs/ca-root-nss.crt:${PORTSDIR}/security/ca_root_nss
+.endif
+
+.if !defined(WITH_GNUTLS) && !defined(WITH_OPENSSL)
+CONFIGURE_ARGS+=--without-ssl
.endif
post-patch: