aboutsummaryrefslogtreecommitdiff
path: root/net-im/mikutter
diff options
context:
space:
mode:
authorTAKATSU Tomonari <tota@FreeBSD.org>2012-06-12 15:10:39 +0000
committerTAKATSU Tomonari <tota@FreeBSD.org>2012-06-12 15:10:39 +0000
commitbc53b57d23ca3d4f774cc3cfa85c08c64711488f (patch)
treebdd343137879792d40c5184246d4c7848ebec578 /net-im/mikutter
parent1cc19a47d197e896efc36f288c96770cbfaef92f (diff)
downloadports-bc53b57d23ca3d4f774cc3cfa85c08c64711488f.tar.gz
ports-bc53b57d23ca3d4f774cc3cfa85c08c64711488f.zip
- Convert to new options framework
Notes
Notes: svn path=/head/; revision=299114
Diffstat (limited to 'net-im/mikutter')
-rw-r--r--net-im/mikutter/Makefile19
1 files changed, 11 insertions, 8 deletions
diff --git a/net-im/mikutter/Makefile b/net-im/mikutter/Makefile
index 6ac10ff6192b..987e7676c0b1 100644
--- a/net-im/mikutter/Makefile
+++ b/net-im/mikutter/Makefile
@@ -45,19 +45,22 @@ SUB_LIST= RUBY_SITELIBDIR=${RUBY_SITELIBDIR}
PORTDOCS= README
PORTSCOUT= limit:^0\.0\.3\.[0-9]*
-OPTIONS= NOTIFY "notify-send support" on \
- HTTPCLIENT "httpclient support" on
+OPTIONS_DEFINE= HTTPCLIENT NOTIFY
+HTTPCLIENT_DESC= httpclient support
+NOTIFY_DESC= notify-send support
-.include <bsd.port.pre.mk>
+OPTIONS_DEFAULT= ${OPTIONS_DEFINE}
-.if defined(WITH_NOTIFY)
-RUN_DEPENDS+= notify-send:${PORTSDIR}/devel/libnotify
-.endif
+.include <bsd.port.options.mk>
-.if defined(WITH_HTTPCLIENT)
+.if ${PORT_OPTIONS:MHTTPCLIENT}
RUN_DEPENDS+= rubygem-httpclient>=0:${PORTSDIR}/www/rubygem-httpclient
.endif
+.if ${PORT_OPTIONS:MNOTIFY}
+RUN_DEPENDS+= notify-send:${PORTSDIR}/devel/libnotify
+.endif
+
post-patch:
@${REINPLACE_CMD} -e "50s|chdir\(.*\)|chdir\('${RUBY_SITELIBDIR}/mikutter/core'\)|" \
${WRKSRC}/mikutter.rb
@@ -89,4 +92,4 @@ x-generate-plist:
${ECHO} @exec ${MKDIR:S|/bin/||} %D/%%RUBY_SITELIBDIR%%/mikutter/core/hatsunelisp >> pkg-plist.new
${FIND} ${RUBY_SITELIBDIR}/mikutter -type d -depth | ${SORT} -r | ${SED} -e 's,${RUBY_SITELIBDIR},@dirrm %%RUBY_SITELIBDIR%%,' >> pkg-plist.new
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>