aboutsummaryrefslogtreecommitdiff
path: root/net-im/telepathy-butterfly
diff options
context:
space:
mode:
authorJoe Marcus Clarke <marcus@FreeBSD.org>2010-12-19 08:28:54 +0000
committerJoe Marcus Clarke <marcus@FreeBSD.org>2010-12-19 08:28:54 +0000
commitac44c7fc49782990105f200c022475f378f0bccc (patch)
treedc1e7868a71fb9d12f738d753d7fcd03a15980ca /net-im/telepathy-butterfly
parent105cf8eee6b6992373ab5e3c278de17e30cdb234 (diff)
downloadports-ac44c7fc49782990105f200c022475f378f0bccc.tar.gz
ports-ac44c7fc49782990105f200c022475f378f0bccc.zip
Fix a bug in the im module.
Notes
Notes: svn path=/head/; revision=266576
Diffstat (limited to 'net-im/telepathy-butterfly')
-rw-r--r--net-im/telepathy-butterfly/Makefile1
-rw-r--r--net-im/telepathy-butterfly/files/patch-butterfly_channel_im.py22
2 files changed, 23 insertions, 0 deletions
diff --git a/net-im/telepathy-butterfly/Makefile b/net-im/telepathy-butterfly/Makefile
index 32d787829fa9..f014c4f9a07d 100644
--- a/net-im/telepathy-butterfly/Makefile
+++ b/net-im/telepathy-butterfly/Makefile
@@ -8,6 +8,7 @@
PORTNAME= telepathy-butterfly
PORTVERSION= 0.5.15
+PORTREVISION= 1
CATEGORIES= net-im
MASTER_SITES= http://telepathy.freedesktop.org/releases/${PORTNAME}/
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
diff --git a/net-im/telepathy-butterfly/files/patch-butterfly_channel_im.py b/net-im/telepathy-butterfly/files/patch-butterfly_channel_im.py
new file mode 100644
index 000000000000..d539c5527ebb
--- /dev/null
+++ b/net-im/telepathy-butterfly/files/patch-butterfly_channel_im.py
@@ -0,0 +1,22 @@
+--- butterfly/channel/im.py.orig 2010-12-19 03:27:02.000000000 -0500
++++ butterfly/channel/im.py 2010-12-19 03:27:16.000000000 -0500
+@@ -30,7 +30,7 @@ import papyon.event
+
+ from butterfly.channel.text import ButterflyTextChannel
+
+-from butterfly.Channel_Interface_Conference import CHANNEL_INTERFACE_CONFERENCE
++#from butterfly.Channel_Interface_Conference import CHANNEL_INTERFACE_CONFERENCE
+
+ __all__ = ['ButterflyImChannel']
+
+@@ -144,8 +144,8 @@ class ButterflyImChannel(ButterflyTextCh
+ props = {
+ telepathy.CHANNEL + '.ChannelType': dbus.String(telepathy.CHANNEL_TYPE_TEXT),
+ telepathy.CHANNEL + '.TargetHandleType': dbus.UInt32(telepathy.HANDLE_TYPE_NONE),
+- CHANNEL_INTERFACE_CONFERENCE + '.InitialChannels': dbus.Array([self._object_path], signature='o'),
+- CHANNEL_INTERFACE_CONFERENCE + '.InitialInviteeIDs': dbus.Array([dbus.String(handle.get_name())], signature='s'),
++ telepathy.CHANNEL_INTERFACE_CONFERENCE + '.InitialChannels': dbus.Array([self._object_path], signature='o'),
++ telepathy.CHANNEL_INTERFACE_CONFERENCE + '.InitialInviteeIDs': dbus.Array([dbus.String(handle.get_name())], signature='s'),
+ telepathy.CHANNEL + '.Requested': dbus.Boolean(False)
+ }
+