aboutsummaryrefslogtreecommitdiff
path: root/net-im/telepathy-gabble/Makefile
diff options
context:
space:
mode:
authorKoop Mast <kwm@FreeBSD.org>2013-03-08 10:51:34 +0000
committerKoop Mast <kwm@FreeBSD.org>2013-03-08 10:51:34 +0000
commit7887c684adab042fed1bfcba2e91589ecd17c4a8 (patch)
tree961839899dce7f75292a08c079f548973bdbd40d /net-im/telepathy-gabble/Makefile
parent85544f2c01be814e0af1ebee1076012e7ed60bb0 (diff)
downloadports-7887c684adab042fed1bfcba2e91589ecd17c4a8.tar.gz
ports-7887c684adab042fed1bfcba2e91589ecd17c4a8.zip
* Update the glib to 2.34.3 and gtk20 to 2.24.17 and gtk30 to 3.6.4 which
are the latest stable releases. * Update vala to the newest stable release 0.18.1, also update a few ports in the gtk/gnome stack. * The c++ bindings ports for glib, atk, gconf, etc, have now USE_GNOME toggles. * Remove pkg-config run depends from glib20 and freetype2. This doesn't eliminate pkg-config run dependency completely, a second phase is needed and is planned. * Support for .:run. and .:build. for USE_GNOME components was added. Currently only libxml2 and libxslt support this mechanism. * Updates of the telepathy stack and empathy. * Trim makefile headers, convert ports to new options, trim off library versions for some ports. * Fix other ports so they build with the new glib version. Thanks to miwi and crees for helping out with some exp-runs. Approved by: portmgr (miwi & bapt) Obtained from: gnome team repo
Notes
Notes: svn path=/head/; revision=313633
Diffstat (limited to 'net-im/telepathy-gabble/Makefile')
-rw-r--r--net-im/telepathy-gabble/Makefile40
1 files changed, 17 insertions, 23 deletions
diff --git a/net-im/telepathy-gabble/Makefile b/net-im/telepathy-gabble/Makefile
index 038b3f80ee36..1f0e057bb7d2 100644
--- a/net-im/telepathy-gabble/Makefile
+++ b/net-im/telepathy-gabble/Makefile
@@ -1,43 +1,37 @@
-# New ports collection makefile for: telepathy-gabble
-# Date created: Apr 19 2007
-# Whom: Florent Thoumie <flz@FreeBSD.org>
-#
# $FreeBSD$
-# $MCom: ports/net-im/telepathy-gabble/Makefile,v 1.10 2010/11/14 16:18:09 marcus Exp $
+# $MCom: ports/net-im/telepathy-gabble/Makefile,v 1.22 2012/08/08 16:56:40 kwm Exp $
PORTNAME= telepathy-gabble
-PORTVERSION= 0.10.4
+PORTVERSION= 0.16.1
CATEGORIES= net-im
MASTER_SITES= http://telepathy.freedesktop.org/releases/${PORTNAME}/
MAINTAINER= gnome@FreeBSD.org
COMMENT= Jabber Connection Manager for Telepathy Framework
-LIB_PC_DEPENDS= gobject-2.0.pc:${PORTSDIR}/devel/glib20 \
- dbus-glib-1.pc:${PORTSDIR}/devel/dbus-glib \
- nice.pc:${PORTSDIR}/net-im/libnice \
- uuid.pc:${PORTSDIR}/misc/e2fsprogs-libuuid \
- telepathy-glib.pc:${PORTSDIR}/net-im/telepathy-glib \
- loudmouth-1.0.pc:${PORTSDIR}/net-im/loudmouth
-
-BUILD_DEPENDS= xsltproc:${PORTSDIR}/textproc/libxslt
-
-BUILD_DEPENDS+= ${LIB_PC_DEPENDS:C|^|${LOCALBASE}/libdata/pkgconfig/|g}
-LIB_DEPENDS= soup-2.4.1:${PORTSDIR}/devel/libsoup \
- sqlite3.8:${PORTSDIR}/databases/sqlite3
-RUN_DEPENDS+= ${LIB_PC_DEPENDS:C|^|${LOCALBASE}/libdata/pkgconfig/|g}
+BUILD_DEPENDS= xsltproc:${PORTSDIR}/textproc/libxslt \
+ telepathy-glib>=0.18.0:${PORTSDIR}/net-im/telepathy-glib \
+ ${LOCALBASE}/share/certs/ca-root-nss.crt:${PORTSDIR}/security/ca_root_nss
+LIB_DEPENDS= soup-2.4:${PORTSDIR}/devel/libsoup \
+ nice:${PORTSDIR}/net-im/libnice \
+ telepathy-glib:${PORTSDIR}/net-im/telepathy-glib \
+ dbus-glib-1:${PORTSDIR}/devel/dbus-glib \
+ uuid:${PORTSDIR}/misc/e2fsprogs-libuuid \
+ loudmouth-1:${PORTSDIR}/net-im/loudmouth
+RUN_DEPENDS= ${LOCALBASE}/share/certs/ca-root-nss.crt:${PORTSDIR}/security/ca_root_nss
GNU_CONFIGURE= yes
-CONFIGURE_ARGS= --disable-Werror
LDFLAGS+= ${PTHREAD_LIBS}
USE_GMAKE= yes
-USE_GNOME= gnomehack pkgconfig glib20
+USE_GNOME= gnomehack glib20
+USE_SQLITE= yes
USE_OPENSSL= yes
USE_PYTHON_BUILD= yes
+CONFIGURE_ARGS= --with-ca-certificates=${LOCALBASE}/share/certs/ca-root-nss.crt
MAN8= telepathy-gabble.8
-.include <bsd.port.pre.mk>
+PLIST_SUB= PVERSION=${PORTVERSION}
.if defined(WITH_OPENSSL_BASE)
CONFIGURE_ENV+= OPENSSL_LIBS="-L/usr/lib -ssl -crypto" OPENSSL_CFLAGS="-I/usr/include"
@@ -47,4 +41,4 @@ post-patch:
@${REINPLACE_CMD} -e 's|-Werror||g' \
${WRKSRC}/lib/ext/wocky/configure
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>