aboutsummaryrefslogtreecommitdiff
path: root/net-im/ttytter
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2009-03-22 15:03:57 +0000
committerMartin Wilke <miwi@FreeBSD.org>2009-03-22 15:03:57 +0000
commit5b4448bdb0235512e5113ec8c62873f8bca1e9cf (patch)
tree224f69096c321c369d7e1d620e8b1c73c3312467 /net-im/ttytter
parentb272b6bff70167f9206b173f32e10604d002ce83 (diff)
downloadports-5b4448bdb0235512e5113ec8c62873f8bca1e9cf.tar.gz
ports-5b4448bdb0235512e5113ec8c62873f8bca1e9cf.zip
TTYtter is a multi-functional, fully 100% text, Perl command line
Twitter client. It has the following features: * A fully interactive client with asynchronous background updates and commands. Use it over telnet, ssh or even a dummy terminal. Supports ANSI colour, hashtags and Twitter Search! * Works within your favourite environment: modify prompt and input methods for many popular window and session managers, or use a compatible readline library. Or don't: basic editing and screen management features built-in. * From the command line, use it to update your Twitter in shell scripts, from cron, and so on. * Supports standard timelines and automatically fetches direct messages. * Extensible using the -lib option. * Run detached in -daemon mode, and make your own Twitter bot! WWW: http://www.floodgap.com/software/ttytter/ PR: ports/132920 Submitted by: Julian C. Dunn <jdunn at aquezada.com>
Notes
Notes: svn path=/head/; revision=230666
Diffstat (limited to 'net-im/ttytter')
-rw-r--r--net-im/ttytter/Makefile43
-rw-r--r--net-im/ttytter/distinfo3
-rw-r--r--net-im/ttytter/pkg-descr17
3 files changed, 63 insertions, 0 deletions
diff --git a/net-im/ttytter/Makefile b/net-im/ttytter/Makefile
new file mode 100644
index 000000000000..c05d6ac898a1
--- /dev/null
+++ b/net-im/ttytter/Makefile
@@ -0,0 +1,43 @@
+# New ports collection makefile for: ttytter
+# Date created: 21 March 2009
+# Whom: Julian C. Dunn <jdunn@aquezada.com>
+#
+# $FreeBSD$
+
+PORTNAME= ttytter
+PORTVERSION= 0.9.4
+CATEGORIES= net-im
+MASTER_SITES= http://www.floodgap.com/software/ttytter/
+DISTFILES= ${PORTNAME}.txt
+EXTRACT_ONLY=
+
+MAINTAINER= jdunn@aquezada.com
+COMMENT= Command-line Twitter client in Perl
+
+RUN_DEPENDS= ${SITE_PERL}/Date/Parse.pm:${PORTSDIR}/devel/p5-TimeDate \
+ curl:${PORTSDIR}/ftp/curl
+
+NO_BUILD= yes
+USE_PERL5_RUN= yes
+
+OPTIONS= READLINE "Include rich readline support" on
+
+PLIST_FILES= bin/${PORTNAME}
+
+.include <bsd.port.pre.mk>
+
+.if defined(WITH_READLINE)
+RUN_DEPENDS+= ${SITE_PERL}/Term/ReadLine/Perl.pm:${PORTSDIR}/devel/p5-ReadLine-Perl
+.endif
+
+do-extract:
+ @${MKDIR} ${WRKSRC}
+ @${CP} ${DISTDIR}/${PORTNAME}.txt ${WRKSRC}/${PORTNAME}
+
+post-patch:
+ @${REINPLACE_CMD} -e 's|^\#!/usr/bin/perl|\#!${PERL}|' ${WRKSRC}/${PORTNAME}
+
+do-install:
+ ${INSTALL_SCRIPT} ${WRKSRC}/${PORTNAME} ${PREFIX}/bin
+
+.include <bsd.port.post.mk>
diff --git a/net-im/ttytter/distinfo b/net-im/ttytter/distinfo
new file mode 100644
index 000000000000..71c7d154bee3
--- /dev/null
+++ b/net-im/ttytter/distinfo
@@ -0,0 +1,3 @@
+MD5 (ttytter.txt) = 3654e88a176d8a716a4b85b90bb551cf
+SHA256 (ttytter.txt) = d2c9420eb257f3756ade37a0a71df5847ae3ebad3541d4649f19cbb136eb9042
+SIZE (ttytter.txt) = 65237
diff --git a/net-im/ttytter/pkg-descr b/net-im/ttytter/pkg-descr
new file mode 100644
index 000000000000..dc3981ebe395
--- /dev/null
+++ b/net-im/ttytter/pkg-descr
@@ -0,0 +1,17 @@
+TTYtter is a multi-functional, fully 100% text, Perl command line
+Twitter client. It has the following features:
+
+* A fully interactive client with asynchronous background updates and
+ commands. Use it over telnet, ssh or even a dummy terminal.
+ Supports ANSI colour, hashtags and Twitter Search!
+* Works within your favourite environment: modify prompt and input
+ methods for many popular window and session managers, or use a
+ compatible readline library. Or don't: basic editing and screen
+ management features built-in.
+* From the command line, use it to update your Twitter in shell scripts,
+ from cron, and so on.
+* Supports standard timelines and automatically fetches direct messages.
+* Extensible using the -lib option.
+* Run detached in -daemon mode, and make your own Twitter bot!
+
+WWW: http://www.floodgap.com/software/ttytter/