aboutsummaryrefslogtreecommitdiff
path: root/net-im
diff options
context:
space:
mode:
authorLi-Wen Hsu <lwhsu@FreeBSD.org>2009-05-17 07:57:39 +0000
committerLi-Wen Hsu <lwhsu@FreeBSD.org>2009-05-17 07:57:39 +0000
commit02cde29e352c2682afc76bb88c759ad485948c1b (patch)
treec68349cba32a05734aab31181c0c082c11e83591 /net-im
parent3f59a0daab1aa832d4f81d836973e36a218b5660 (diff)
downloadports-02cde29e352c2682afc76bb88c759ad485948c1b.tar.gz
ports-02cde29e352c2682afc76bb88c759ad485948c1b.zip
Add qq , tencent QQ for Linux.
PR: ports/133408 Submitted by: Kai Wang <kaiw27 at gmail.com>
Notes
Notes: svn path=/head/; revision=234063
Diffstat (limited to 'net-im')
-rw-r--r--net-im/Makefile1
-rw-r--r--net-im/qq/Makefile47
-rw-r--r--net-im/qq/distinfo3
-rw-r--r--net-im/qq/files/qq.sh.in4
-rw-r--r--net-im/qq/pkg-descr3
-rw-r--r--net-im/qq/pkg-plist4
6 files changed, 62 insertions, 0 deletions
diff --git a/net-im/Makefile b/net-im/Makefile
index 94e2e80bdd28..e3c649093db7 100644
--- a/net-im/Makefile
+++ b/net-im/Makefile
@@ -130,6 +130,7 @@
SUBDIR += py-xmpppy-irc
SUBDIR += py-xmpppy-yahoo
SUBDIR += pymsn
+ SUBDIR += qq
SUBDIR += qutim
SUBDIR += qwit
SUBDIR += rubygem-xmpp4r
diff --git a/net-im/qq/Makefile b/net-im/qq/Makefile
new file mode 100644
index 000000000000..736800964db8
--- /dev/null
+++ b/net-im/qq/Makefile
@@ -0,0 +1,47 @@
+# New ports collection makefile for: qq
+# Date created: 2009-04-05
+# Whom: Kai Wang <kaiw27@gmail.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= qq
+DISTVERSION= v1.0.2-beta1_i386
+CATEGORIES= net-im
+MASTER_SITES= http://dl_dir.qq.com/linuxqq/
+DISTNAME= linuxqq_${DISTVERSION}
+
+MAINTAINER= kaiw27@gmail.com
+COMMENT= Tencent QQ for Linux
+
+ONLY_FOR_ARCHS= i386 amd64
+USE_LINUX= yes
+USE_LINUX_APPS= gtk2 xorglibs
+NO_BUILD= yes
+
+QQDIR= libexec/qq
+PLIST_SUB+= QQDIR=${QQDIR}
+SUB_FILES= qq.sh
+SUB_LIST+= QQDIR=${QQDIR}
+
+.include <bsd.port.pre.mk>
+
+pre-fetch:
+ @${ECHO_MSG} ""
+ @${ECHO_MSG} "==============================================="
+ @${ECHO_MSG} "QQ requires linux_base-f8 ports infrastructure."
+ @${ECHO_MSG} "Press 'Ctrl-C' to stop now if you dont't have "
+ @${ECHO_MSG} "the right version installed. "
+ @${ECHO_MSG} ""
+ @${ECHO_MSG} "Please read ${PORTSDIR}/UPDATING for how to "
+ @${ECHO_MSG} "install the linux_base-f8 ports. "
+ @${ECHO_MSG} "==============================================="
+ @${ECHO_MSG} ""
+
+do-install:
+ @${MKDIR} ${PREFIX}/${QQDIR}
+ ${INSTALL_PROGRAM} ${WRKSRC}/qq ${PREFIX}/${QQDIR}/
+ ${INSTALL_DATA} ${WRKSRC}/res.db ${PREFIX}/${QQDIR}/
+ ${INSTALL_SCRIPT} ${WRKDIR}/qq.sh ${PREFIX}/bin/qq
+
+.include <bsd.port.post.mk>
diff --git a/net-im/qq/distinfo b/net-im/qq/distinfo
new file mode 100644
index 000000000000..7395763c8a6a
--- /dev/null
+++ b/net-im/qq/distinfo
@@ -0,0 +1,3 @@
+MD5 (linuxqq_v1.0.2-beta1_i386.tar.gz) = 86ad416b4d6f8d95d3f886d332bd4873
+SHA256 (linuxqq_v1.0.2-beta1_i386.tar.gz) = fefca909314a72b3a16c46a9f3788255ee58c5fd24f180b7d573416118000901
+SIZE (linuxqq_v1.0.2-beta1_i386.tar.gz) = 5029235
diff --git a/net-im/qq/files/qq.sh.in b/net-im/qq/files/qq.sh.in
new file mode 100644
index 000000000000..3fd91f1fb7d6
--- /dev/null
+++ b/net-im/qq/files/qq.sh.in
@@ -0,0 +1,4 @@
+#!/bin/sh
+
+cd %%PREFIX%%/%%QQDIR%%
+./qq
diff --git a/net-im/qq/pkg-descr b/net-im/qq/pkg-descr
new file mode 100644
index 000000000000..e2fc3020f7d8
--- /dev/null
+++ b/net-im/qq/pkg-descr
@@ -0,0 +1,3 @@
+This is the official Tencent QQ client for Linux.
+
+WWW: http://im.qq.com/qq/linux/
diff --git a/net-im/qq/pkg-plist b/net-im/qq/pkg-plist
new file mode 100644
index 000000000000..61a2844bd3c7
--- /dev/null
+++ b/net-im/qq/pkg-plist
@@ -0,0 +1,4 @@
+bin/qq
+%%QQDIR%%/qq
+%%QQDIR%%/res.db
+@dirrm %%QQDIR%%