aboutsummaryrefslogtreecommitdiff
path: root/net-im
diff options
context:
space:
mode:
authorThomas Zander <riggs@FreeBSD.org>2016-03-25 07:42:23 +0000
committerThomas Zander <riggs@FreeBSD.org>2016-03-25 07:42:23 +0000
commit1f19714d85fe2e77014fbd281a56b08c89f845e9 (patch)
tree3dda8781046840106d7cc0beef189c77dd7e41e9 /net-im
parent7372ba9f7a419d8209602eb72946817fd26a159d (diff)
downloadports-1f19714d85fe2e77014fbd281a56b08c89f845e9.tar.gz
ports-1f19714d85fe2e77014fbd281a56b08c89f845e9.zip
Update to upstream version 0.7.0.20160321
While on it: - Pet portlint PR: 208230 Submitted by: fidaj@ukr.net (maintainer)
Notes
Notes: svn path=/head/; revision=411822
Diffstat (limited to 'net-im')
-rw-r--r--net-im/uTox/Makefile7
-rw-r--r--net-im/uTox/distinfo4
-rw-r--r--net-im/uTox/files/patch-Makefile21
-rw-r--r--net-im/uTox/files/patch-src_ui.c21
4 files changed, 38 insertions, 15 deletions
diff --git a/net-im/uTox/Makefile b/net-im/uTox/Makefile
index dff9cc7a8b34..47a7740e7498 100644
--- a/net-im/uTox/Makefile
+++ b/net-im/uTox/Makefile
@@ -1,8 +1,7 @@
# $FreeBSD$
PORTNAME= uTox
-PORTVERSION= 0.5.1.20160121
-PORTREVISION= 2
+PORTVERSION= 0.7.0.20160321
CATEGORIES= net-im net-p2p
MAINTAINER= fidaj@ukr.net
@@ -23,7 +22,7 @@ RUN_DEPENDS= ${LOCALBASE}/lib/libtoxcore.a:${PORTSDIR}/net-im/tox
USE_GITHUB= yes
GH_ACCOUNT= GrayHatter
-GH_TAGNAME= b623d58
+GH_TAGNAME= 9524f98
USES= compiler:c11 desktop-file-utils gmake openal:al pkgconfig
USE_XORG= x11 xext xrender
@@ -37,7 +36,7 @@ DBUS_MAKE_ARGS_OFF= DBUS=0
post-patch:
@${REINPLACE_CMD} -e 's|$$(GIT_V)|${DISTVERSION}-${GH_TAGNAME}|' \
- -e 's|share/man|man|' ${WRKSRC}/${MAKEFILE}
+ -e 's|(DATAROOTDIR)/man|(PREFIX)/man|' ${WRKSRC}/${MAKEFILE}
pre-configure:
@(if [ ! -e "${LOCALBASE}/lib/libtoxav.so" ]; then \
diff --git a/net-im/uTox/distinfo b/net-im/uTox/distinfo
index 0d7d3b4447b0..64d055a6cf9b 100644
--- a/net-im/uTox/distinfo
+++ b/net-im/uTox/distinfo
@@ -1,2 +1,2 @@
-SHA256 (GrayHatter-uTox-0.5.1.20160121-b623d58_GH0.tar.gz) = eaaeccc253c6262b9316783ed51d87b9103bef54f5dbf60b4ef9f124a9a342c0
-SIZE (GrayHatter-uTox-0.5.1.20160121-b623d58_GH0.tar.gz) = 978712
+SHA256 (GrayHatter-uTox-0.7.0.20160321-9524f98_GH0.tar.gz) = 5e6a6023e63ec77f5378541ed5f03981aa8b71b5586d8b02b24335dfcc88a636
+SIZE (GrayHatter-uTox-0.7.0.20160321-9524f98_GH0.tar.gz) = 1986717
diff --git a/net-im/uTox/files/patch-Makefile b/net-im/uTox/files/patch-Makefile
index 2dc6d978f1d1..d14d9738a252 100644
--- a/net-im/uTox/files/patch-Makefile
+++ b/net-im/uTox/files/patch-Makefile
@@ -1,15 +1,18 @@
---- Makefile.orig 2015-12-29 12:13:36.418539000 +0200
-+++ Makefile 2015-12-29 12:16:20.089265000 +0200
-@@ -2,7 +2,7 @@
+--- Makefile.orig 2016-03-21 02:14:57 UTC
++++ Makefile
+@@ -2,9 +2,9 @@
# set to anything else to disable them
- DBUS = 1
- V4LCONVERT = 1
--FILTER_AUDIO = 0
-+FILTER_AUDIO = 1
- UNITY = 0
+ DBUS = 1
+ V4LCONVERT = 1
+-FILTER_AUDIO = 0
++FILTER_AUDIO = 1
+ UNITY = 0
+-XP = 0
++XP = 0
DEPS = libtoxav libtoxcore openal vpx libsodium
-@@ -50,6 +50,37 @@
+
+@@ -53,6 +53,37 @@ ifeq ($(UNAME_S), Linux)
TRAY_OBJ = icons/utox-128x128.o
TRAY_GEN = $(LD) -r -b binary icons/utox-128x128.png -o
diff --git a/net-im/uTox/files/patch-src_ui.c b/net-im/uTox/files/patch-src_ui.c
new file mode 100644
index 000000000000..0e496b11e771
--- /dev/null
+++ b/net-im/uTox/files/patch-src_ui.c
@@ -0,0 +1,21 @@
+--- src/ui.c.orig 2016-03-21 02:14:57 UTC
++++ src/ui.c
+@@ -275,16 +275,9 @@ static void draw_settings_header(int UNU
+ setfont(FONT_SELF_NAME);
+ drawstr(MAIN_LEFT + SCALE(10), SCALE(10), UTOX_SETTINGS);
+ #ifdef GIT_VERSION
+- int x = MAIN_LEFT + SCALE(10) + UTOX_STR_WIDTH(UTOX_SETTINGS) + SCALE(10);
++ int x = MAIN_LEFT + UTOX_SCALE(5 ) + UTOX_STR_WIDTH(UTOX_SETTINGS) + UTOX_SCALE(5 );
+ setfont(FONT_TEXT);
+- drawtext(x, SCALE(10), (uint8_t*)GIT_VERSION, strlen(GIT_VERSION));
+- char version_string[64];
+- int count;
+- count = snprintf(version_string, 64, "Core v%u.%u.%u ToxAV v%u.%u.%u ToxES v%u.%u.%u",
+- tox_version_major(), tox_version_minor(), tox_version_patch(),
+- toxav_version_major(), toxav_version_minor(), toxav_version_patch(),
+- toxes_version_major(), toxes_version_minor(), toxes_version_patch());
+- drawtextwidth_right(w, textwidth((char_t*)version_string, count), SCALE(10), (uint8_t*)version_string, strlen(version_string));
++ drawtext(x, UTOX_SCALE(5), (uint8_t*)GIT_VERSION, strlen(GIT_VERSION));
+ #endif
+ }
+