aboutsummaryrefslogtreecommitdiff
path: root/net-im
diff options
context:
space:
mode:
authorRaphael Kubo da Costa <rakuco@FreeBSD.org>2016-03-19 14:38:35 +0000
committerRaphael Kubo da Costa <rakuco@FreeBSD.org>2016-03-19 14:38:35 +0000
commit8f30c5e1b7a4429680fe0c8d3e25adedf92660c4 (patch)
treeef2e437626dc84508564d5e7cfde485da97de2dd /net-im
parentf5d9f759f0cdf0fb1982a687c6512e29a4ad17fa (diff)
downloadports-8f30c5e1b7a4429680fe0c8d3e25adedf92660c4.tar.gz
ports-8f30c5e1b7a4429680fe0c8d3e25adedf92660c4.zip
Add some upstream patches that properly declare all build dependencies.
The upcoming CMake 3.5.0 generates Makefiles that break parallel builds more often when the dependencies between each targets are not declared correctly. PR: 208033
Notes
Notes: svn path=/head/; revision=411407
Diffstat (limited to 'net-im')
-rw-r--r--net-im/telepathy-qt4/files/patch-git_1e1f53e921
-rw-r--r--net-im/telepathy-qt4/files/patch-git_7389dc920
2 files changed, 41 insertions, 0 deletions
diff --git a/net-im/telepathy-qt4/files/patch-git_1e1f53e9 b/net-im/telepathy-qt4/files/patch-git_1e1f53e9
new file mode 100644
index 000000000000..6b5bfc30de66
--- /dev/null
+++ b/net-im/telepathy-qt4/files/patch-git_1e1f53e9
@@ -0,0 +1,21 @@
+This commit is required to avoid occasional build failures in parallel builds
+especially after CMake 3.5.0.
+
+commit 1e1f53e9d91684918c34ec50392f86287e001a1e
+Author: Alexandr Akulich <akulichalexander@gmail.com>
+Date: Fri Jan 15 18:52:59 2016 +0500
+
+ BaseChannel: Reduced includes (doesn't depend on client stuff anymore).
+
+--- TelepathyQt/base-channel.cpp
++++ TelepathyQt/base-channel.cpp
+@@ -26,7 +26,8 @@
+
+ #include "TelepathyQt/_gen/base-channel.moc.hpp"
+ #include "TelepathyQt/_gen/base-channel-internal.moc.hpp"
+-#include "TelepathyQt/future-internal.h"
++#include "TelepathyQt/_gen/future-constants.h"
++#include "TelepathyQt/_gen/future-types.h"
+
+ #include "TelepathyQt/debug-internal.h"
+
diff --git a/net-im/telepathy-qt4/files/patch-git_7389dc9 b/net-im/telepathy-qt4/files/patch-git_7389dc9
new file mode 100644
index 000000000000..5d139473e6b1
--- /dev/null
+++ b/net-im/telepathy-qt4/files/patch-git_7389dc9
@@ -0,0 +1,20 @@
+This commit is required to avoid occasional build failures in parallel builds.
+
+commit 7389dc990c67d4269f3a79c924c054e87f2e4ac5
+Author: Alexandr Akulich <akulichalexander@gmail.com>
+Date: Fri, 15 Jan 2016 18:54:09 +0500
+
+ CMakeLists: Added missing service dependence.
+
+ telepathy-qt-service depends on generated stable and future types and consts.
+
+--- TelepathyQt/CMakeLists.txt
++++ TelepathyQt/CMakeLists.txt
+@@ -953,6 +953,7 @@ if(ENABLE_SERVICE_SUPPORT)
+ #endif (ENABLE_COMPILER_COVERAGE)
+ # lets build a static only library until we have a stable API/ABI
+ add_library(telepathy-qt${QT_VERSION_MAJOR}-service STATIC ${telepathy_qt_service_SRCS})
++ add_dependencies(telepathy-qt${QT_VERSION_MAJOR}-service stable-typesgen future-typesgen)
+
+ # generate service moc files
+ foreach(moc_src ${telepathy_qt_service_MOC_SRCS})