aboutsummaryrefslogtreecommitdiff
path: root/net-im
diff options
context:
space:
mode:
authorRaphael Kubo da Costa <rakuco@FreeBSD.org>2016-03-08 15:32:10 +0000
committerRaphael Kubo da Costa <rakuco@FreeBSD.org>2016-03-08 15:32:10 +0000
commitbb3589f9f9e5390b57c71bff92c92347d8a7f5f8 (patch)
tree87286db73761d8ded24d069bae83ccbbcd904590 /net-im
parentd09896ca58e5ab904bc3ae16266a7646e24728ff (diff)
downloadports-bb3589f9f9e5390b57c71bff92c92347d8a7f5f8.tar.gz
ports-bb3589f9f9e5390b57c71bff92c92347d8a7f5f8.zip
Update to 0.9.6.1.
With commits by yours truly, alonso@ and Adriaan de Groot <groot@kde.org>. Significant changes from a porting perspective: * Import upstream commit to make the port build with GStreamer 1.6+. * Drop a lot of unnecessary sed calls. Some of them were outdated, and some were replaced by USES=pathfix and new CMAKE_ARGS. * Switch to options target helpers. * Switch to an out-of-source CMake build. * Drop the EXAMPLES option. The examples shipped in this port are only buildable from within the telepathy-qt4 source tree.
Notes
Notes: svn path=/head/; revision=410619
Diffstat (limited to 'net-im')
-rw-r--r--net-im/telepathy-qt4/Makefile59
-rw-r--r--net-im/telepathy-qt4/distinfo4
-rw-r--r--net-im/telepathy-qt4/files/patch-git_ec4a3d679
-rw-r--r--net-im/telepathy-qt4/pkg-plist41
4 files changed, 136 insertions, 47 deletions
diff --git a/net-im/telepathy-qt4/Makefile b/net-im/telepathy-qt4/Makefile
index 85f82e416c3d..663894a4251a 100644
--- a/net-im/telepathy-qt4/Makefile
+++ b/net-im/telepathy-qt4/Makefile
@@ -1,9 +1,8 @@
# Created by: Alberto Villa <avilla@FreeBSD.org>
# $FreeBSD$
-# $MCom: ports/trunk/net-im/telepathy-qt4/Makefile 19955 2014-10-15 10:15:00Z gusi $
PORTNAME= telepathy-qt4
-PORTVERSION= 0.9.4
+PORTVERSION= 0.9.6.1
CATEGORIES= net-im
MASTER_SITES= http://telepathy.freedesktop.org/releases/${PORTNAME:C/4//}/
DISTNAME= ${PORTNAME:C/4//}-${PORTVERSION}
@@ -18,61 +17,39 @@ LIB_DEPENDS= libtelepathy-farstream.so:${PORTSDIR}/net-im/telepathy-farstream \
libtelepathy-glib.so:${PORTSDIR}/net-im/telepathy-glib
RUN_DEPENDS= ${PYTHON_SITELIBDIR}/_dbus_bindings.so:${PORTSDIR}/devel/py-dbus
+OPTIONS_DEFINE= DOCS
+
USE_GNOME= libxslt:build
USE_GSTREAMER= yes
USE_QT4= corelib dbus gui network qtestlib_build xml \
moc_build qmake_build rcc_build uic_build
-USES= cmake pkgconfig python:build
-CMAKE_ARGS= -DENABLE_FARSIGHT:BOOL=False \
+USES= cmake:outsource pathfix pkgconfig python:build
+CMAKE_ARGS= -DENABLE_EXAMPLES:BOOL=False \
+ -DENABLE_FARSIGHT:BOOL=False \
-DENABLE_FARSTREAM:BOOL=True \
- -DENABLE_TESTS:BOOL=False
+ -DENABLE_TESTS:BOOL=False \
+ -DDESIRED_QT_VERSION:STRING=4 \
+ -DQT_QMAKE_EXECUTABLE:FILEPATH=${QMAKE}
+USE_LDCONFIG= yes
+
+# Required because FindGObject.cmake is too old and uses the pkg-config values
+# directly (-lgobject-2.0 instead of /path/to/libgobject-2.0.so).
CXXFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
-USE_LDCONFIG= yes
+
+# We do not need Doxygen because the tarball already ships with prebuilt
+# documentation.
+CMAKE_ARGS+= -DDOXYGEN_EXECUTABLE:FILEPATH=""
PLIST_SUB= PORTVERSION="${PORTVERSION}"
PORTDOCS= AUTHORS ChangeLog HACKING NEWS README html
-PORTEXAMPLES= Makefile accounts cm contact-messenger extensions \
- file-transfer protocols roster stream-tubes
-
-.include <bsd.port.options.mk>
-
-.if ${PORT_OPTIONS:MEXAMPLES}
-CMAKE_ARGS+= -DENABLE_EXAMPLES:BOOL=True
-.else
-CMAKE_ARGS+= -DENABLE_EXAMPLES:BOOL=False
-.endif
-
-pre-configure:
- ${REINPLACE_CMD} -e '/FIND_PROGRAM/ s/qmake //' \
- ${WRKSRC}/cmake/modules/FindQt.cmake
- ${REINPLACE_CMD} -e '/^add_dependencies(doxygen-doc / d' \
- ${WRKSRC}/TelepathyQt/CMakeLists.txt
- ${REINPLACE_CMD} -e '/TelepathyQt.*\.pc/ s|pkgconfig|../libdata/pkgconfig|' \
- ${WRKSRC}/TelepathyQt/CMakeLists.txt
- ${REINPLACE_CMD} -e 's|LIB_INSTALL_DIR}/pkgconfig|LIB_INSTALL_DIR}/../libdata/pkgconfig|' \
- ${WRKSRC}/TelepathyQt/Farstream/CMakeLists.txt
-
-post-patch:
- @${REINPLACE_CMD} -e 's|farstream-0.1|farstream-0.2|g' \
- ${WRKSRC}/cmake/modules/FindFarstream.cmake
-
-post-install:
-.if ${PORT_OPTIONS:MDOCS}
+post-install-DOCS-on:
${MKDIR} ${STAGEDIR}${DOCSDIR}
cd ${WRKSRC} && ${CP} -R doc/html .
. for f in ${PORTDOCS}
cd ${WRKSRC} && ${COPYTREE_SHARE} ${f} ${STAGEDIR}${DOCSDIR}
. endfor
-.endif
-.if ${PORT_OPTIONS:MEXAMPLES}
- cd ${WRKSRC}/examples && ${RM} -rf */CMakeFiles */*.cmake */Makefile
- ${MKDIR} ${STAGEDIR}${EXAMPLESDIR}
-. for f in ${PORTEXAMPLES}
- cd ${WRKSRC}/examples && ${COPYTREE_SHARE} ${f} ${STAGEDIR}${EXAMPLESDIR}
-. endfor
-.endif
.include <bsd.port.mk>
diff --git a/net-im/telepathy-qt4/distinfo b/net-im/telepathy-qt4/distinfo
index 25e52d8098f9..adfa14111d0f 100644
--- a/net-im/telepathy-qt4/distinfo
+++ b/net-im/telepathy-qt4/distinfo
@@ -1,2 +1,2 @@
-SHA256 (telepathy-qt-0.9.4.tar.gz) = f1b1db3a9f96ece92df430a8de4d30317f4c58a06fe99e82cc2c6875791e61f2
-SIZE (telepathy-qt-0.9.4.tar.gz) = 5294554
+SHA256 (telepathy-qt-0.9.6.1.tar.gz) = 496eb4951ea9b181d7d68a2122a885474c4f73b519319496aa1b97d9b361a1f8
+SIZE (telepathy-qt-0.9.6.1.tar.gz) = 6067468
diff --git a/net-im/telepathy-qt4/files/patch-git_ec4a3d6 b/net-im/telepathy-qt4/files/patch-git_ec4a3d6
new file mode 100644
index 000000000000..3573f75b561c
--- /dev/null
+++ b/net-im/telepathy-qt4/files/patch-git_ec4a3d6
@@ -0,0 +1,79 @@
+Required for the port to build with GStreamer 1.6+.
+
+commit ec4a3d62b68a57254515f01fc5ea3325ffb1dbfb
+Author: Niels Ole Salscheider <niels_ole@salscheider-online.de>
+Date: Tue Sep 29 20:52:15 2015 +0200
+
+ Farstream: gst/gstconfig.h can be in LIBDIR, search for it explicitly
+
+ Since GStreamer-1.5.1 config header file moved to LIBDIR.
+
+ Reviewed-by: Alexandr Akulich <akulichalexander@gmail.com>
+
+--- TelepathyQt/Farstream/CMakeLists.txt
++++ TelepathyQt/Farstream/CMakeLists.txt
+@@ -2,7 +2,7 @@ if(FARSTREAM_COMPONENTS_FOUND)
+ include_directories(${TELEPATHY_FARSTREAM_INCLUDE_DIR}
+ ${TELEPATHY_GLIB_INCLUDE_DIR}
+ ${FARSTREAM_INCLUDE_DIR}
+- ${GSTREAMER_INCLUDE_DIR}
++ ${GSTREAMER_INCLUDE_DIRS}
+ ${GLIB2_INCLUDE_DIR}
+ ${LIBXML2_INCLUDE_DIR}
+ ${DBUS_INCLUDE_DIR})
+--- cmake/modules/FindGStreamer.cmake
++++ cmake/modules/FindGStreamer.cmake
+@@ -13,12 +13,12 @@
+
+ # TODO: Other versions --> GSTREAMER_X_Y_FOUND (Example: GSTREAMER_0_8_FOUND and GSTREAMER_0_10_FOUND etc)
+
+-IF (GSTREAMER_INCLUDE_DIR AND GSTREAMER_LIBRARIES AND GSTREAMER_BASE_LIBRARY AND GSTREAMER_INTERFACE_LIBRARY)
++IF (GSTREAMER_INCLUDE_DIRS AND GSTREAMER_LIBRARIES AND GSTREAMER_BASE_LIBRARY AND GSTREAMER_INTERFACE_LIBRARY)
+ # in cache already
+ SET(GSTREAMER_FIND_QUIETLY TRUE)
+-ELSE (GSTREAMER_INCLUDE_DIR AND GSTREAMER_LIBRARIES AND GSTREAMER_BASE_LIBRARY AND GSTREAMER_INTERFACE_LIBRARY)
++ELSE (GSTREAMER_INCLUDE_DIRS AND GSTREAMER_LIBRARIES AND GSTREAMER_BASE_LIBRARY AND GSTREAMER_INTERFACE_LIBRARY)
+ SET(GSTREAMER_FIND_QUIETLY FALSE)
+-ENDIF (GSTREAMER_INCLUDE_DIR AND GSTREAMER_LIBRARIES AND GSTREAMER_BASE_LIBRARY AND GSTREAMER_INTERFACE_LIBRARY)
++ENDIF (GSTREAMER_INCLUDE_DIRS AND GSTREAMER_LIBRARIES AND GSTREAMER_BASE_LIBRARY AND GSTREAMER_INTERFACE_LIBRARY)
+
+ IF (NOT WIN32)
+ # use pkg-config to get the directories and then use these values
+@@ -38,6 +38,15 @@ FIND_PATH(GSTREAMER_INCLUDE_DIR gst/gst.h
+ PATH_SUFFIXES gstreamer-1.0
+ )
+
++FIND_PATH(GSTREAMER_CONF_INCLUDE_DIR gst/gstconfig.h
++ PATHS
++ ${PC_GSTREAMER_INCLUDEDIR}
++ ${PC_GSTREAMER_INCLUDE_DIRS}
++ PATH_SUFFIXES gstreamer-1.0
++ )
++
++SET(GSTREAMER_INCLUDE_DIRS ${GSTREAMER_INCLUDE_DIR} ${GSTREAMER_CONF_INCLUDE_DIR})
++
+ FIND_LIBRARY(GSTREAMER_LIBRARIES NAMES gstreamer-1.0
+ PATHS
+ ${PC_GSTREAMER_LIBDIR}
+@@ -57,6 +66,12 @@ ELSE (GSTREAMER_INCLUDE_DIR)
+ MESSAGE(STATUS "GStreamer: WARNING: include dir not found")
+ ENDIF (GSTREAMER_INCLUDE_DIR)
+
++IF (GSTREAMER_CONF_INCLUDE_DIR)
++ #MESSAGE(STATUS "DEBUG: Found GStreamer config include dir: ${GSTREAMER_CONF_INCLUDE_DIR}")
++ELSE (GSTREAMER_CONF_INCLUDE_DIR)
++ MESSAGE(STATUS "GStreamer: WARNING: config include dir not found")
++ENDIF (GSTREAMER_CONF_INCLUDE_DIR)
++
+ IF (GSTREAMER_LIBRARIES)
+ #MESSAGE(STATUS "DEBUG: Found GStreamer library: ${GSTREAMER_LIBRARIES}")
+ ELSE (GSTREAMER_LIBRARIES)
+@@ -65,6 +80,6 @@ ENDIF (GSTREAMER_LIBRARIES)
+
+
+ INCLUDE(FindPackageHandleStandardArgs)
+-FIND_PACKAGE_HANDLE_STANDARD_ARGS(GStreamer DEFAULT_MSG GSTREAMER_LIBRARIES GSTREAMER_INCLUDE_DIR GSTREAMER_BASE_LIBRARY)
++FIND_PACKAGE_HANDLE_STANDARD_ARGS(GStreamer DEFAULT_MSG GSTREAMER_LIBRARIES GSTREAMER_INCLUDE_DIRS GSTREAMER_BASE_LIBRARY)
+
+-MARK_AS_ADVANCED(GSTREAMER_INCLUDE_DIR GSTREAMER_LIBRARIES GSTREAMER_BASE_LIBRARY)
++MARK_AS_ADVANCED(GSTREAMER_INCLUDE_DIRS GSTREAMER_LIBRARIES GSTREAMER_BASE_LIBRARY)
diff --git a/net-im/telepathy-qt4/pkg-plist b/net-im/telepathy-qt4/pkg-plist
index a5fbd46fffe5..9492dbec08ed 100644
--- a/net-im/telepathy-qt4/pkg-plist
+++ b/net-im/telepathy-qt4/pkg-plist
@@ -1,8 +1,11 @@
+include/telepathy-qt4/TelepathyQt/AbstractAdaptor
include/telepathy-qt4/TelepathyQt/AbstractClient
include/telepathy-qt4/TelepathyQt/AbstractClientApprover
include/telepathy-qt4/TelepathyQt/AbstractClientHandler
include/telepathy-qt4/TelepathyQt/AbstractClientObserver
+include/telepathy-qt4/TelepathyQt/AbstractDBusServiceInterface
include/telepathy-qt4/TelepathyQt/AbstractInterface
+include/telepathy-qt4/TelepathyQt/AbstractProtocolInterface
include/telepathy-qt4/TelepathyQt/Account
include/telepathy-qt4/TelepathyQt/AccountCapabilityFilter
include/telepathy-qt4/TelepathyQt/AccountFactory
@@ -19,6 +22,14 @@ include/telepathy-qt4/TelepathyQt/AndFilter
include/telepathy-qt4/TelepathyQt/AuthenticationTLSCertificateInterface
include/telepathy-qt4/TelepathyQt/AvatarData
include/telepathy-qt4/TelepathyQt/AvatarSpec
+include/telepathy-qt4/TelepathyQt/BaseCall
+include/telepathy-qt4/TelepathyQt/BaseChannel
+include/telepathy-qt4/TelepathyQt/BaseConnection
+include/telepathy-qt4/TelepathyQt/BaseConnectionManager
+include/telepathy-qt4/TelepathyQt/BaseProtocol
+include/telepathy-qt4/TelepathyQt/BaseProtocolAddressingInterface
+include/telepathy-qt4/TelepathyQt/BaseProtocolAvatarsInterface
+include/telepathy-qt4/TelepathyQt/BaseProtocolPresenceInterface
include/telepathy-qt4/TelepathyQt/CallChannel
include/telepathy-qt4/TelepathyQt/CallContent
include/telepathy-qt4/TelepathyQt/CallContentInterface
@@ -132,8 +143,11 @@ include/telepathy-qt4/TelepathyQt/ContactMessenger
include/telepathy-qt4/TelepathyQt/ContactSearchChannel
include/telepathy-qt4/TelepathyQt/DBus
include/telepathy-qt4/TelepathyQt/DBusDaemonInterface
+include/telepathy-qt4/TelepathyQt/DBusError
+include/telepathy-qt4/TelepathyQt/DBusObject
include/telepathy-qt4/TelepathyQt/DBusProxy
include/telepathy-qt4/TelepathyQt/DBusProxyFactory
+include/telepathy-qt4/TelepathyQt/DBusService
include/telepathy-qt4/TelepathyQt/DBusTubeChannel
include/telepathy-qt4/TelepathyQt/Debug
include/telepathy-qt4/TelepathyQt/DebugReceiver
@@ -225,6 +239,7 @@ include/telepathy-qt4/TelepathyQt/RequestableChannelClassSpec
include/telepathy-qt4/TelepathyQt/RequestableChannelClassSpecList
include/telepathy-qt4/TelepathyQt/RoomListChannel
include/telepathy-qt4/TelepathyQt/ServerAuthenticationChannel
+include/telepathy-qt4/TelepathyQt/ServiceTypes
include/telepathy-qt4/TelepathyQt/SharedPtr
include/telepathy-qt4/TelepathyQt/SimpleCallObserver
include/telepathy-qt4/TelepathyQt/SimpleObserver
@@ -260,7 +275,12 @@ include/telepathy-qt4/TelepathyQt/_gen/cli-media-stream-handler.h
include/telepathy-qt4/TelepathyQt/_gen/cli-properties.h
include/telepathy-qt4/TelepathyQt/_gen/cli-tls-certificate.h
include/telepathy-qt4/TelepathyQt/_gen/constants.h
+include/telepathy-qt4/TelepathyQt/_gen/svc-call.h
+include/telepathy-qt4/TelepathyQt/_gen/svc-channel.h
+include/telepathy-qt4/TelepathyQt/_gen/svc-connection-manager.h
+include/telepathy-qt4/TelepathyQt/_gen/svc-connection.h
include/telepathy-qt4/TelepathyQt/_gen/types.h
+include/telepathy-qt4/TelepathyQt/abstract-adaptor.h
include/telepathy-qt4/TelepathyQt/abstract-client.h
include/telepathy-qt4/TelepathyQt/abstract-interface.h
include/telepathy-qt4/TelepathyQt/account-capability-filter.h
@@ -272,6 +292,11 @@ include/telepathy-qt4/TelepathyQt/account-set.h
include/telepathy-qt4/TelepathyQt/account.h
include/telepathy-qt4/TelepathyQt/and-filter.h
include/telepathy-qt4/TelepathyQt/avatar.h
+include/telepathy-qt4/TelepathyQt/base-call.h
+include/telepathy-qt4/TelepathyQt/base-channel.h
+include/telepathy-qt4/TelepathyQt/base-connection-manager.h
+include/telepathy-qt4/TelepathyQt/base-connection.h
+include/telepathy-qt4/TelepathyQt/base-protocol.h
include/telepathy-qt4/TelepathyQt/call-channel.h
include/telepathy-qt4/TelepathyQt/call-content-media-description.h
include/telepathy-qt4/TelepathyQt/call-content.h
@@ -303,8 +328,11 @@ include/telepathy-qt4/TelepathyQt/contact-manager.h
include/telepathy-qt4/TelepathyQt/contact-messenger.h
include/telepathy-qt4/TelepathyQt/contact-search-channel.h
include/telepathy-qt4/TelepathyQt/contact.h
+include/telepathy-qt4/TelepathyQt/dbus-error.h
+include/telepathy-qt4/TelepathyQt/dbus-object.h
include/telepathy-qt4/TelepathyQt/dbus-proxy-factory.h
include/telepathy-qt4/TelepathyQt/dbus-proxy.h
+include/telepathy-qt4/TelepathyQt/dbus-service.h
include/telepathy-qt4/TelepathyQt/dbus-tube-channel.h
include/telepathy-qt4/TelepathyQt/dbus.h
include/telepathy-qt4/TelepathyQt/debug-receiver.h
@@ -366,6 +394,7 @@ include/telepathy-qt4/TelepathyQt/referenced-handles.h
include/telepathy-qt4/TelepathyQt/requestable-channel-class-spec.h
include/telepathy-qt4/TelepathyQt/room-list-channel.h
include/telepathy-qt4/TelepathyQt/server-authentication-channel.h
+include/telepathy-qt4/TelepathyQt/service-types.h
include/telepathy-qt4/TelepathyQt/shared-ptr.h
include/telepathy-qt4/TelepathyQt/simple-call-observer.h
include/telepathy-qt4/TelepathyQt/simple-observer.h
@@ -386,11 +415,15 @@ lib/cmake/TelepathyQt4/TelepathyQt4Targets-%%CMAKE_BUILD_TYPE%%.cmake
lib/cmake/TelepathyQt4/TelepathyQt4Targets.cmake
lib/cmake/TelepathyQt4Farstream/TelepathyQt4FarstreamConfig.cmake
lib/cmake/TelepathyQt4Farstream/TelepathyQt4FarstreamConfigVersion.cmake
-lib/libtelepathy-qt4.so
-lib/libtelepathy-qt4.so.2
-lib/libtelepathy-qt4.so.2.%%PORTVERSION%%
+lib/cmake/TelepathyQt4Service/TelepathyQt4ServiceConfig.cmake
+lib/cmake/TelepathyQt4Service/TelepathyQt4ServiceConfigVersion.cmake
lib/libtelepathy-qt4-farstream.so
lib/libtelepathy-qt4-farstream.so.2
lib/libtelepathy-qt4-farstream.so.2.%%PORTVERSION%%
-libdata/pkgconfig/TelepathyQt4Farstream.pc
+lib/libtelepathy-qt4-service.a
+lib/libtelepathy-qt4.so
+lib/libtelepathy-qt4.so.2
+lib/libtelepathy-qt4.so.2.%%PORTVERSION%%
libdata/pkgconfig/TelepathyQt4.pc
+libdata/pkgconfig/TelepathyQt4Farstream.pc
+libdata/pkgconfig/TelepathyQt4Service.pc