aboutsummaryrefslogtreecommitdiff
path: root/net-im
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2009-04-23 09:04:15 +0000
committerMartin Wilke <miwi@FreeBSD.org>2009-04-23 09:04:15 +0000
commit13bf4a0b690919fca5cf46f5259cc3287ff538c3 (patch)
treec8283c07bfd246f92d30980663616a1076bdae9e /net-im
parent17a51f02b8a404427f5ad29bd55de9d56b9fd56f (diff)
downloadports-13bf4a0b690919fca5cf46f5259cc3287ff538c3.tar.gz
ports-13bf4a0b690919fca5cf46f5259cc3287ff538c3.zip
Reminds you of your buddies birthday.
WWW: http://freakazoid.teamblind.de/2009/02/14/pidgin-birthday-reminder/ PR: ports/133651 Submitted by: Alexander Logvinov <ports at logvinov.com>
Notes
Notes: svn path=/head/; revision=232557
Diffstat (limited to 'net-im')
-rw-r--r--net-im/Makefile1
-rw-r--r--net-im/pidgin-birthday-reminder/Makefile30
-rw-r--r--net-im/pidgin-birthday-reminder/distinfo3
-rw-r--r--net-im/pidgin-birthday-reminder/pkg-descr3
-rw-r--r--net-im/pidgin-birthday-reminder/pkg-plist20
-rw-r--r--net-im/pidgin-birthday_reminder/Makefile30
-rw-r--r--net-im/pidgin-birthday_reminder/distinfo3
-rw-r--r--net-im/pidgin-birthday_reminder/pkg-descr3
-rw-r--r--net-im/pidgin-birthday_reminder/pkg-plist20
9 files changed, 113 insertions, 0 deletions
diff --git a/net-im/Makefile b/net-im/Makefile
index 4947478f4de9..94e2e80bdd28 100644
--- a/net-im/Makefile
+++ b/net-im/Makefile
@@ -107,6 +107,7 @@
SUBDIR += p5-POE-Component-Client-MSN
SUBDIR += pebrot
SUBDIR += pidgin
+ SUBDIR += pidgin-birthday_reminder
SUBDIR += pidgin-facebookchat
SUBDIR += pidgin-fetion
SUBDIR += pidgin-guifications
diff --git a/net-im/pidgin-birthday-reminder/Makefile b/net-im/pidgin-birthday-reminder/Makefile
new file mode 100644
index 000000000000..5ef1aa4ead70
--- /dev/null
+++ b/net-im/pidgin-birthday-reminder/Makefile
@@ -0,0 +1,30 @@
+# New ports collection makefile for: pidgin-birthday_reminder
+# Date created: 11 April 2009
+# Whom: Alexander Logvinov <ports@logvinov.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= birthday_reminder
+PORTVERSION= 1.0
+CATEGORIES= net-im
+MASTER_SITES= http://freakazoid.teamblind.de/wp-content/uploads/
+PKGNAMEPREFIX= pidgin-
+
+MAINTAINER= ports@logvinov.com
+COMMENT= The birthday reminder for Pidgin
+
+LIB_DEPENDS= purple.5:${PORTSDIR}/net-im/libpurple
+BUILD_DEPENDS= pidgin:${PORTSDIR}/net-im/pidgin
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+MAKE_JOBS_SAFE= yes
+
+GNU_CONFIGURE= yes
+USE_GMAKE= yes
+USE_GETTEXT= yes
+USE_GNOME= pkgconfig intltool
+CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
+ LDFLAGS="-L${LOCALBASE}/lib"
+
+.include <bsd.port.mk>
diff --git a/net-im/pidgin-birthday-reminder/distinfo b/net-im/pidgin-birthday-reminder/distinfo
new file mode 100644
index 000000000000..2ca8e54970f3
--- /dev/null
+++ b/net-im/pidgin-birthday-reminder/distinfo
@@ -0,0 +1,3 @@
+MD5 (birthday_reminder-1.0.tar.gz) = 7d3c75522c650cf713da8945a3b4ddb5
+SHA256 (birthday_reminder-1.0.tar.gz) = f9d8a0e12574afe1450f1cb288e239e84d246298df653023a9381948fca0237b
+SIZE (birthday_reminder-1.0.tar.gz) = 468265
diff --git a/net-im/pidgin-birthday-reminder/pkg-descr b/net-im/pidgin-birthday-reminder/pkg-descr
new file mode 100644
index 000000000000..7e46d367b851
--- /dev/null
+++ b/net-im/pidgin-birthday-reminder/pkg-descr
@@ -0,0 +1,3 @@
+Reminds you of your buddies birthday.
+
+WWW: http://freakazoid.teamblind.de/2009/02/14/pidgin-birthday-reminder/
diff --git a/net-im/pidgin-birthday-reminder/pkg-plist b/net-im/pidgin-birthday-reminder/pkg-plist
new file mode 100644
index 000000000000..4364dc355eba
--- /dev/null
+++ b/net-im/pidgin-birthday-reminder/pkg-plist
@@ -0,0 +1,20 @@
+lib/pidgin/birthday_reminder.so
+lib/pidgin/birthday_reminder.la
+lib/pidgin/birthday_reminder.a
+share/locale/de/LC_MESSAGES/birthday_reminder.mo
+share/pixmaps/pidgin/birthday_reminder/birthday0.png
+share/pixmaps/pidgin/birthday_reminder/birthday1.png
+share/pixmaps/pidgin/birthday_reminder/birthday2.png
+share/pixmaps/pidgin/birthday_reminder/birthday3.png
+share/pixmaps/pidgin/birthday_reminder/birthday4.png
+share/pixmaps/pidgin/birthday_reminder/birthday5.png
+share/pixmaps/pidgin/birthday_reminder/birthday6.png
+share/pixmaps/pidgin/birthday_reminder/birthday7.png
+share/pixmaps/pidgin/birthday_reminder/birthday8.png
+share/pixmaps/pidgin/birthday_reminder/birthday9.png
+share/sounds/pidgin/birthday_reminder/birthday.wav
+@dirrmtry share/sounds/pidgin/birthday_reminder
+@dirrmtry share/sounds/pidgin
+@dirrmtry share/pixmaps/pidgin/birthday_reminder
+@dirrmtry share/pixmaps/pidgin
+@dirrmtry lib/pidgin
diff --git a/net-im/pidgin-birthday_reminder/Makefile b/net-im/pidgin-birthday_reminder/Makefile
new file mode 100644
index 000000000000..5ef1aa4ead70
--- /dev/null
+++ b/net-im/pidgin-birthday_reminder/Makefile
@@ -0,0 +1,30 @@
+# New ports collection makefile for: pidgin-birthday_reminder
+# Date created: 11 April 2009
+# Whom: Alexander Logvinov <ports@logvinov.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= birthday_reminder
+PORTVERSION= 1.0
+CATEGORIES= net-im
+MASTER_SITES= http://freakazoid.teamblind.de/wp-content/uploads/
+PKGNAMEPREFIX= pidgin-
+
+MAINTAINER= ports@logvinov.com
+COMMENT= The birthday reminder for Pidgin
+
+LIB_DEPENDS= purple.5:${PORTSDIR}/net-im/libpurple
+BUILD_DEPENDS= pidgin:${PORTSDIR}/net-im/pidgin
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+MAKE_JOBS_SAFE= yes
+
+GNU_CONFIGURE= yes
+USE_GMAKE= yes
+USE_GETTEXT= yes
+USE_GNOME= pkgconfig intltool
+CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
+ LDFLAGS="-L${LOCALBASE}/lib"
+
+.include <bsd.port.mk>
diff --git a/net-im/pidgin-birthday_reminder/distinfo b/net-im/pidgin-birthday_reminder/distinfo
new file mode 100644
index 000000000000..2ca8e54970f3
--- /dev/null
+++ b/net-im/pidgin-birthday_reminder/distinfo
@@ -0,0 +1,3 @@
+MD5 (birthday_reminder-1.0.tar.gz) = 7d3c75522c650cf713da8945a3b4ddb5
+SHA256 (birthday_reminder-1.0.tar.gz) = f9d8a0e12574afe1450f1cb288e239e84d246298df653023a9381948fca0237b
+SIZE (birthday_reminder-1.0.tar.gz) = 468265
diff --git a/net-im/pidgin-birthday_reminder/pkg-descr b/net-im/pidgin-birthday_reminder/pkg-descr
new file mode 100644
index 000000000000..7e46d367b851
--- /dev/null
+++ b/net-im/pidgin-birthday_reminder/pkg-descr
@@ -0,0 +1,3 @@
+Reminds you of your buddies birthday.
+
+WWW: http://freakazoid.teamblind.de/2009/02/14/pidgin-birthday-reminder/
diff --git a/net-im/pidgin-birthday_reminder/pkg-plist b/net-im/pidgin-birthday_reminder/pkg-plist
new file mode 100644
index 000000000000..4364dc355eba
--- /dev/null
+++ b/net-im/pidgin-birthday_reminder/pkg-plist
@@ -0,0 +1,20 @@
+lib/pidgin/birthday_reminder.so
+lib/pidgin/birthday_reminder.la
+lib/pidgin/birthday_reminder.a
+share/locale/de/LC_MESSAGES/birthday_reminder.mo
+share/pixmaps/pidgin/birthday_reminder/birthday0.png
+share/pixmaps/pidgin/birthday_reminder/birthday1.png
+share/pixmaps/pidgin/birthday_reminder/birthday2.png
+share/pixmaps/pidgin/birthday_reminder/birthday3.png
+share/pixmaps/pidgin/birthday_reminder/birthday4.png
+share/pixmaps/pidgin/birthday_reminder/birthday5.png
+share/pixmaps/pidgin/birthday_reminder/birthday6.png
+share/pixmaps/pidgin/birthday_reminder/birthday7.png
+share/pixmaps/pidgin/birthday_reminder/birthday8.png
+share/pixmaps/pidgin/birthday_reminder/birthday9.png
+share/sounds/pidgin/birthday_reminder/birthday.wav
+@dirrmtry share/sounds/pidgin/birthday_reminder
+@dirrmtry share/sounds/pidgin
+@dirrmtry share/pixmaps/pidgin/birthday_reminder
+@dirrmtry share/pixmaps/pidgin
+@dirrmtry lib/pidgin