aboutsummaryrefslogtreecommitdiff
path: root/net-im
diff options
context:
space:
mode:
authorDavid Thiel <lx@FreeBSD.org>2011-04-11 20:24:00 +0000
committerDavid Thiel <lx@FreeBSD.org>2011-04-11 20:24:00 +0000
commitf8272a5a5927e4f15bc9306851e2de9e3e847680 (patch)
treecfffeb6345969b8bbeb99942dec0aa16f442b361 /net-im
parentf4aed7878c19996b62ba6fe4ac74240d4b38cf5d (diff)
downloadports-f8272a5a5927e4f15bc9306851e2de9e3e847680.tar.gz
ports-f8272a5a5927e4f15bc9306851e2de9e3e847680.zip
Update to 0.8.0.
PR: ports/156308 Submitted by: nico <nico@lifeisabug.com>
Notes
Notes: svn path=/head/; revision=272544
Diffstat (limited to 'net-im')
-rw-r--r--net-im/prosody/Makefile5
-rw-r--r--net-im/prosody/distinfo4
-rw-r--r--net-im/prosody/files/patch-Makefile9
-rw-r--r--net-im/prosody/files/patch-configure87
-rw-r--r--net-im/prosody/files/patch-prosody.cfg.lua.dist11
-rw-r--r--net-im/prosody/files/patch-prosodyctl23
-rw-r--r--net-im/prosody/files/patch-util-src-Makefile11
-rw-r--r--net-im/prosody/pkg-plist26
8 files changed, 67 insertions, 109 deletions
diff --git a/net-im/prosody/Makefile b/net-im/prosody/Makefile
index 9bf92a65083e..32560b40e71f 100644
--- a/net-im/prosody/Makefile
+++ b/net-im/prosody/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= prosody
-PORTVERSION= 0.7.0
-PORTREVISION= 1
+PORTVERSION= 0.8.0
CATEGORIES= net-im
MASTER_SITES= http://prosody.im/downloads/source/ \
http://redundancy.redundancy.org/mirror/
@@ -37,7 +36,7 @@ SUB_FILES= pkg-install pkg-deinstall
pre-install:
${SH} ${PKGINSTALL} ${PKGNAME} PRE-INSTALL
- ${REINPLACE_CMD} -e 's|/usr/bin/env lua|${LUA_CMD}|' ${WRKSRC}/prosody.install ${WRKSRC}/prosodyctl.install
+ ${REINPLACE_CMD} -e 's|/usr/bin/env lua|${LUA_CMD}|' ${WRKSRC}/prosody ${WRKSRC}/prosodyctl
post-install:
${SH} ${PKGINSTALL} ${PKGNAME} POST-INSTALL
diff --git a/net-im/prosody/distinfo b/net-im/prosody/distinfo
index 4a5d27f4891d..97a664a583e1 100644
--- a/net-im/prosody/distinfo
+++ b/net-im/prosody/distinfo
@@ -1,2 +1,2 @@
-SHA256 (prosody-0.7.0.tar.gz) = a8b826805dd55282706c5683c2028899b3721eb0f84d3e35c0509a6c1bc32390
-SIZE (prosody-0.7.0.tar.gz) = 177412
+SHA256 (prosody-0.8.0.tar.gz) = 0b9e39a6b555b4c848af288f27107e99b1480d9733556a2c9b3a9f249eba602d
+SIZE (prosody-0.8.0.tar.gz) = 210945
diff --git a/net-im/prosody/files/patch-Makefile b/net-im/prosody/files/patch-Makefile
index 5070130de0e2..dffe197584fb 100644
--- a/net-im/prosody/files/patch-Makefile
+++ b/net-im/prosody/files/patch-Makefile
@@ -1,5 +1,5 @@
---- Makefile.orig 2010-06-12 17:23:01.000000000 -0700
-+++ Makefile 2010-11-24 11:29:05.873218722 -0800
+--- ./Makefile.orig 2011-04-05 15:47:05.000000000 +0200
++++ ./Makefile 2011-04-10 18:09:24.000000000 +0200
@@ -6,7 +6,7 @@
MODULES = $(DESTDIR)$(PREFIX)/lib/prosody/modules
SOURCE = $(DESTDIR)$(PREFIX)/lib/prosody
@@ -9,14 +9,15 @@
INSTALLEDSOURCE = $(PREFIX)/lib/prosody
INSTALLEDCONFIG = $(SYSCONFDIR)
-@@ -33,10 +33,11 @@
+@@ -33,11 +33,12 @@
install -m644 plugins/*.lua $(MODULES)
install -d $(MODULES)/muc
install -m644 plugins/muc/* $(MODULES)/muc
- install -m644 certs/* $(CONFIG)/certs
+ install -m644 certs/localhost.cert $(CONFIG)/certs/localhost.cert.sample
+ install -m644 certs/localhost.key $(CONFIG)/certs/localhost.key.sample
- install -m644 plugins/*.lua $(MODULES)
+ install -d $(MODULES)/adhoc
+ install -m644 plugins/adhoc/*.lua $(MODULES)/adhoc
install -m644 man/prosodyctl.man $(MAN)/man1/prosodyctl.1
- test -e $(CONFIG)/prosody.cfg.lua || install -m644 prosody.cfg.lua.install $(CONFIG)/prosody.cfg.lua
+ install -m644 prosody.cfg.lua.install $(CONFIG)/prosody.cfg.lua.sample
diff --git a/net-im/prosody/files/patch-configure b/net-im/prosody/files/patch-configure
index c7bb6ca14479..bd39d9a544e9 100644
--- a/net-im/prosody/files/patch-configure
+++ b/net-im/prosody/files/patch-configure
@@ -1,89 +1,10 @@
---- configure.orig 2010-06-12 17:23:01.000000000 -0700
-+++ configure 2010-11-24 11:15:06.435111085 -0800
-@@ -2,20 +2,19 @@
+--- ./configure.orig 2011-04-05 15:47:05.000000000 +0200
++++ ./configure 2011-04-10 18:09:24.000000000 +0200
+@@ -2,7 +2,6 @@
# Defaults
-PREFIX=/usr/local
-+#PREFIX=/usr/local
SYSCONFDIR="$PREFIX/etc/prosody"
DATADIR="$PREFIX/var/lib/prosody"
--LUA_SUFFIX=""
--LUA_DIR="/usr"
--LUA_BINDIR="/usr/bin"
--LUA_INCDIR="/usr/include"
--LUA_LIBDIR="/usr/lib"
-+LUA_DIR="$PREFIX"
-+LUA_BINDIR="$PREFIX/bin"
-+#LUA_INCDIR="/usr/include"
-+#LUA_LIBDIR="/usr/lib"
- IDN_LIB=idn
- OPENSSL_LIB=crypto
--CC=gcc
-+#CC=gcc
- LD=gcc
-
--CFLAGS="-fPIC -Wall"
-+#CFLAGS="-fPIC -Wall"
- LDFLAGS="-shared"
-
- # Help
-@@ -26,7 +25,7 @@
-
- --help This help.
- --ostype=OS Use one of the OS presets.
-- May be one of: debian, macosx, linux
-+ May be one of: debian, macosx, linux, freebsd
- --prefix=DIR Prefix where Prosody should be installed.
- Default is $PREFIX
- --sysconfdir=DIR Location where the config file should be installed.
-@@ -142,22 +141,24 @@
- LUA_INCDIR=/usr/include/lua5.1;
- LUA_INCDIR_SET=yes
- fi
-- if [ "$OSTYPE" = "macosx" ]
-- then LUA_INCDIR=/usr/local/include;
-+ if [ "$OSTYPE" = "linux" ]
-+ then LUA_INCDIR=/usr/local/include;
-+ LUA_INCDIR_SET=yes
-+ LUA_LIBDIR=/usr/local/lib
-+ LUA_LIBDIR_SET=yes
-+ CFLAGS="-Wall -fPIC"
-+ LDFLAGS="-shared"
-+ fi
-+
-+ if [ "$OSTYPE" = "freebsd" ]
-+ then
- LUA_INCDIR_SET=yes
-- LUA_LIBDIR=/usr/local/lib
- LUA_LIBDIR_SET=yes
-- CFLAGS="-Wall"
-- LDFLAGS="-bundle -undefined dynamic_lookup"
-+ CFLAGS="-fPIC -D_POSIX_SOURCE -I${LOCALBASE}/include"
-+ LFLAGS="-lm -shared -L${LOCALBASE}/lib"
-+ LUA_SUFFIX_SET=yes
-+ LUA_LIB=lua
- fi
-- if [ "$OSTYPE" = "linux" ]
-- then LUA_INCDIR=/usr/local/include;
-- LUA_INCDIR_SET=yes
-- LUA_LIBDIR=/usr/local/lib
-- LUA_LIBDIR_SET=yes
-- CFLAGS="-Wall -fPIC"
-- LDFLAGS="-shared"
-- fi
- fi
-
- if [ "$PREFIX_SET" = "yes" -a ! "$SYSCONFDIR_SET" = "yes" ]
-@@ -306,9 +307,9 @@
- REQUIRE_CONFIG=$REQUIRE_CONFIG
- IDN_LIB=$IDN_LIB
- OPENSSL_LIB=$OPENSSL_LIB
--CFLAGS=$CFLAGS
-+CFLAGS+=$CFLAGS
- LDFLAGS=$LDFLAGS
--CC=$CC
-+CC?=$CC
- LD=$LD
-
- EOF
+ LUA_SUFFIX=""
diff --git a/net-im/prosody/files/patch-prosody.cfg.lua.dist b/net-im/prosody/files/patch-prosody.cfg.lua.dist
new file mode 100644
index 000000000000..5c392b1c5017
--- /dev/null
+++ b/net-im/prosody/files/patch-prosody.cfg.lua.dist
@@ -0,0 +1,11 @@
+--- prosody.cfg.lua.dist.orig 2011-04-11 13:21:41.498385123 -0700
++++ prosody.cfg.lua.dist 2011-04-11 13:21:51.387828331 -0700
+@@ -59,7 +59,7 @@
+ --"admin_telnet"; -- Opens telnet console interface on localhost port 5582
+
+ -- Other specific functionality
+- --"posix"; -- POSIX functionality, sends server to background, enables syslog, etc.
++ "posix"; -- POSIX functionality, sends server to background, enables syslog, etc.
+ --"bosh"; -- Enable BOSH clients, aka "Jabber over HTTP"
+ --"httpserver"; -- Serve static files from a directory over HTTP
+ --"groups"; -- Shared roster support
diff --git a/net-im/prosody/files/patch-prosodyctl b/net-im/prosody/files/patch-prosodyctl
new file mode 100644
index 000000000000..be367ec28c29
--- /dev/null
+++ b/net-im/prosody/files/patch-prosodyctl
@@ -0,0 +1,23 @@
+--- ./prosodyctl.orig 2011-04-05 15:47:06.000000000 +0200
++++ ./prosodyctl 2011-04-10 18:10:17.000000000 +0200
+@@ -53,11 +53,6 @@
+ };
+ _G.prosody = prosody;
+
+-local dependencies = require "util.dependencies";
+-if not dependencies.check_dependencies() then
+- os.exit(1);
+-end
+-
+ config = require "core.configmanager"
+
+ do
+@@ -121,8 +116,6 @@
+
+ require "core.loggingmanager"
+
+-dependencies.log_warnings();
+-
+ -- Switch away from root and into the prosody user --
+ local switched_user, current_uid;
+
diff --git a/net-im/prosody/files/patch-util-src-Makefile b/net-im/prosody/files/patch-util-src-Makefile
deleted file mode 100644
index cc392c6b2b6f..000000000000
--- a/net-im/prosody/files/patch-util-src-Makefile
+++ /dev/null
@@ -1,11 +0,0 @@
---- util-src/Makefile.orig 2010-12-06 12:33:26.434094017 -0800
-+++ util-src/Makefile 2010-12-06 12:33:39.599095155 -0800
-@@ -16,7 +16,7 @@
-
- .o.so:
- MACOSX_DEPLOYMENT_TARGET="10.3"; export MACOSX_DEPLOYMENT_TARGET;
-- $(LD) $(LDFLAGS) -o $@ $< -L$(LUA_LIBDIR) -llua$(LUA_SUFFIX) -lidn -lcrypto
-+ $(LD) $(LDFLAGS) -o $@ $< -L$(LUA_LIBDIR) -L${LOCALBASE}/lib -llua$(LUA_SUFFIX) -lidn -lcrypto
-
- all: encodings.so hashes.so pposix.so signal.so
-
diff --git a/net-im/prosody/pkg-plist b/net-im/prosody/pkg-plist
index 74a156cde7af..16d434a0afca 100644
--- a/net-im/prosody/pkg-plist
+++ b/net-im/prosody/pkg-plist
@@ -12,24 +12,30 @@ etc/prosody/certs/localhost.key.sample
@dirrmtry etc/prosody/certs
@dirrmtry etc/prosody
lib/prosody/core/certmanager.lua
-lib/prosody/core/componentmanager.lua
lib/prosody/core/configmanager.lua
-lib/prosody/core/eventmanager.lua
lib/prosody/core/hostmanager.lua
lib/prosody/core/loggingmanager.lua
lib/prosody/core/modulemanager.lua
-lib/prosody/core/offlinemanager.lua
lib/prosody/core/rostermanager.lua
lib/prosody/core/s2smanager.lua
lib/prosody/core/sessionmanager.lua
lib/prosody/core/stanza_router.lua
+lib/prosody/core/storagemanager.lua
lib/prosody/core/usermanager.lua
-lib/prosody/core/xmlhandlers.lua
+lib/prosody/modules/mod_admin_adhoc.lua
+lib/prosody/modules/mod_admin_telnet.lua
+lib/prosody/modules/mod_auth_anonymous.lua
+lib/prosody/modules/mod_auth_cyrus.lua
+lib/prosody/modules/mod_auth_internal_hashed.lua
+lib/prosody/modules/mod_auth_internal_plain.lua
+lib/prosody/modules/mod_motd.lua
+lib/prosody/modules/mod_offline.lua
+lib/prosody/modules/mod_storage_internal.lua
+lib/prosody/modules/mod_storage_sql.lua
lib/prosody/modules/mod_announce.lua
lib/prosody/modules/mod_bosh.lua
lib/prosody/modules/mod_component.lua
lib/prosody/modules/mod_compression.lua
-lib/prosody/modules/mod_console.lua
lib/prosody/modules/mod_dialback.lua
lib/prosody/modules/mod_disco.lua
lib/prosody/modules/mod_groups.lua
@@ -57,6 +63,8 @@ lib/prosody/modules/mod_watchregistrations.lua
lib/prosody/modules/mod_welcome.lua
lib/prosody/modules/muc/mod_muc.lua
lib/prosody/modules/muc/muc.lib.lua
+lib/prosody/modules/adhoc/adhoc.lib.lua
+lib/prosody/modules/adhoc/mod_adhoc.lua
lib/prosody/net/adns.lua
lib/prosody/net/connlisteners.lua
lib/prosody/net/dns.lua
@@ -91,6 +99,12 @@ lib/prosody/util/multitable.lua
lib/prosody/util/pluginloader.lua
lib/prosody/util/pposix.so
lib/prosody/util/prosodyctl.lua
+lib/prosody/util/caps.lua
+lib/prosody/util/filters.lua
+lib/prosody/util/httpstream.lua
+lib/prosody/util/json.lua
+lib/prosody/util/template.lua
+lib/prosody/util/xmppstream.lua
lib/prosody/util/sasl.lua
lib/prosody/util/sasl/anonymous.lua
lib/prosody/util/sasl/digest-md5.lua
@@ -105,10 +119,10 @@ lib/prosody/util/termcolours.lua
lib/prosody/util/timer.lua
lib/prosody/util/uuid.lua
lib/prosody/util/xmlrpc.lua
-lib/prosody/util/ztact.lua
@dirrm lib/prosody/util/sasl
@dirrm lib/prosody/util
@dirrm lib/prosody/net
+@dirrm lib/prosody/modules/adhoc
@dirrm lib/prosody/modules/muc
@dirrm lib/prosody/modules
@dirrm lib/prosody/core