aboutsummaryrefslogtreecommitdiff
path: root/net-im
diff options
context:
space:
mode:
authorThierry Thomas <thierry@FreeBSD.org>2015-02-05 18:38:18 +0000
committerThierry Thomas <thierry@FreeBSD.org>2015-02-05 18:38:18 +0000
commit673551dbd17d84e87d63772e3ac39afe8f26f08b (patch)
treed20754b71bd311c50562620614091471a13c9845 /net-im
parentef9dbfdeb05bf0ceb40f4ede172b15e8a6679124 (diff)
downloadports-673551dbd17d84e87d63772e3ac39afe8f26f08b.tar.gz
ports-673551dbd17d84e87d63772e3ac39afe8f26f08b.zip
Update to git20150204 v0.2.l .
PR: ports/197347 Submitted by: Ivan Klymenko (maintainer)
Notes
Notes: svn path=/head/; revision=378483
Diffstat (limited to 'net-im')
-rw-r--r--net-im/uTox/Makefile7
-rw-r--r--net-im/uTox/distinfo4
-rw-r--r--net-im/uTox/files/patch-Makefile21
3 files changed, 27 insertions, 5 deletions
diff --git a/net-im/uTox/Makefile b/net-im/uTox/Makefile
index 761691e3acbf..44a77e7f4c1e 100644
--- a/net-im/uTox/Makefile
+++ b/net-im/uTox/Makefile
@@ -1,7 +1,7 @@
# $FreeBSD$
PORTNAME= uTox
-DISTVERSION= 0.1.9.git20150114
+DISTVERSION= 0.2.l.git20150204
CATEGORIES= net-im net-p2p
MAINTAINER= fidaj@ukr.net
@@ -15,14 +15,15 @@ BUILD_DEPENDS= ${LOCALBASE}/lib/libtoxcore.a:${PORTSDIR}/net-im/tox \
LIB_DEPENDS= libfreetype.so:${PORTSDIR}/print/freetype2 \
libfontconfig.so:${PORTSDIR}/x11-fonts/fontconfig \
libv4lconvert.so:${PORTSDIR}/multimedia/libv4l \
- libvpx.so:${PORTSDIR}/multimedia/libvpx
+ libvpx.so:${PORTSDIR}/multimedia/libvpx \
+ libfilteraudio.so:${PORTSDIR}/audio/filter_audio
RUN_DEPENDS= ${LOCALBASE}/lib/libtoxcore.a:${PORTSDIR}/net-im/tox
USE_GITHUB= yes
GH_ACCOUNT= notsecure
GH_PROJECT= ${PORTNAME}
GH_TAGNAME= ${GH_COMMIT}
-GH_COMMIT= a78a756
+GH_COMMIT= 621727d
USES= compiler:c11 desktop-file-utils gmake openal:al pkgconfig
USE_XORG= x11 xext xrender
diff --git a/net-im/uTox/distinfo b/net-im/uTox/distinfo
index 2006b3176ecb..e38b7ecd8c62 100644
--- a/net-im/uTox/distinfo
+++ b/net-im/uTox/distinfo
@@ -1,2 +1,2 @@
-SHA256 (uTox-0.1.9.git20150114.tar.gz) = 13ecdc34efd0cec358301c5c3cdf24f9e2bac2ff8941fd621ebe108301e3394c
-SIZE (uTox-0.1.9.git20150114.tar.gz) = 744372
+SHA256 (uTox-0.2.l.git20150204.tar.gz) = c66f1d9751bcfa3d82e7b895dc52cb200a761f11bd4e7d3a957b2c4bfd519dc5
+SIZE (uTox-0.2.l.git20150204.tar.gz) = 753374
diff --git a/net-im/uTox/files/patch-Makefile b/net-im/uTox/files/patch-Makefile
new file mode 100644
index 000000000000..b2c53e4e61cc
--- /dev/null
+++ b/net-im/uTox/files/patch-Makefile
@@ -0,0 +1,21 @@
+--- Makefile.orig 2015-01-28 12:42:36.939246000 +0200
++++ Makefile 2015-01-28 12:44:04.733423000 +0200
+@@ -15,10 +15,6 @@
+ DEPS += libv4lconvert
+ endif
+
+-ifeq ($(FILTER_AUDIO), 1)
+- DEPS += filteraudio
+-endif
+-
+ UNAME_S := $(shell uname -s)
+
+ CFLAGS += -g -Wall -Wshadow -pthread -std=gnu99
+@@ -36,6 +32,7 @@
+
+ ifeq ($(FILTER_AUDIO), 1)
+ CFLAGS += -DAUDIO_FILTERING
++ LDFLAGS += -lfilteraudio
+ endif
+
+ ifeq ($(UNAME_S), Linux)